質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

TensorFlowがimportできない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 299

piyotechi

score 15

機械学習をやろうと思いTensorFlowをpipにてインストールしたのですが、importできません。
最新でインストールしたところ、ver2.1.0でインストールされコンソールでimportしたところ、
以下サイトと同じエラーが出ました。
リンク内容
サイト通りver2.0.0で再インストールしたのですが、importするとカーネルが停止してしまいます。
解決方法が分かります方にお知恵をお借りしたいです。

python3.7
spyder4.1.3
wiondows10
プロセッサ Intel(R)Core(TM)i5-6200U CPU @2.30GHz 2.40GHz

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • piyotechi

    2020/07/27 09:17

    osはwindows10でpip install tensorflowでインストールしました。
    ログはtensorflow2.2.0のとき(質問本文では2.1.0となっていますが誤記です)
    ImportError: Traceback (most recent call last):
    File "C:\Users\I06136\AppData\Local\Continuum\anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow.py", line 58, in <module>
    from tensorflow.python.pywrap_tensorflow_internal import *
    File "C:\Users\I06136\AppData\Local\Continuum\anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow_internal.py", line 28, in <module>
    _pywrap_tensorflow_internal = swig_import_helper()
    File "C:\Users\I06136\AppData\Local\Continuum\anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow_internal.py", line 24, in swig_import_helper
    _mod = imp.load_module('_pywrap_tensorflow_internal', fp, pathname, description)
    File "C:\Users\I06136\AppData\Local\Continuum\anaconda3\lib\imp.py", line 242, in load_module
    return load_dynamic(name, filename, file)
    File "C:\Users\I06136\AppData\Local\Continuum\anaconda3\lib\imp.py", line 342, in load_dynamic
    return _load(spec)
    ImportError: DLL load failed: 指定されたモジュールが見つかりません。


    Failed to load the native TensorFlow runtime.

    See https://www.tensorflow.org/install/errors

    for some common reasons and solutions. Include the entire stack trace
    above this error message when asking for help.

    tensorflow2.0.0のとき
    カーネル停止しました。再起動中



    カーネル停止しました。再起動中
    となります。

    キャンセル

  • meg_

    2020/07/27 14:44

    ・OSの情報は質問に追記してください。
    ・古いCPUだと最新のtensorflowが動かないことがあるらしいですが、今回の件に当てはまりますか?

    キャンセル

  • meg_

    2020/07/27 14:51

    あとは、visual studioのランタイムをインストールすると治るかもしれません。※自己責任でお願いします。

    キャンセル

回答 1

check解決した方法

0

meg_さんのコメントが的を得ていて、CPUが古いためTensorFlowが動作しなかったようです。
TensorFlow 1.5以前なら問題なく動くことが確認できました。本来retrain.pyを実行したいと思い、TensorFlowを動かしたかったのですが、anacondaでPython3.6.5 TensorFlow1.14.1 numpy1.18.1 Keras 2.4.3でも動作することが確認できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る