pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

RSS
  • 受付中

    回答
    2

    mac -bash: pip-3: command not found の対処方法 (pip は反応...

    前提・実現したいこと pc: Mac Pro (Late 2013) os: High Sierra pythonとopencvの環境を整えていたところ、pipは反応するもののpip3が反応しなくなってしまいました。 どなたか改善方法を教えていただけると幸いです。 発生している問題・エラーメッセージ pipは存在しますがpip3が存在しません。

    • 0評価
    • 59PV
    mkgrei mkgrei 2日前に 回答
  • 解決済

    回答
    2

    pip3コマンドが使えなくなってしまいました。'pip' has no attribute 'mai...

    kerasをインストールしようと思い pip3 install keras と打ったところ You are using pip version 9.0.3, however version 10.0.1 is available. You should consider upgrading via the 'pip install --upgrad

    • 0評価
    • 269PV
    maikeru-- maikeru-- 2週間前に コメント
  • 解決済

    回答
    3

    python3をアンインストールしたのに、pipコマンドが/usr/local/Cellar/pyt...

    すみません、教えて下さい。Mac OS High Sierraです。 Brewでインストールしたpython3が不要になったのでbrew uninstall したのですが、pipコマンドが -bash: /usr/local/bin/pip: /usr/local/Cellar/python3/3.6.4_2/bin/python3.6: bad i

    • 0評価
    • 108PV
    SaintKnowledge SaintKnowledge 2週間前に 回答
  • 解決済

    回答
    1

    pipによるインストールを実行するとEnvironmentErrorが発生する

    pip install wtformsしようとしたところ、以下のエラーが発生しました。 Could not install packages due to an EnvironmentError: [Errno 2] No such file or directory: 'c:\\users\\●●●\\anaconda3\\lib\\site-pack

    • 0評価
    • 218PV
    mk75 mk75 2週間前に ベストアンサー
  • 解決済

    回答
    2

    Statsmodelsがインストールできない, Python

    Pythonのpipでstatsmodelsをインストールしようとすると、 Cython is required to complie statsmodels from a development branch. Please install Cython or download a source release of statsmodels

    • 0評価
    • 111PV
    gaia8514 gaia8514 2週間前に コメント
  • 解決済

    回答
    1

    pipでpyrafがインストールできない

    sudo pip install PyRAF と入力したのですが、インストールの最後に以下のようなメッセージがでて、pyrafというパッケージをインストールできません。 もし解決方法をご存知の方がいらっしゃれば教えていただけると嬉しいです。 よろしくお願いいたします。 src/xutil.c:2:19: fatal error: X11/X.h: その

    • 0評価
    • 101PV
    kazto kazto 3週間前に 回答を編集
  • 解決済

    回答
    2

    pythonでexeファイルを作りたい

    pipのpy2exeってやつでできるらしいんですけど、自分の使っているpython3.6ではできないみたいです。ほかにいいやり方している方がいたら教えてくれませんか?

    • 0評価
    • 155PV
    mike2mike4 mike2mike4 4週間前に ベストアンサー
  • 受付中

    回答
    2

    さくらのレンタルサーバで、pip3 を使用したインストールが使用できない

    前提・実現したいこと さくらレンタルサーバを使用しています。 python3.6.4 をローカルにインストールしています。 pip3 を使用して、インストールができなくて困っています。 例えば、 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< $ pip3 install numpy <<<<<<<<<<<<<<

    • 0評価
    • 144PV
    yom2o yom2o 4週間前に 回答
  • 解決済

    回答
    1

    Python 3.6 windows 10 pip10.0導入について

    前提・実現したいこと cmd 上にて、get-pip.py コマンドを実行するとpip 10.0 導入を促され、エラーが返ってきます。 python.exe -m pip コマンドを促されますが、どうすればよいでしょうか。 発生している問題・エラーメッセージは以下の通りです。 C:\Users\**.**>python get-pip.py ERRO

    • 0評価
    • 260PV
    jcsmiles jcsmiles 3週間前に ベストアンサー
  • 受付中

    回答
    3

    Jupyter Notebookでnumpyがないと言われました。pip3 install nump...

    Jupyter notebook で  import numpy as np x = np.arange(1, 31) print(x) と打ったら --------------------------------------------------------------------------- ModuleNotFoundError

    • 0評価
    • 136PV
    KatoAtushi KatoAtushi 1ヶ月前に コメント
  • 解決済

    回答
    2

    pipでflaskがインストールできません

    はじめまして。 Python初心者です。 pipでflaskをインストールしようとしたところ、以下のようなエラーが発生しました。 C:\Users\名前>pip install flask Collecting flask Using cached Flask-0.12.2-py2.py3-none-any.whl Requirement alrea

    • 0評価
    • 197PV
    umyu umyu 1ヶ月前に 回答を編集
  • 受付中

    回答
    3

    初心者です。sudo pip-3.6 install

    前提・実現したいこと 初心者です。簡単であろう質問であることをお許しください。 通貨売買のBOTを購入したのですが、その指示の中で 必要なライブラリを読み込ませるため、 sudo pip-3.6 install requests sudo pip-3.6 install pybitflyer sudo pip-3.6 install pytz

    • 0評価
    • 481PV
    t_masa t_masa 1ヶ月前に 回答
  • 受付中

    回答
    3

    [python]pipで「pysummarization」をインストール時に出現するエラーメッセージ...

    windows7+anaconda上で「pip install pysummarization」で「pysummarization」をインストールしようとしたのですが、以下のようなエラーメッセージが出てしまい、どのように対応して良いのか分からず、苦戦しています。 (base) C:\Users\...>pip install pysummarizatio

    • 0評価
    • 116PV
    mini1988 mini1988 1ヶ月前に コメント
  • 解決済

    回答
    1

    pythonのsympyで利用してグラフを描きたいのですが、うまく行きません。

    jupyter notebookを構築して、実行しました。 グラフを描いた結果が違うので、何が違うのか教えてください。 from sympy import * import matplotlib.pyplot as plt x = symbols('x') y = symbols('y') y = 2*x**3-3*x**2-12*x+8 plo

    • 0評価
    • 126PV
    UekiKouji UekiKouji 1ヶ月前に ベストアンサー
  • 解決済

    回答
    1

    Djangoでapacheをつかう際のエラー

    前提・実現したいこと ここに質問の内容を詳しく書いてください。 python3.6.4 Django2.0.3 をvirtualenv環境で動かし、Apacheで公開しようとしています。 pip install mod_wsgiを実行中に以下のエラーメッセージが発生しました。 発生している問題・エラーメッセージ /bin/ld: /usr/l

    • 0評価
    • 104PV
    kazi0321 kazi0321 1ヶ月前に コメント
  • 解決済

    回答
    1

    Python3.6・CentOS7でSSL証明書が更新できない

    原因は違うことが判明しました。 前の質問で、SSLでサーバに接続ができない原因がSSL証明書関係だとわかりました。 macOSでは/Applications/Python 3.6/Install Certificates.commandを実行することでSSL証明書が更新できましたが、CentOSでの対応するコマンドが見つかりません。 certifiをインス

    • 0評価
    • 182PV
    stmkza stmkza 1ヶ月前に ベストアンサー
  • 解決済

    回答
    1

    CentOS7・Python 3.6でSSLエラーが発生する

    原因がわかったので新しく質問しました CentOS7にインストールしたPython3.6でSSL通信をするライブラリを使ったのですが、その時エラーが出て、通信ができません。 どうやったら解決できるか教えてください。 環境 CentOS Linux release 7.4.1708 (Core) Python 3.6.4(IUSからyumでpyt

    • 0評価
    • 213PV
    stmkza stmkza 1ヶ月前に ベストアンサー
  • 解決済

    回答
    2

    Mecabをインストールしたのですが文字コードのせいで実行できない

    上記の手順でmecabをインストールしたのですが以下のようなエラーが出てしまっています。dicrcはUTFに変えたので問題ないと思うのですが色々なサイトを当たっても解決策が見つかりませんでした。どなたか解決よろしくお願いします・(Macです)

    • 0評価
    • 165PV
    maikeru-- maikeru-- 1ヶ月前に コメント
  • 受付中

    回答
    1

    pythonでインストールしたパッケージが使えない

    前提・実現したいこと pythonでインストールしたパッケージを使いたい 発生している問題・エラーメッセージ ImportError: No module named (パッケージの名前) 該当のソースコード python 補足情報(FW/ツールのバージョンなど プログラミング初心者です pythonを使うさいpip というものを使ってパッケージ

    • 0評価
    • 128PV
    y_waiwai y_waiwai 1ヶ月前に 回答
  • 解決済

    回答
    1

    pipバージョンエラー

    前提・実現したいこと windowsにpython3.6.4を入れ、pipでパッケージをインストールしようとしたところ 赤文字のあと、黄文字で以下のように文章が表示されました。 You are using pip version 9.0.1, however version 9.0.2 is available. You should consider u

    • 0評価
    • 420PV
    ajaijiwq ajaijiwq 1ヶ月前に ベストアンサー
1

タグ情報

  • あなたの順位

    -

  • タグ登録者数

    29

  • 総質問数

    137

  • 今週の質問数

    1

関連するタグ

pipタグのよく見られている質問

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る