質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
CUDA

CUDAは並列計算プラットフォームであり、Nvidia GPU(Graphics Processing Units)向けのプログラミングモデルです。CUDAは様々なプログラミング言語、ライブラリ、APIを通してNvidiaにインターフェイスを提供します。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

解決済

tensorflow-gpu==1.13.1がうまくインストールできません。

akasateru
akasateru

総合スコア21

CUDA

CUDAは並列計算プラットフォームであり、Nvidia GPU(Graphics Processing Units)向けのプログラミングモデルです。CUDAは様々なプログラミング言語、ライブラリ、APIを通してNvidiaにインターフェイスを提供します。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

2回答

0評価

0クリップ

7659閲覧

投稿2020/05/13 12:22

編集2020/05/13 23:17

前提・実現したいこと

tensorflow-gpu==1.13.1がうまくインストールできません。

発生している問題・エラーメッセージ

>pip install tensorflow-gpu==1.13.1 ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.13.1 (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.0rc4, 2.2.0) ERROR: No matching distribution found for tensorflow-gpu==1.13.1

試したこと

pip install tensorflow-gpuでとりあえずインストールしてみたところtensorflowのバージョンを表示するコードは動作しました。しかし、以下のようなエラーが出てtensorflow gpuが動いていないみたいです。

python

import tensorflow as tf print(tf.__version__) print(tf.keras.__version__)
2020-05-13 20:41:16.893217: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library 'cudart64_101.dll'; dlerror: cudart64_101.dll not found 2020-05-13 20:41:16.897238: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine. 2.2.0 2.3.0-tf

補足情報(FW/ツールのバージョンなど)

cuda 10.0とcuDNN 7.6.0
windows 10

pip listです。

Package Version -------------------- ---------- absl-py 0.9.0 astunparse 1.6.3 boto 2.49.0 boto3 1.13.6 botocore 1.16.6 cachetools 4.1.0 certifi 2020.4.5.1 chardet 3.0.4 Cython 0.29.14 docutils 0.15.2 et-xmlfile 1.0.1 flags 0.0.1.2 gast 0.3.3 gensim 3.8.3 google-auth 1.14.3 google-auth-oauthlib 0.4.1 google-pasta 0.2.0 grpcio 1.28.1 h5py 2.10.0 idna 2.9 Janome 0.3.10 jdcal 1.4.1 jmespath 0.9.5 Keras-Preprocessing 1.1.1 Markdown 3.2.2 mojimoji 0.0.10 numpy 1.18.4 oauthlib 3.1.0 openpyxl 3.0.3 opt-einsum 3.2.1 pandas 1.0.3 pip 20.1 protobuf 3.11.3 pyasn1 0.4.8 pyasn1-modules 0.2.8 python-dateutil 2.8.1 pytz 2020.1 requests 2.23.0 requests-oauthlib 1.3.0 rsa 4.0 s3transfer 0.3.3 scipy 1.4.1 setuptools 41.2.0 six 1.14.0 smart-open 2.0.0 termcolor 1.1.0 urllib3 1.25.9 Werkzeug 1.0.1 wheel 0.34.2 wrapt 1.12.1 xlrd 1.2.0

pythonのバージョンを3.8から3.7にして

pip install tensorflow-gpu==1.13.1 ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.13.1 (from versions: none) ERROR: No matching distribution found for tensorflow-gpu==1.13.1

を実行しましたが、できませんでした。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

tiitoi

2020/05/13 12:58

Python のバージョンはいくつでしょうか? Python 3.7 では 1.13.1 をインストールできるみたいですが、3.8 とかそれより新しいバージョンの Python だと TensorFlow の2系しか配布されていないかもしれないですね
akasateru

2020/05/13 23:18

うまくいきませんでした。
quickquip

2020/05/14 00:45

python -V pip -V python -c 'import sys; print(sys.platform); print(sys.maxsize> 2**32)' の結果あたりを載せましょう。(Pythonのバージョン、pipが使っているPython、Pythonが64bitか)

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

CUDA

CUDAは並列計算プラットフォームであり、Nvidia GPU(Graphics Processing Units)向けのプログラミングモデルです。CUDAは様々なプログラミング言語、ライブラリ、APIを通してNvidiaにインターフェイスを提供します。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。