質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.83%

  • Python

    6429questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Python 3.x

    4907questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • MacOS(OSX)

    1748questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • pip

    155questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

  • Keras

    147questions

pip3コマンドが使えなくなってしまいました。'pip' has no attribute 'main'

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 781

maikeru--

score 21

kerasをインストールしようと思い

pip3 install keras


と打ったところ

You are using pip version 9.0.3, however version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.


といわれたので、そのとおりに実行したところ、

Collecting pip
  Downloading https://files.pythonhosted.org/packages/0f/74/ecd13431bcc456ed390b44c8a6e917c1820365cbebcb6a8974d1
cd045ab4/pip-10.0.1-py2.py3-none-any.whl (1.3MB)
    100% |████████████████████████████████| 1.3MB 869kB/s
Installing collected packages: pip
  Found existing installation: pip 9.0.3
    Uninstalling pip-9.0.3:
      Successfully uninstalled pip-9.0.3
  Rolling back uninstall of pip
Exception:
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/pip/basecommand.py", line 215, in main
  File "/usr/local/lib/python3.6/site-packages/pip/commands/install.py", line 342, in run

  File "/usr/local/lib/python3.6/site-packages/pip/req/req_set.py", line 784, in install
  File "/usr/local/lib/python3.6/site-packages/pip/req/req_install.py", line 851, in install
  File "/usr/local/lib/python3.6/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
  File "/usr/local/lib/python3.6/site-packages/pip/wheel.py", line 462, in move_wheel_files
  File "/usr/local/lib/python3.6/site-packages/pip/_vendor/distlib/scripts.py", line 372, in make
  File "/usr/local/lib/python3.6/site-packages/pip/_vendor/distlib/scripts.py", line 276, in _make_script
    if self._is_nt and not outname.endswith('.' + ext):  # pragma: no cover
  File "/usr/local/lib/python3.6/site-packages/pip/_vendor/distlib/scripts.py", line 250, in _write_script
    script_bytes = launcher + shebang + linesep + zip_data
  File "/usr/local/lib/python3.6/site-packages/pip/_vendor/distlib/util.py", line 407, in write_binary_file
PermissionError: [Errno 13] Permission denied: '/usr/local/bin/pip'
pip3 --version


としたところ

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2332, in resolve

    return functools.reduce(getattr, self.attrs, module)
AttributeError: module 'pip' has no attribute 'main'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/bin/pip3", line 11, in <module>
    load_entry_point('pip==9.0.3', 'console_scripts', 'pip3')()
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 480, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2693, in load_entry_point
    return ep.load()
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2324, in load
    return self.resolve()
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2334, in resolve
    raise ImportError(str(exc))
ImportError: module 'pip' has no attribute 'main'


となりpipが使えなくなってしまいました。
https://stackoverflow.com/questions/49839610/attributeerror-module-pip-has-no-attribute-main?noredirect=1&lq=1
を参考にしてみたのですが上手くいきませんでした。どなたかご教授お願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

回答をします、

 考えられる原因

**version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip
**

この親切なメッセージに沿ってアップグレードしたが、
結果として

 Uninstalling pip-9.0.3:
      Successfully uninstalled pip-9.0.3

あたりで作業が中断したのでしょう。

今の状態は
pip-9.0.3が削除され、version 10.0.1は未インストールのまま

と推測します。


さっき
/usr/local/opt/python/bin/python3.6 
この中にはありますか?
lsで見て何がありますか。

とお伺いしたのですが、

/usr/local/opt/python/bin/python3.6の下あたりに

\Lib\site-packages
とかありませんか?

とにかく site-packagesフォルダを探してください。
見つかったらそこに

pip

pip-1.5.x-py3.3.egg みたいに

pip関係のフォルダが複数ありますか?

(最悪pipの再インストールが解決策になると思います)


追加します

自分もこの質問の間、こちらを見ながら
一から環境を作りました。

そしてpipコマンドを実行したら
同じようにメッセージがでました。
これは無視して、先に進めてみます。
kerasまでいくかどうか、試してみますね。

イメージ説明


追加します

kerasまでインストールできました。

イメージ説明

イメージ説明

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/03 17:23

    はい!pipとpip-9.0.3-py3.6.egg-infoがありました。

    キャンセル

  • 2018/05/03 17:23

    はい!pipとpip-9.0.3-py3.6.egg-infoがありました。

    キャンセル

  • 2018/05/03 17:47

    [~] /usr/local/bin/pip3 -V
    [~] /usr/local/bin/pip -V

    フルパスでこの2つを実行した結果も教えてください。

    キャンセル

  • 2018/05/03 17:55

    [~] /usr/local/bin/pip3 -V 17:54:32
    Traceback (most recent call last):
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2332, in resolve
    return functools.reduce(getattr, self.attrs, module)
    AttributeError: module 'pip' has no attribute 'main'

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/usr/local/bin/pip3", line 11, in <module>
    load_entry_point('pip==9.0.3', 'console_scripts', 'pip3')()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 480, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2693, in load_entry_point
    return ep.load()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2324, in load
    return self.resolve()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2334, in resolve
    raise ImportError(str(exc))
    ImportError: module 'pip' has no attribute 'main'
    [~] /usr/local/bin/pip -V 17:54:53
    pip 9.0.2 from /Library/Python/2.7/site-packages (python 2.7)

    となりました。よろしくお願いします。

    キャンセル

  • 2018/05/03 18:13

    回答ありがとうございます。

    まず回答欄に追加したのですが
    pipで
    自分も今同じメッセージがでました。
    見てください。

    次ですが

    メッセージを見ると

    PermissionError: [Errno 13] Permission denied: '/usr/local/bin/pip'
    とあってここで失敗している。
    ファイル(フォルダ)の読み書き権限のないユーザーなのでエラーだった・・


    あとですが pyenvで仮想環境でPythonを使っていて
    [~] /usr/local/bin/pip -V 17:54:53
    pip 9.0.2 from /Library/Python/2.7/site-packages (python 2.7)

    とあって
    Python3とPython2の環境がありますね。
    今はPython3の環境がおかしいわけです。

    キャンセル

  • 2018/05/03 19:08

    回答ありがとうございます。
    わざわざ試していただきありがとうございます。
    pipのアップグレードを無視していればよかったのですよね…。
    今回の問題の原因はつかめそうでしょうか?

    キャンセル

  • 2018/05/03 20:01

    pipのアップグレードを無視していればよかったのですよね

    本当に大変ですね。
    さっきkerasまでpipでインストールできました。
    あと知り合いに聞いたら pip install --upgrade pipしても
    問題ないそうです(Windows)

    ですので
    今回の問題の原因

    /usr/local/bin/へのアクセス権
    と (あるいは)
    pyenv仮想環境でPython使っているので
    ということなので
    これの設定が今どうなっているのか
    気になりますね。

    export PATH=~/.pyenv/bin:$PATH と実行パスが通っているので
    [~] pyenv version 
    と打って

    現在2.7と3.6のどちらを使っているのか教えてください。

    あとはだめもとで
    sudoコマンドで

    [~] sudo pip3 install --upgrade pip==9.0.3 や
    [~] sudo python3 -m pip install --force-reinstall --upgrade pip
    も試してください。

    キャンセル

  • 2018/05/03 21:19 編集

    知り合いにまで聞いてもらいありがとうございます(>_<)
    [~] pyenv version 17:55:13
    anaconda3-4.3.1/envs/py3.6.0 (set by /Users/ユーザー名/.python-version)
    [~] sudo pip3 install --upgrade pip==9.0.3 21:17:18
    Password:
    Traceback (most recent call last):
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2332, in resolve
    return functools.reduce(getattr, self.attrs, module)
    AttributeError: module 'pip' has no attribute 'main'

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/usr/local/bin/pip3", line 11, in <module>
    load_entry_point('pip==9.0.3', 'console_scripts', 'pip3')()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 480, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2693, in load_entry_point
    return ep.load()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2324, in load
    return self.resolve()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2334, in resolve
    raise ImportError(str(exc))
    ImportError: module 'pip' has no attribute 'main'
    [~] sudo python3 -m pip install --force-reinstall --upgrade pip 21:17:37
    /usr/local/opt/python/bin/python3.6: No module named pip.__main__; 'pip' is a package and cannot be directly executed
    このようになりました。
    なんとか解決したいです。よろしくお願いします!

    キャンセル

  • 2018/05/03 21:25 編集

    すみません

    今の回答.いったん削除か修正してください
    そして

    /Users/**********/ など

    個人情報に触れそうな箇所は隠して
    再度コメントください。

    キャンセル

  • 2018/05/03 21:37 編集

    sをつけて

    [~]pyenv versions 

    でした。これの結果を教えてください。
    今いくつのPythonがインストールされているかです。

    /Users/**********/ など
    個人情報に触れそうな箇所は隠して
    コメントください。

    キャンセル

  • 2018/05/03 22:12

    [~] pyenv versions 21:17:44
    system
    3.6.0
    3.6.1
    3.6.3
    anaconda3-4.3.1
    * anaconda3-4.3.1/envs/py3.6.0 (set by /Users/ユーザ名/.python-version)
    anaconda3-4.3.1/envs/tensorflow
    です!お願いします( ; ; )

    キャンセル

  • 2018/05/03 22:20 編集

    お疲れ様です

    * anaconda3-4.3.1
    了解です。

    やってほしいこと

    そして
    anaconda3-4.3.1/envs/ Anaconda3が入っていますね!
    ※なお質問を挙げるときにできるだけPCの環境を書いてくださいね。
    これからでいいので~(笑)

    そうなると
    pipよりもAnaconda標準のパッケージ管理ツールである
    condaを使うべきです。

    Anacondaではcondaが推奨されています。pipと併用すると最悪パッケージ情報が壊れていきます。

    そこで mニューから Anaconda Promptというシェルに似た
    コンソールウインドウを開いてください。
    そこで

    [~]conda install keras

    を実行してください。どうなりますか?

    キャンセル

  • 2018/05/03 22:59

    すみません( ; ; )次から気をつけます!
    There is no anaconda prompt on Mac. That's only on Windows. Anaconda Prompt is nothing more than a shortcut to open the terminal program and run conda's activate script.
    とありました。僕はMacなので開けないのかなと思います…。

    キャンセル

  • 2018/05/03 23:12 編集

    それでは ”Mac”のターミナルを起動して

    ”まず”
    [~]conda install keras

    を実行してみてください。
    これだけ実行してください。
    どうなりますか。

    あと まー、いいです(笑) 
    macでしたか。

    次から気をつけます!

    この”すぐ次から”
    答える内容を整理して
    気をつけてコメントくださいね。

    ヒントになるかもしれない情報はできるだけ
    わかるように書いてください。

    キャンセル

  • 2018/05/03 23:34

    申し訳ございません。

    [~] conda install keras 23:32:28
    zsh: command not found: conda

    このようになりました。

    よろしくお願いします。

    キャンセル

  • 2018/05/04 00:03

    zsh: ですよね!

    今までの [~] もzsh:ですか。
    すべてzshでの作業でしょうか。

    それから
    ここから注意深く作業をしてください。

    まず

    私はsh(bash)を使っていますが

    kawa@kawa:~$ which conda
    /home/kawakawa/.pyenv/shims/conda
    kawa@kawa:~$

    とでました。そこでですが

    $HOME/.pyenv/shims/conda が
    存在しますでしょうか。

    何がしたいのか 念のため書いておくと

    condaコマンドのありかを探し
    今後は可能な限りcondaから情報を得たいのです。

    * anaconda3-4.3.1/envs/py3.6.0 (set by /Users/ユーザ名/.python-version) 
    と仮想環境のうち
    これが”アクティブ”にあっているからです。

    py3.6.0 つまりPythonの3.6.0ですね?

    念のため

    zsh: つまり[~]で

    zsh: python -V
    も教えてください。

    キャンセル

  • 2018/05/04 00:18

    kawakawaさんの言う通りにpipをやめてcondaコマンドを実行できるようにしたところ無事にkerasのインストールなどすべて正常に動作しました!

    長い間お付き合いいただき本当にありがとうございました。

    今後また分からないことがたくさんあると思いますが、またご教授頂ければ幸いです。
    今までteratailで質問をしてきてこんなにも丁寧に対応してもらったことはないです。
    本当に感謝しています。

    もしよろしければtwitterなどやっておられましたらフォローさせて欲しいです。

    キャンセル

  • 2018/05/04 00:25 編集

    maikeru--さん
    そうですか。おめでとうございます。

    この数時間で相当な技術と知識がついたと思いますよ。
    学んだことを.まとめをしておくといいですね。

    それから
    condaの実行コマンドはどこにありましたか。教えてください。

    なおpipとcondaの環境が混在しているで
    今後はご注意ください。
    condaを使ってください。

    キャンセル

  • 2018/05/04 00:43

    もしよろしければtwitterなどやっておられましたらフォローさせて欲しい

    twitterはいいですよ。
    teratailでフォロー申請があれは受けます。
    相互フォローします。

    まだteratailでの横のつながりの仕組み
    わからないんです。はじめて一か月経っていないので。

    なのでもう少し後で日にちが経ったら
    メッセージください。
    問題なければtwitterも公開します。

    キャンセル

  • 2018/05/04 12:29

    ありがとうございます。

    terateilではすでにフォローしていますので、フォロー返してもらえればと思います!

    キャンセル

  • 2018/05/04 12:35 編集

    こんにちは

    今フォロー返ししました。
    また何かあればフォローを通じて
    メッセージ(?)などください。

    あるいはここで連絡交換(?)かな

    私も知らないことや技術があるので
    そのときはよろしくお願いします。

    キャンセル

  • 2018/05/05 13:10

    メッセージ機能はないみたいなので、@ipokoyでtwitter検索してみてください!

    キャンセル

+1

pip install --upgrade pip==9.0.3もしくはpython -m pip install --upgrade pip==9.0.3のどちらかでダウングレードさせて置くのがいい・・・?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/03 14:28

    回答ありがとうございます。
    [~] python3 -m pip install --upgrade pip==9.0.3 14:27:35
    /usr/local/opt/python/bin/python3.6: No module named pip.__main__; 'pip' is a package and cannot be directly executed

    となってしまいます…

    キャンセル

  • 2018/05/03 14:44

    まず pip3 install keras

    これは無事インストールがされましたか?
    pip3 list で一覧にkerasはでますか? 

    次に
    pip' is a package and cannot be directly executed
    とありますが 一応念のため
    $ which pip3
    $ which pip

    でどう表示されます。

    キャンセル

  • 2018/05/03 14:48

    コメントありがとうございます。
    pip3 コマンドが使えないので、kerasがインストールされ方確認はできません。
    [~] pip3 list 14:45:5
    Traceback (most recent call last):
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2332, in resolve
    return functools.reduce(getattr, self.attrs, module)
    AttributeError: module 'pip' has no attribute 'main'

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/usr/local/bin/pip3", line 11, in <module>
    load_entry_point('pip==9.0.3', 'console_scripts', 'pip3')()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 480, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2693, in load_entry_point
    return ep.load()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2324, in load
    return self.resolve()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2334, in resolve
    raise ImportError(str(exc))
    ImportError: module 'pip' has no attribute 'main'

    となってしまいます。

    [~] which pip 14:29:28
    /usr/local/bin/pip
    [~] which pip3 14:45:46
    /usr/local/bin/pip3

    このようになりました。よろしくお願い致します。

    キャンセル

  • 2018/05/03 14:56

    コメントありがとうございます。

    pip3 コマンドが使えない 

    これはわかっていたのですが
    正確なエラーを知りたくて 婉曲的に実行していただき
    エラーを出させていただきました。

    キャンセル

  • 2018/05/03 15:00

    python -m pip install --force-reinstall --upgrade pip

    キャンセル

  • 2018/05/03 15:01

    python3 -m pip install --force-reinstall --upgrade pip

    でお願いいたします。

    キャンセル

  • 2018/05/03 15:07 編集

    python3 -m pip install --force-reinstall --upgrade pip 15:06:04

    /usr/local/opt/python/bin/python3.6: No module named pip.__main__; 'pip' is a package and cannot be directly executed

    実行して見たのですが、上記のように表示されてしまいました。お手数おかけしてしまい申し訳ございません( ; ; )

    キャンセル

  • 2018/05/03 15:31

    1.
    .(ドット)ファイルで Pythonの設定をしている部分を教えてください。
    .bash_profile か.bashrc

    2.一度シェルを閉じて shのシェルウインドウ(Macだとターミナル)を開いてください。

    こうして一度シェル変数を読み直した状態で
    まずは影響のすくない 

    pip3 -V
    をもう一度実行してください。

    キャンセル

  • 2018/05/03 15:44

    /usr/local/opt/python/bin/python3.6 
    この中にはありますか?
    lsで見て何がありますか。

    さっきの

    [~] which pip 14:29:28
    /usr/local/bin/pip
    [~] which pip3 14:45:46
    /usr/local/bin/pip3

    と合わせてみると、おかしなことになってますね。

    キャンセル

  • 2018/05/03 15:50 編集

    .bash_profileは
    export PYENV_ROOT="$HOME/.pyenv"
    export PATH="$PYENV_ROOT/bin:$PATH"
    export PATH=~/.pyenv/bin:$PATH
    export PATH="$HOME/.pyenv/shims:$PATH"
    eval "$(pyenv init -)"
    eval "$(pyenv virtualenv-init -)"

    となっています。ですが私は今zshを使用しているのでzshrは
    # If you come from bash you might have to change your $PATH.
    # export PATH=$HOME/bin:/usr/local/bin:$PATH

    # Path to your oh-my-zsh installation.
    export ZSH=/Users/ユーザー名/.oh-my-zsh

    # Set name of the theme to load. Optionally, if you set this to "random"
    # it'll load a random theme each time that oh-my-zsh is loaded.
    # See https://github.com/robbyrussell/oh-my-zsh/wiki/Themes
    ZSH_THEME="wedisagree"

    # Set list of themes to load
    # Setting this variable when ZSH_THEME=random
    # cause zsh load theme from this variable instead of
    # looking in ~/.oh-my-zsh/themes/
    # An empty array have no effect
    # ZSH_THEME_RANDOM_CANDIDATES=( "robbyrussell" "agnoster" )

    # Uncomment the following line to use case-sensitive completion.
    # CASE_SENSITIVE="true"

    # Uncomment the following line to use hyphen-insensitive completion. Case
    # sensitive completion must be off. _ and - will be interchangeable.
    # HYPHEN_INSENSITIVE="true"

    # Uncomment the following line to disable bi-weekly auto-update checks.
    # DISABLE_AUTO_UPDATE="true"

    # Uncomment the following line to change how often to auto-update (in days).
    # export UPDATE_ZSH_DAYS=13

    # Uncomment the following line to disable colors in ls.
    # DISABLE_LS_COLORS="true"

    # Uncomment the following line to disable auto-setting terminal title.
    # DISABLE_AUTO_TITLE="true"

    # Uncomment the following line to enable command auto-correction.
    # ENABLE_CORRECTION="true"

    # Uncomment the following line to display red dots whilst waiting for completion.
    # COMPLETION_WAITING_DOTS="true"

    # Uncomment the following line if you want to disable marking untracked files
    # under VCS as dirty. This makes repository status check for large repositories
    # much, much faster.
    # DISABLE_UNTRACKED_FILES_DIRTY="true"

    # Uncomment the following line if you want to change the command execution time
    # stamp shown in the history command output.
    # The optional three formats: "mm/dd/yyyy"|"dd.mm.yyyy"|"yyyy-mm-dd"
    # HIST_STAMPS="mm/dd/yyyy"

    # Would you like to use another custom folder than $ZSH/custom?
    # ZSH_CUSTOM=/path/to/new-custom-folder

    # Which plugins would you like to load? (plugins can be found in ~/.oh-my-zsh/plugins/*)
    # Custom plugins may be added to ~/.oh-my-zsh/custom/plugins/
    # Example format: plugins=(rails git textmate ruby lighthouse)
    # Add wisely, as too many plugins slow down shell startup.
    plugins=(
    git
    )

    source $ZSH/oh-my-zsh.sh

    # User configuration
    PATH="/usr/local/bin:/usr/local/sbin:$PATH"

    # You may need to manually set your language environment
    # export LANG=en_US.UTF-8

    # Preferred editor for local and remote sessions
    # if [[ -n $SSH_CONNECTION ]]; then
    # export EDITOR='vim'
    # else
    # export EDITOR='mvim'
    # fi

    # Compilation flags
    # export ARCHFLAGS="-arch x86_64"

    # ssh
    # export SSH_KEY_PATH="~/.ssh/rsa_id"

    # Set personal aliases, overriding those provided by oh-my-zsh libs,
    # plugins, and themes. Aliases can be placed here, though oh-my-zsh
    # users are encouraged to define aliases within the ZSH_CUSTOM folder.
    # For a full list of active aliases, run `alias`.
    #
    # Example aliases
    # alias zshconfig="mate ~/.zshrc"
    # alias ohmyzsh="mate ~/.oh-my-zsh"
    setopt nonomatch
    となっています。

    よろしくお願いします。

    キャンセル

  • 2018/05/03 15:58

    $HOME
    $PYENV_ROOT

    はどうなっていますか?

    $HOMEがログインユーザー名である場合には 
    ログインユーザーと答えてください
       個人情報保護のため

    キャンセル

  • 2018/05/03 16:26

    [~] echo $HOME 16:20:16
    /Users/ログインユーザー名

    [~] echo $PYENV_ROOT
    何も表示されませんでした。

    親切に対応してくださり本当にありがとうございます。

    キャンセル

  • 2018/05/03 16:38

    すみませんが、以降は回答欄に書きます。

    それから個人情報の観点から、十分注意してください。
    注意 zshの設定 (指摘しておきます。)

    キャンセル

  • 2018/05/03 16:47

    はい!お願いします!

    キャンセル

  • 2018/05/03 17:39

    pipの再インストールはこちらを参考にしてみてください。https://pip.pypa.io/en/stable/installing/

    キャンセル

  • 2018/05/03 19:24

    ありがとうございます!参考にしてみます!

    キャンセル

  • 2018/05/03 22:24

    Anaconda使ってるならcondaコマンドでpipを復旧させられると思いますが。conda install pip, conda update pip, など。

    キャンセル

  • 2018/05/04 00:19

    参考にしてみます!ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.83%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    6429questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Python 3.x

    4907questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • MacOS(OSX)

    1748questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • pip

    155questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

  • Keras

    147questions