質問編集履歴

1

一部変更

2022/06/23 19:21

投稿

yoshiya
yoshiya

score13

test CHANGED
File without changes
test CHANGED
@@ -5,29 +5,29 @@
5
5
  windowsコマンド プロンプト上
6
6
 
7
7
  ### 問題点
8
- tensorflowを使っていたがいつのまにかこのようなエラーが出るようにな
8
+ tensorflowを使っていたがいつのまにかこのようなエラーが出るようになりまし
9
9
  ```ここに言語を入力
10
10
  error: Can't find libdevice directory ${CUDA_DIR}/nvvm/libdevice
11
11
  2022-06-24 03:39:17.708285: W tensorflow/core/framework/op_kernel.cc:1733] UNKNOWN: JIT compilation failed.
12
12
  ```
13
13
  ### やったこと
14
- CUDAとcudnnを削除し以下のリンクの手順でもう一度ダウンロードした(nvvcなどのパスは確認済)
14
+ CUDAとcudnnを削除し以下のリンクの手順でもう一度ダウンロードしました(nvvcなどのパスは確認済)
15
15
  [NVIDIA ドライバ,NVIDIA CUDA ツールキット 11.6.2,NVIDIA cuDNN v8.4.0 のインストール(Windows 上)](https://www.kkaneko.jp/tools/win/cuda.html)
16
16
  ```ここに言語を入力
17
17
  バージョン
18
18
  CUDA 11.7
19
19
  cuDNN 8.4.1
20
20
  ```
21
- それでもさっきのエラーが出るので調べたところlibdevice.10.bcがあるところにパスを通せばいいらしくwindowsのコマンドプロンプトで以下のコードを打っ
21
+ それでもさっきのエラーが出るので調べたところlibdevice.10.bcがあるところにパスを通せばいいらしくwindowsのコマンドプロンプトで以下のコード実行しまし
22
22
  [参考元](https://stackoverflow.com/questions/68614547/tensorflow-libdevice-not-found-why-is-it-not-found-in-the-searched-path)
23
23
  ```ここに言語を入力
24
24
  SET XLA_FLAGS="--xla_gpu_cuda_data_dir=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.7\nvvm\libdevice"
25
25
  ```
26
- その結果以下のようなエラーが出た
26
+ その結果以下のようなエラーが出まし
27
27
  ```ここに言語を入力
28
28
  tensorflow/compiler/xla/parse_flags_from_env.cc:168] Could not open file ""--xla_gpu_cuda_data_dir=C:/Program Files/NVIDIA GPU Computing Toolkit/CUDA/v11.7/nvvm/libdevice"" to read flags for environment variable "XLA_FLAGS". (We assumed ""--xla_gpu_cuda_data_dir=C:/Program Files/NVIDIA GPU Computing Toolkit/CUDA/v11.7/nvvm/libdevice"" was a file name because it did not start with a "--".)
29
29
  ```
30
+
30
- プログム自体GCEで実行できるで大丈夫だうのですがまたローカルで実行~~そろそろ無料クレジット分がなくなるので~~
31
+ ーの意味なんとなくわかりますがどうすればいいかわかりません.参考元のサイト同じよにやってるに...どうかよろくお願しま
31
- どうかよろしくお願いします
32
32
 
33
33