質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.48%
Raspberry Pi

Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

Q&A

解決済

1回答

1520閲覧

エラーメッセージが何を言っているのかがわからない

kouki-ymd

総合スコア32

Raspberry Pi

Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

0グッド

0クリップ

投稿2022/09/18 10:05

編集2022/09/19 01:38

前提

ラズベリーパイ4でpythonを用いてneopioxelのws2812bを動かすコードを書いています。
adfruit社のHPを参考に配線をし、boardとadfruit-circuitpython-neopixelをインストールしました。
https://learn.adafruit.com/adafruit-neopixel-uberguide/python-circuitpython

該当のソースコード

HPを参考に以下のような記述をして実行してみたところ、

python

1import time 2import board 3import neopixel 4 5pixels = neopixel.NeoPixel(board.D18, 30) 6 7pixels[0] = (255, 0, 0) 8 9time.sleep(5)   #これがないと処理が一瞬で終わってしまう?

エラーメッセージ

このようなエラーメセージが出ました。

/home/pi/.local/lib/python3.7/site-packages/scipy/__init__.py:149: UserWarning: A NumPy version >=1.16.5 and <1.23.0 is required for this version of SciPy (detected version 1.16.2 UserWarning) RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd Traceback (most recent call last): File "/home/pi/neopixel-t2-02.py", line 3, in <module> import neopixel File "/home/pi/.local/lib/python3.7/site-packages/neopixel/__init__.py", line 4, in <module> from .scroll import Scroll File "/home/pi/.local/lib/python3.7/site-packages/neopixel/scroll.py", line 2, in <module> from scipy.ndimage import gaussian_filter1d File "/home/pi/.local/lib/python3.7/site-packages/scipy/ndimage/__init__.py", line 151, in <module> from .filters import * File "/home/pi/.local/lib/python3.7/site-packages/scipy/ndimage/filters.py", line 37, in <module> from . import _nd_image ImportError: numpy.core.multiarray failed to import

分からないこと

エラーメッセージの読み方がわからないため、このエラーメッセージが何を言っていて、どうすれば解決するのかを教えていただきたいです。

教えていただいて

なんやかんやでnumpyを1.21.6までアップデートすることができました。その後再度上記のコードを実行したところ、

Traceback (most recent call last): File "/home/pi/neopixel-t2-02.py", line 3, in <module> import neopixel File "/home/pi/.local/lib/python3.7/site-packages/neopixel/__init__.py", line 4, in <module> from .scroll import Scroll File "/home/pi/.local/lib/python3.7/site-packages/neopixel/scroll.py", line 2, in <module> from scipy.ndimage import gaussian_filter1d File "/home/pi/.local/lib/python3.7/site-packages/scipy/ndimage/__init__.py", line 153, in <module> from .interpolation import * File "/home/pi/.local/lib/python3.7/site-packages/scipy/ndimage/interpolation.py", line 37, in <module> from scipy import special File "/home/pi/.local/lib/python3.7/site-packages/scipy/special/__init__.py", line 643, in <module> from . import _ufuncs ImportError: libf77blas.so.3: cannot open shared object file: No such file or directory

このようなエラーメッセージが出ました。

まずエラーメッセージの読み方についてなのですが、これはlibf77blas.so.3という種類のインポートエラーで_ufuncsというファイルまたはディレクトリがなかったよーということを表している、という事であっていますか?(初歩的な質問で申し訳ありません><)

そしてやはりどうすれば解決するのかがわからない為、要はなにをすればいいのかを教えていただきたいです。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

jbpb0

2022/09/18 13:43

> RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd > このエラーメッセージが何を言っていて、 必要とされてるnumpyのバージョンと、現状インストールされてるnumpyのバージョンが違う、という意味です 参考 https://www.souichi.club/python/cv2-runtime-error/
jbpb0

2022/09/19 02:01

melianさんの回答で元々のエラーは出なくなったので、「解決済」にしましょう
kouki-ymd

2022/09/19 03:11

そうですね ありがとうございます。
guest

回答1

0

ベストアンサー

DeepL翻訳 でエラーメッセージを翻訳してみましょう。

UserWarning: A NumPy version >=1.16.5 and <1.23.0 is required for this version of SciPy (detected version 1.16.2
RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd

ユーザー警告 このバージョンの SciPy には NumPy のバージョン >=1.16.5 および <1.23.0 が必要です (バージョン 1.16.2 を検出)
RuntimeError: モジュールは API バージョン 0xe に対してコンパイルされたが、この numpy のバージョンは 0xd である。

Numpy を version 1.16.5 以上、1.23.0 未満にアップデートする、という対応が考えられます(SciPy と Numpy を最新版にアップデートしてもよいかもしれません)。

投稿2022/09/18 10:28

編集2022/09/18 10:29
melian

総合スコア19714

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.48%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問