質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.49%
Google Colaboratory

Google Colaboratoryとは、無償のJupyterノートブック環境。教育や研究機関の機械学習の普及のためのGoogleの研究プロジェクトです。PythonやNumpyといった機械学習で要する大方の環境がすでに構築されており、コードの記述・実行、解析の保存・共有などが可能です。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

Q&A

1回答

1649閲覧

Google Colaboratory で パッケージのバージョンを更新して使用したい

hoge-ta

総合スコア0

Google Colaboratory

Google Colaboratoryとは、無償のJupyterノートブック環境。教育や研究機関の機械学習の普及のためのGoogleの研究プロジェクトです。PythonやNumpyといった機械学習で要する大方の環境がすでに構築されており、コードの記述・実行、解析の保存・共有などが可能です。

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

0グッド

0クリップ

投稿2023/01/19 15:05

編集2023/01/19 15:10

イタリックテキスト### 前提

  • google colaboratory を使用
  • パッケージのバージョンを更新して使用したい
    • 使用したいバージョン: tweepy==4.12.1
    • 現在のバージョン : tweepy==3.10.0
Python 3.8.10 Looking in indexes: https://pypi.org/simple, https://us-python.pkg.dev/colab-wheels/public/simple/ Requirement already satisfied: tweepy==4.12.1 in /usr/local/lib/python3.9/dist-packages (4.12.1) Requirement already satisfied: requests<3,>=2.27.0 in /usr/local/lib/python3.9/dist-packages (from tweepy==4.12.1) (2.28.2) Requirement already satisfied: requests-oauthlib<2,>=1.2.0 in /usr/local/lib/python3.9/dist-packages (from tweepy==4.12.1) (1.3.1) Requirement already satisfied: oauthlib<4,>=3.2.0 in /usr/local/lib/python3.9/dist-packages (from tweepy==4.12.1) (3.2.2) Requirement already satisfied: charset-normalizer<4,>=2 in /usr/local/lib/python3.9/dist-packages (from requests<3,>=2.27.0->tweepy==4.12.1) (3.0.1) Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/local/lib/python3.9/dist-packages (from requests<3,>=2.27.0->tweepy==4.12.1) (1.26.14) Requirement already satisfied: idna<4,>=2.5 in /usr/local/lib/python3.9/dist-packages (from requests<3,>=2.27.0->tweepy==4.12.1) (3.4) Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.9/dist-packages (from requests<3,>=2.27.0->tweepy==4.12.1) (2022.12.7) WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv 3.10.0

該当のソースコード

上のエラーコードは以下のコードを実行したときに出た
pip installをしているのに使用されない

!python3 --version !sudo pip install tweepy==4.12.1 import tweepy print(tweepy.__version__)

試したこと

pip installでバージョン指定

補足情報(FW/ツールのバージョンなど)

pip listを実行した場合は4.12.1になっている

Package Version ----------------------- -------------------- certifi 2022.12.7 charset-normalizer 3.0.1 dbus-python 1.2.16 distlib 0.3.6 GDAL 3.0.4 idna 3.4 oauthlib 3.2.2 pip 22.3.1 PyGObject 3.36.0 python-apt 2.0.0+ubuntu0.20.4.8 requests 2.28.2 requests-oauthlib 1.3.1 requests-unixsocket 0.2.0 screen-resolution-extra 0.0.0 setuptools 66.0.0 tweepy 4.12.1 <===目的のパッケージ urllib3 1.26.14 wheel 0.34.2 xkit 0.0.0

pip3 list でも同じ

Package Version ----------------------- -------------------- certifi 2022.12.7 charset-normalizer 3.0.1 dbus-python 1.2.16 distlib 0.3.6 GDAL 3.0.4 idna 3.4 oauthlib 3.2.2 pip 22.3.1 PyGObject 3.36.0 python-apt 2.0.0+ubuntu0.20.4.8 requests 2.28.2 requests-oauthlib 1.3.1 requests-unixsocket 0.2.0 screen-resolution-extra 0.0.0 setuptools 66.0.0 tweepy 4.12.1 urllib3 1.26.14 wheel 0.34.2 xkit 0.0.0

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

quickquip

2023/01/19 15:35

再現しないです。 最初のセルで !sudo pip install tweepy==4.12.1 をしてますか? (先に import tweepy してませんか?)
退会済みユーザー

退会済みユーザー

2023/01/19 16:34 編集

英語の警告の末尾に「sudo を付けてpipすると環境をぶっ壊すからやめた方がイイよ」とあるので、「!pip 略」とすると事態がかわるかもしれません。sudoでインストールしてsudoなしのPythonを走らせるとインポート先が食い違うとでも呼ぶのでしょうか。
jbpb0

2023/01/19 22:48 編集

google colabのメニューの 「ランタイム」→「ランタイムを再起動」 を実行してから、もう一度やってみてください
quickquip

2023/01/20 00:58 編集

「/usr/local/lib/python3.8/dist-packages に root 権限のpipから入れられたtweepy」を入れ替えるのが目的なので、sudo pip でもおかしくないのでは。
guest

回答1

0

インストールコマンドは!pip install tweepy==4.12.1で良いと思います。

イメージ説明

投稿2023/01/19 16:45

meg_

総合スコア10579

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.49%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問