質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

pip で lxml がインストールできません

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,649

score 8

すいません。質問です
pipでlxmlをインストールしようとすると以下のようなエラーが出てしまいます

running build_ext
    building 'lxml.etree' extension
    creating build/temp.linux-armv7l-3.5
    creating build/temp.linux-armv7l-3.5/src
    creating build/temp.linux-armv7l-3.5/src/lxml
    gcc -pthread -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -Isrc/lxml/includes -I/root/.pyenv/versions/3.5.1/include/python3.5m -c src/lxml/lxml.etree.c -o build/temp.linux-armv7l-3.5/src/lxml/lxml.etree.o -w
    In file included from src/lxml/lxml.etree.c:321:0:
    src/lxml/includes/etree_defs.h:14:31: 致命的エラー: libxml/xmlversion.h: そのようなファイルやディレクトリはありません
     #include "libxml/xmlversion.h"
                                   ^
    コンパイルを停止しました。
    Compile failed: command 'gcc' failed with exit status 1
    creating tmp
    cc -I/usr/include/libxml2 -c /tmp/xmlXPathInittcuj55lo.c -o tmp/xmlXPathInittcuj55lo.o
    cc tmp/xmlXPathInittcuj55lo.o -lxml2 -o a.out
    error: command 'gcc' failed with exit status 1


調べてlibxslt-develをインストールしようとしたのですが次は以下の様なエラーが出てしまいました

読み込んだプラグイン:fastestmirror
Loading mirror speeds from cached hostfile
パッケージ libxslt-devel は利用できません。
エラー: 何もしません

これに関しては調べても解決方法が見出せませんでした
どなたか分かる方はいらっしゃるでしょうか

環境はraspberryPie2用のCentOS7
python3.5.1
pyenvで管理しています

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

EPELリポジトリをインストールしてからlibxslt-develをインストールしていますか?

yum install epel-release

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/27 14:19

    EPELリポジトリもインストールしようとしましたが同じ様に利用できないというメッセージが返ってきてしまいます

    キャンセル

0

libxslt-devel, libxml2-devel は base か updates リポジトリにあります。
base, updates リポジトリが有効になっているか、yum repolist や /etc/yum.repos.d/ 以下のファイルを確認ください。

(2016/09/28 00:34) 追記

失礼しました。
Raspberry Pi は x86_64 ではなく、armhfp アーキテクチャなのですね。
libxml2-devel (/usr/include/libxml2/libxml/xmlversion.h を含む) は updates にありましたが、libxslt-devel は提供されていないようです。

検索すると、http://armv7.dev.centos.org/repodir/ 以下に 署名されていない RPM があるようです。
(例えば、http://armv7.dev.centos.org/repodir/c7-pass-1/libxslt/1.1.28-5.el7/armv7hl/libxslt-devel-1.1.28-5.el7.armv7hl.rpm)

どうしても libxslt-devel が必要ならば、SRPM からビルドを試みるか、上記サイトから libxslt と同じバージョン・リリースの libxslt-devel-*.armv7hl.rpm を探すかですが、署名されていないので自己責任で。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/27 20:58

    有効になっていますね

    キャンセル

  • 2016/09/28 15:48

    詳しい説明ありがとうございます
    自己責任ということなので、失敗したらOSごと他のものに変えてしまおうかと思います

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る