質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.81%

ubuntuにtensorflowをインストールしたいのですがエラーが出てしまいます

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 8,158

miyashino

score 8

こんにちは。UbuntuにTensorflowをインストールしようとしています。以下のコマンドをUbuntuのterminalから実行したところエラーになってしまいました。
<コマンド>
sudo pip install --upgrade ./tensorflow-0.10.0rc0-cp27-none-linux_x86_64.whl 
<エラー>
tensorflow-0.10.0rc0-cp27-none-linux_x86_64.whl is not a supported wheel on this platform.

環境は以下の通りです。他に必要な情報がありましたら、ご指摘ください。
OS:Ubuntu 14.04LTS
pip: 8.1.2
python: 3.5.2

いろいろ調べてたのですが、もう3日も前進できず、お手上げ状態です。
みなさまからアドバイスをいただけるとうれしいです。
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

tensorflow-0.10.0rc0-cp27-none-linux_x86_64.whl

なので、このwhlファイルはPython2.7系用です。

オフィシャルのセットアップページに、Then, select the correct binary to install:というセクションがあったので見てみましtが、一番上のURLのものをダウンロードしたりしたのではないでしょうか。
同じ一覧から抜き出すと、以下のどっちかを取ってきてインストールするのが正しいのだと思います。

  • https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.10.0rc0-cp35-cp35m-linux_x86_64.whl
  • https://storage.googleapis.com/tensorflow/linux/gpu/tensorflow-0.10.0rc0-cp35-cp35m-linux_x86_64.whl

上がCPUのみ使用するもの、下がGPUも使用するものっぽいです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/08/26 00:01

    何度もすみません。ほぼ同一環境でためしてくださり、ありがとうございます。
    which pipコマンドを打つと以下の結果がでました。
    /home/user1/anaconda3/bin/pip
    何か環境がおかしなことになってしまってるのですかねぇ。

    キャンセル

  • 2016/08/26 00:12

    'pip -V'で「pipのバージョン」と「どこに含まれているか」がわかるみたいです。(初めて知った...)

    例えばpyenvで構築した環境だとこんな感じで出て3.5系の環境であることがはっきりわかるので、もしかしたら何かのヒントにはなりそうですね

    $ pip -V
    pip 8.1.2 from /usr/local/pyenv/versions/3.5.2/lib/python3.5/site-packages (python 3.5)

    キャンセル

  • 2016/08/26 09:06

    何度もすみません。ありがとうございます。
    pip -Vを実行した結果は以下の通りになりました。
    pip 8.1.2 from /home/user1/anaconda3/lib/python3.5/site-packages (python 3.5)
    おそらく3.5系だと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.81%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る