質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

受付中

tensorflow,h5pyがpipでインストールできません.

chanyou
chanyou

総合スコア0

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

2回答

0評価

0クリップ

519閲覧

投稿2021/12/11 13:24

tensorflow,h5pyがインストールできない

tensorflowをインストールして使おうと思っているのですが,途中でエラーを吐かれてしまいインストールできません.
途中のログを見るとh5pyモジュールがインストールできていないようでした.
どなたか解決法がわかる方がいらっしゃいましたら,ご教授頂ければ幸いです.

発生しているエラーメッセージ

 copying h5py/tests/data_files/vlen_string_dset_utc.h5 -> build/lib.macosx-11-universal2-3.8/h5py/tests/data_files copying h5py/tests/data_files/vlen_string_dset.h5 -> build/lib.macosx-11-universal2-3.8/h5py/tests/data_files running build_ext Loading library to get build settings and version: libhdf5.dylib error: Unable to load dependency HDF5, make sure HDF5 is installed properly error: dlopen(libhdf5.dylib, 0x0006): tried: 'libhdf5.dylib' (no such file), '/usr/lib/libhdf5.dylib' (no such file), '/private/var/folders/ss/npnz30qs3790gbzg8c2lrpyc0000gp/T/pip-install-cxxaf373/h5py_e848f75459564e0f991ca1f7959d5f70/libhdf5.dylib' (no such file), '/usr/lib/libhdf5.dylib' (no such file) ---------------------------------------- ERROR: Failed building wheel for h5py Failed to build h5py ERROR: Could not build wheels for h5py, which is required to install pyproject.toml-based projects

エラーログを見るとHDF5とlibhdf5.dylibが関係しているようですが,何を指しているかわかりませんでした.

試したこと

以下の二つのサイト
M1 Mac(Apple Silicon)/GPU対応のTensorFlowをインストール
h5pyをインストールできません
等を見てコマンドを打ってみたのですが,うまく実行できないので,手詰まりしてしまっています.よろしくお願いいたします.

補足情報(ツールのバージョン)

使っている環境は

  • m1 Mac
  • python3.8.9 64bit
  • homebrew 3.3.7
  • Xcode-select version 2392
  • Apple clang version 13.0.0 (clang-1300.0.29.3)

Target: arm64-apple-darwin21.1.0

です.anacondaはpipで統一したいので入れていません.バージョン管理ツールpyenv等も使っていません.

プログラム関連の投稿サイトで質問するのが初めてなので,失礼等ございましたらご容赦頂ければ幸いです.

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。