質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

SSL

SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

proxy

proxy(プロキシー)は、企業などの内部コンピュータとインターネットの中間に位置し、例えば直接インターネットに接続できない内部コンピュータの代理としてインターネットに接続する等をするシステム、もしくは代理として機能を実行するソフトウェアです。内部ネットワークへのアクセスを一元管理し、内部からの特定の種類の接続以外を遮断すること、外部からの不正アクセスを拒否することなどに用いられます。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

解決済

pip installがSSLエラー

pariparigorilla
pariparigorilla

総合スコア14

Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

SSL

SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

proxy

proxy(プロキシー)は、企業などの内部コンピュータとインターネットの中間に位置し、例えば直接インターネットに接続できない内部コンピュータの代理としてインターネットに接続する等をするシステム、もしくは代理として機能を実行するソフトウェアです。内部ネットワークへのアクセスを一元管理し、内部からの特定の種類の接続以外を遮断すること、外部からの不正アクセスを拒否することなどに用いられます。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

1回答

0評価

1クリップ

2185閲覧

投稿2021/07/19 11:57

編集2021/07/19 13:45

前提・実現したいこと

miniconda環境でpipを使用したinstallしたい。
(base)にpipenvを入れたい。

発生している問題・エラーメッセージ

WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))': /simple/pipenv/ WARNING: Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))': /simple/pipenv/ WARNING: Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))': /simple/pipenv/ WARNING: Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))': /simple/pipenv/ WARNING: Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))': /simple/pipenv/ Could not fetch URL https://pypi.org/simple/pipenv/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pipenv/ (Caused by SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))) - skipping ERROR: Could not find a version that satisfies the requirement pipenv ERROR: No matching distribution found for pipenv Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError(SSLError(1, '[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1123)'))) - skipping

該当のソースコード

pip install pipenv

試したこと

下記を参考に、ユーザフォルダの下に、.condarcファイルを作り、プロキシ設定を行いました
https://lifetime-engineer.com/anaconda-miniconda-proxy/

下記を参考に、Appdata/Roamingの下に、pip.iniを作り、pipのhostを信頼済み登録にしました。
https://qiita.com/agajo/items/73d6f14855da703972e0

補足情報(FW/ツールのバージョンなど)

OS:Windows10
conda version : 4.9.2
python version : 3.9.1.final.0
pip:20.3.1

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

pariparigorilla

2021/07/19 12:56

ご回答ありがとうございます。この設定は既に入れています。
meg_

2021/07/19 13:05

OSは何でしょうか?
jbpb0

2021/07/19 13:27

プロキシの設定は https://… ではなく http://… です 大丈夫だと思いますが、念の為に書いときます
pariparigorilla

2021/07/19 13:49

>OSは何でしょうか? win10です。質問文にも追記します。 >http://… はい、httpで設定しております。 >pythonのバージョンとpipのバージョンの組み合わせ python 3.9.1とpip 20.3.1なので、頂いたパターンには当てはまりませんが、ちょっとバージョン違い試してみます。
jbpb0

2021/07/19 23:33 編集

そういえば、プロキシ環境で使ってる当方のWindowsのPython 3.7も、しばらく前に同じ状態になって、pipのバージョンを20.2.4に戻したらつながるようになった、ということがありました ご参考までに (このコメントを書いた直前まで、そのことを忘れてました)
pariparigorilla

2021/07/20 00:48

python 3.9.1×pip 20.3.1だったものを python 3.9.1×pip 21.1.3にして実行しましたが駄目で、新たに仮想環境を作り(上記はbase)、 python 3.7.10×pip 21.1.3 python 3.8.10×pip 21.1.3を実行してもダメでした。 バージョンよりも環境問題な気がしますが、原因がさっぱりわかりません…。
jbpb0

2021/07/20 00:54

pipを新しい方じゃなくて、pip 20.2みたいな古いのに変えても、ダメですか?
jbpb0

2021/07/20 01:00

あとは、プロキシの設定を「pip.ini」ではなく、pipコマンドの「--proxy」オプションでやってみるとか
pariparigorilla

2021/07/20 01:17

こちらで、SETコマンドでプロキシを設定したら通りました。 https://qiita.com/samunohito/items/40a03e1464899225e698 .condarcやpip.iniのプロキシ設定との関係がよくわかりませんが、プロキシ設定の問題だったようです。 後ほど解決方法欄に記載しようと思いますが取り急ぎ。
jbpb0

2021/07/20 01:46 編集

> どのように古いpipに差し替えるのでしょうか? この質問のエラーを直すためにはもう必要ないかもしれませんが、重要なことがあるので、一応書いておきます 「.condarc」を設定してるということは、Anacondaを使ってるのですよね? その場合は、condaでインストールしたものはcondaでアップデート、pipでインストールしたものはpipでアップデートしないと、環境が壊れることがあります Anacondaをインストールした時点でpipは同梱されてますから、(自分でcondaでインストールしてないけど)pipはcondaでインストールした扱いですから、アップデートもcondaでやります 「.condarc」を設定して、(pipはダメでも)condaはプロキシ通してアクセスできるなら、condaでバージョンを指定してpipをインストールします もし、condaでもプロキシ超えられないなら、Webブラウザで https://anaconda.org/anaconda/pip/files から該当するバージョンのファイルをダウンロード して、オフラインでcondaでインストールします 上記の話は、pipだけじゃなくて、numpyとかpandasとか、Anacondaに同梱されてる多くのものに共通の話です それらは、pipでアップデートしない方がいいです たとえ、ググって見つかった参考Webページにそう書いてあっても 【追記】 AnacondaではないPythonを使ってる場合に、プロキシ超えられない時にpipをインストールする場合は、 https://pypi.org/project/pip/ の「Release history」でバージョンを選んで、「Download files」から「*.whl」ファイルをダウンロード して、オフラインでpipでインストールします
pariparigorilla

2021/07/20 01:54

なるほど。 pip自体はcondaで入れているから、pipでのupdateはcondaで行うのですね。 勉強になりました。オフラインでのinstall方法など含め、ありがとうございます。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Anaconda

Anacondaは、Python本体とPythonで利用されるライブラリを一括でインストールできるパッケージです。環境構築が容易になるため、Python開発者間ではよく利用されており、商用目的としても利用できます。

SSL

SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

proxy

proxy(プロキシー)は、企業などの内部コンピュータとインターネットの中間に位置し、例えば直接インターネットに接続できない内部コンピュータの代理としてインターネットに接続する等をするシステム、もしくは代理として機能を実行するソフトウェアです。内部ネットワークへのアクセスを一元管理し、内部からの特定の種類の接続以外を遮断すること、外部からの不正アクセスを拒否することなどに用いられます。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。