質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
コマンド

コマンドとは特定のタスクを行う為に、コンピュータープログラムへ提示する指示文です。多くの場合、コマンドはShellやcmdようなコマンドラインインターフェイスに対する指示文を指します。

コマンドライン

コマンドライン(別名:Command Line Interface)は、ユーザに命令の入力を促す(プロンプト)文字列の表示を行い、すべての操作をキーボードを用いて文字列を打ち込む事でプログラムを走らせるユーザインターフェースです。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

selenium

Selenium(セレニウム)は、ブラウザをプログラムで作動させるフレームワークです。この原理を使うことにより、ブラウザのユーザーテストなどを自動化にすることができます。

Q&A

解決済

4回答

24159閲覧

pipコマンドを実行したときにSyntaxErrorが出て実行できない。

apollo_

総合スコア14

コマンド

コマンドとは特定のタスクを行う為に、コンピュータープログラムへ提示する指示文です。多くの場合、コマンドはShellやcmdようなコマンドラインインターフェイスに対する指示文を指します。

コマンドライン

コマンドライン(別名:Command Line Interface)は、ユーザに命令の入力を促す(プロンプト)文字列の表示を行い、すべての操作をキーボードを用いて文字列を打ち込む事でプログラムを走らせるユーザインターフェースです。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

selenium

Selenium(セレニウム)は、ブラウザをプログラムで作動させるフレームワークです。この原理を使うことにより、ブラウザのユーザーテストなどを自動化にすることができます。

0グッド

1クリップ

投稿2021/01/25 00:45

編集2021/01/25 02:07

前提・実現したいこと

下記のサイトを実行するために、
各単語を google イメージ検索で検索し、そのブラウザの画面毎キャプチャしファイルに保存するスクリプト
Python 2.7でseleniumとpillowをインストールしようとし、
$pip install selenium pillowをターミナルに入力したところ、syntax errorが発生しましました。

該当のソースコード

[~] % sudo pip install --upgrade pip Traceback (most recent call last): File "/usr/local/bin/pip", line 11, in <module> load_entry_point('pip==21.0', 'console_scripts', 'pip')() File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 489, in load_entry_point return get_distribution(dist).load_entry_point(group, name) File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2843, in load_entry_point return ep.load() File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2434, in load return self.resolve() File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2440, in resolve module = __import__(self.module_name, fromlist=['__name__'], level=0) File "/Library/Python/2.7/site-packages/pip-21.0-py2.7.egg/pip/_internal/cli/main.py", line 60 sys.stderr.write(f"ERROR: {exc}") ^ SyntaxError: invalid syntax

試したこと

pip3コマンドで実行しようと試みましたが、pip3では以下のエラー文が出てpipコマンドを実行しなければならないため、上記を解決しないと進めないようです。

You should consider upgrading via the 'pip install --upgrade pip' command.

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答4

0

ベストアンサー

エラーの原因は、 sys.stderr.write(f"ERROR: {exc}")f文字列(フォーマット済み文字列リテラル、f"..."の中の{式}に値を埋め込むやつ)が使われていることですね。

これは、Python 3.6で追加された機能なので、Python 2.7ではSyntaxErrorになります。

pip 21以降ではPython 2系が対象外になったので、pip 20を使うか、Pythonそのものを3系に移行しましょう。

投稿2021/01/25 01:58

編集2021/01/25 02:04
Daregada

総合スコア11990

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

https://pip.pypa.io/en/stable/news/

21.0 (2021-01-23)
Deprecations and Removals
Drop support for Python 2.

Python2系はもうサポートされません。どうしてもというならバージョン指定してインストールしまよう。

Modernise the codebase after Python 2.

"サポートされません"は、2.x,3.5との互換性のためのコードを破棄しました、という意味です。

今さらPython2を始めるのは百害あって一利なしでしょう。
少なくともこの情報を自力で調べだせないようなら、Python2を使おうと思わない方がいいです。

投稿2021/01/25 01:49

編集2021/01/25 02:16
quickquip

総合スコア11003

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

pipコマンドでpipのアップデートは出来ないはずです。その場合にこのエラーなのかどうかは知りませんが(違う気がする)。pythonコマンドで実行します。

python -m pip install --upgrade pip

pip3コマンドで実行しようと試みましたが

Python2.7 を使うのであれば、pip3は全く関係ないです。Python3用です。

ところで、seleniumとpillowがPython2で動くことは確認していますか?

投稿2021/01/25 01:13

otn

総合スコア84247

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

apollo_

2021/01/25 01:34

回答ありがとうございます。 実行しても、下記のようになり、同じ問題に当たりました。 ``` python -m pip install --upgrade pip Traceback (most recent call last): File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 174, in _run_module_as_main "__main__", fname, loader, pkg_name) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 72, in _run_code exec code in run_globals File "/Library/Python/2.7/site-packages/pip-21.0-py2.7.egg/pip/__main__.py", line 21, in <module> from pip._internal.cli.main import main as _main File "/Library/Python/2.7/site-packages/pip-21.0-py2.7.egg/pip/_internal/cli/main.py", line 60 sys.stderr.write(f"ERROR: {exc}") ^ SyntaxError: invalid syntax ``` 下記に記載していることを実行しようと思っているため、python2で動くと考えています。 https://github.com/t9md/bulk-screen-capture
guest

0

pip自体のアップグレードに、下記コマンドを試してみてください。

Terminal

1$ python -m pip install --upgrade pip

pythonのバージョンが、2.7のようですので、pip3は使えません。(pip3は、python3.x系用です)


【追記】
selenium は最新バージョンも、python2.7以上またはpython3.4以上で使えますが、pillowはver.6.2.2までしかpython2.7に対応いないようです。
pillow 公式ページ参照:https://pillow.readthedocs.io/en/stable/installation.html

そのため、pillowをインストールする際は、以下のようにバージョンを指定してください。

Terminal

1$ pip install pillow==6.2.2

投稿2021/01/25 01:15

編集2021/01/25 01:27
_whitecat_22

総合スコア1305

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

apollo_

2021/01/25 01:31

回答ありがとうございます。 実行しても、下記のようになり、同じ問題に当たりました。 ``` python -m pip install --upgrade pip Traceback (most recent call last): File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 174, in _run_module_as_main "__main__", fname, loader, pkg_name) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 72, in _run_code exec code in run_globals File "/Library/Python/2.7/site-packages/pip-21.0-py2.7.egg/pip/__main__.py", line 21, in <module> from pip._internal.cli.main import main as _main File "/Library/Python/2.7/site-packages/pip-21.0-py2.7.egg/pip/_internal/cli/main.py", line 60 sys.stderr.write(f"ERROR: {exc}") ^ SyntaxError: invalid syntax ``` python3(Python 3.8.2)も入っているので、そちらの環境化で試そうと思い実行しました。 説明不足ですみません。
_whitecat_22

2021/01/25 01:52

$ pip install --U pip ($ pip install --upgrade pip の簡略系)でも同じですよね? python3系が入っているのであれば、そちらで動かしたほうが良いです。2系のサポートは切れてますし。。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問