質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.77%

(助けてください!)django, djangogirls「デプロイ!」でのエラー

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 914

YusukeNagata

score 12

django, djangogirls「デプロイ!」でのエラー

djangogirlsに沿ってdjangoのセットアップを進めています。
しかし、「デプロイ!」項にてつまづいてしまいました。(https://tutorial.djangogirls.org/ja/deploy/)
本当は、下のコードを実行後、コマンドラインに

 (ola.pythonanywhere.com) $~


と表示されるはずなのですが、うまく実行されません。
お忙しい中とは思いますが、ぜひお力を貸してください。

< Running API sanity checks >
   \
    ~<:>>>>>>>>>
Cloning into '/home/yuchandayo/yuchandayo.pythonanywhere.com'...
remote: Enumerating objects: 7828, done.
remote: Counting objects: 100% (7828/7828), done.
remote: Compressing objects: 100% (4716/4716), done.
remote: Total 7828 (delta 2093), reused 7828 (delta 2093), pack-reused 0
Receiving objects: 100% (7828/7828), 10.17 MiB | 0 bytes/s, done.
Resolving deltas: 100% (2093/2093), done.
Checking connectivity... done.
Checking out files: 100% (5681/5681), done.

< Creating virtualenv with Python3.5 >
   \
    ~<:>>>>>>>>>
Removing yuchandayo.pythonanywhere.com...
Running virtualenv with interpreter /usr/bin/python3.5
Using base prefix '/usr'
New python executable in /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/python3.5
Also creating executable in /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/python
Installing setuptools, pip, wheel...done.
virtualenvwrapper.user_scripts creating /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/predeactivate
virtualenvwrapper.user_scripts creating /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/postdeactivate
virtualenvwrapper.user_scripts creating /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/preactivate
virtualenvwrapper.user_scripts creating /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/postactivate
virtualenvwrapper.user_scripts creating /home/yuchandayo/.virtualenvs/yuchandayo.pythonanywhere.com/bin/get_env_details

  _____________________________________________________________________
/                                                                       \
| Pip installing -r                                                     |
| /home/yuchandayo/yuchandayo.pythonanywhere.com/requirements.txt (this |
| may take a couple of minutes)                                         |
\                                                                       /
  ---------------------------------------------------------------------
   \
    ~<:>>>>>>>>>
ERROR: Invalid requirement: '{\rtf1\ansi\ansicpg932\cocoartf1671\cocoasubrtf20
0'
Traceback (most recent call last):
  File "/home/yuchandayo/.local/bin/pa_autoconfigure_django.py", line 52, in <
module>
    main(arguments['<git-repo-url>'], arguments['--domain'], arguments['--pyth
on'], nuke=arguments.get('--nuke'))
  File "/home/yuchandayo/.local/bin/pa_autoconfigure_django.py", line 36, in m
ain
    project.create_virtualenv(nuke=nuke)
  File "/home/yuchandayo/.local/lib/python3.6/site-packages/pythonanywhere/dja
ngo_project.py", line 27, in create_virtualenv
    self.virtualenv.pip_install(packages)
  File "/home/yuchandayo/.local/lib/python3.6/site-packages/pythonanywhere/vir
tualenvs.py", line 30, in pip_install
    subprocess.check_call(commands)
  File "/usr/lib/python3.6/subprocess.py", line 291, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/home/yuchandayo/.virtualenvs/yuchan
dayo.pythonanywhere.com/bin/pip', 'install', '-r', '/home/yuchandayo/yuchanday
o.pythonanywhere.com/requirements.txt']' returned non-zero exit status 1.

該当のソースコード

pa_autoconfigure_django.py https://github.com/Yuspecter/my-first-blog.git --nuke

試したこと

調べてみたところ、Djangoのバージョンがどうのこうの...とありましたが理解できず、解決には至りませんでした。

補足情報(FW/ツールのバージョンなど)

Django~=2.0.6
PythonAnywhere

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hayataka2049

    2019/05/30 11:09

    理解できなかったサイトへのリンクも載せてほしいです!

    キャンセル

  • YusukeNagata

    2019/05/30 11:11

    https://tutorial.djangogirls.org/ja/deploy/

    上になります!失礼しました。

    キャンセル

  • hayataka2049

    2019/05/30 11:12

    Djangoのバージョンがどうのこうの...とあったサイトのことです。

    キャンセル

  • キャンセル

回答 1

-1

requirements.txt はそのプロジェクトで利用するパッケージの情報を記述するためのファイルで、通常次のような内容(各行にパッケージ名を記述したもの)を記述します。

pkg1
pkg2
pkg3>=1.0,<=2.0

質問文の中に書かれているリポジトリの requirements.txt ( https://github.com/Yuspecter/my-first-blog/blob/master/requirements.txt )を見てみると、次のようになっているので、この内容が間違っているのではないかと思います。

{\rtf1\ansi\ansicpg932\cocoartf1671\cocoasubrtf200
{\fonttbl}
{\colortbl;\red255\green255\blue255;}
{\*\expandedcolortbl;;}
\paperw9980\paperh14180\margl1440\margr1440\vieww10800\viewh8400\viewkind0
}

ですので、この中身を正しいものに修正されるとこのエラーの問題は解決するのではないでしょうか。

requirements.txt が何なのかご存知でない場合は次のページ等をご覧になってみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/02 11:24

    余談です。この類の質問の場合は、質問に初心者マークを付けておくと、回答をもらえる確率が上がるのではないかと思います :)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る