質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Python

    11729questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • pip

    235questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

pythonのライブラリインストールについて

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 421

plk

score 5

pythonライブラリのインストールについて質問させていただきます。

私は現在pipを用いて直接インストールすることができないため、
ライブラリのパッケージ(File tipe : wheel)をpypiからダウンロードし、
そこからpipコマンドを用いてインストールをしています。

初めにnumpyをインストールした際は無事にできたのですが、
pandasやmatplotlibをインストールしようとしたところ以下のような
エラーがでてインストールができませんでした。
どなたかご助言を頂けないでしょうか。
私の使用しているpcとライブラリのバージョン等の対応は合っているのを確認しております。

宜しくお願いいたします。

pc : windows8 64bit
python : 3.7.1

<以下エラー内容>
Processing c:\users\matplotlib-3.0.2-cp37-cp37m-win_amd64.whl
Requirement already satisfied: numpy>=1.10.0 in c:\users\junya\appdata\local\pro
grams\python\python37\lib\site-packages (from matplotlib==3.0.2) (1.15.4)
Collecting python-dateutil>=2.1 (from matplotlib==3.0.2)
Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None))
after connection broken by 'SSLError(SSLCertVerificationError(1, '[SSL: CERTIFI
CATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certif
icate (_ssl.c:1051)'))': /packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b
9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None))
after connection broken by 'SSLError(SSLCertVerificationError(1, '[SSL: CERTIFI
CATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certif
icate (_ssl.c:1051)'))': /packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b
9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None))
after connection broken by 'SSLError(SSLCertVerificationError(1, '[SSL: CERTIFI
CATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certif
icate (_ssl.c:1051)'))': /packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b
9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None))
after connection broken by 'SSLError(SSLCertVerificationError(1, '[SSL: CERTIFI
CATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certif
icate (_ssl.c:1051)'))': /packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b
9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None))
after connection broken by 'SSLError(SSLCertVerificationError(1, '[SSL: CERTIFI
CATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certif
icate (_ssl.c:1051)'))': /packages/74/68/d87d9b36af36f44254a8d512cbfc48369103a3b
9e474be9bdfe536abfc45/python_dateutil-2.7.5-py2.py3-none-any.whl
Could not install packages due to an EnvironmentError: HTTPSConnectionPool(host=
'files.pythonhosted.org', port=443): Max retries exceeded with url: /packages/74
/68/d87d9b36af36f44254a8d512cbfc48369103a3b9e474be9bdfe536abfc45/python_dateutil
-2.7.5-py2.py3-none-any.whl (Caused by SSLError(SSLCertVerificationError(1, '[SS
L: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local iss
uer certificate (_ssl.c:1051)')))

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

Collecting python-dateutil>=2.1 (from matplotlib==3.0.2)

matplotlibが内部で利用している別パッケージをダウンロードしようとして失敗しています。
pipを利用したダウンロードが使えないのであれば、これらも別の手段でダウンロードする必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/21 00:45

    ありがとうございます!
    勉強になりました!

    キャンセル

checkベストアンサー

0

matplotlibは複数のパッケージに依存しており、インストール時にそれらのパッケージも同時に入れようとします。
今回の場合はpython-dateutilをインストールしようとしてインターネットへの接続を試行した結果、繋がらずに提示エラーが発生しています。
よってこれらのパッケージもwheelインストールする必要があります。
なお、依存しているパッケージはDependenciesに記載されています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/21 00:46

    ありがとうございます!
    勉強になりました!

    より詳細に教えて頂いたのでベストアンサーとさせて頂きます。

    キャンセル

同じタグがついた質問を見る

  • Python

    11729questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • pip

    235questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。