質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Python 3.x

    6388questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Raspberry Pi

    804questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Keras

    209questions

ラズパイでkerasがエラーでインストールできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 255

masa328

score 1

Python 3.5.3 (default, Jan 19 2017, 14:11:04)
でkerasをインストールできません。

$ sudo pip3 install keras
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting keras
Using cached 
:(途中省略します)

Collecting pyyaml (from keras)
HTTP error 404 while getting https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl#sha256=a5b125a24244830d574ccfd8fab861198d2ffe491b73179ffd75abf78caee6ff (from https://www.piwheels.org/simple/pyyaml/)
Could not install requirement pyyaml from https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl#sha256=a5b125a24244830d574ccfd8fab861198d2ffe491b73179ffd75abf78caee6ff (from keras) because of error 404 Client Error: Not Found for url: https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl
Could not install requirement pyyaml from https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl#sha256=a5b125a24244830d574ccfd8fab861198d2ffe491b73179ffd75abf78caee6ff (from keras) because of HTTP error 404 Client Error: Not Found for url: https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl for URL https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl#sha256=a5b125a24244830d574ccfd8fab861198d2ffe491b73179ffd75abf78caee6ff (from https://www.piwheels.org/simple/pyyaml/)

結果・・・
$ python3
Python 3.5.3 (default, Jan 19 2017, 14:11:04)
[GCC 6.3.0 20170124] on linux
Type "help", "copyright", "credits" or "license" for more information.

import keras
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named 'keras'

とインストールできません。

お助けを・・・

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

masa328さん、

エラーメッセージを見ると、PyYAML-4.1-cp35-cp35m-linux_armv7l.whlを取得しようとして、エラー404になっています。

そのあたりで、ぐぐったりしてると、↓のようなものが出てきました

HTTP error 404 while getting https://www.piwheels.org/simple/pyyaml/PyYAML-4.1-cp35-cp35m-linux_armv7l.whl #204

ちょこちょこ読んでいくと、

Can't install pyyaml on RaspberryPi3 with python3 #203

4.1 Tagged Release Missing on PyPI #201

が出てきます。結局は、

4.1は壊れていたので削除された、とのことで、最新の安定版は3.13になるので、pip3 install pyyaml==3.13 で、インストールをしてくれ、とのことのようです。

sudo pip3 install pyyaml==3.13 をしてから、sudo pip3 install kerasしてみてはどうでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/17 22:22

    ありがとうございます。無事インストールできました!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 受付中

    cronの設定についてどなたか教えていただけませんか

    何卒よろしくお願いいたします。 前提・実現したいこと Linuxのパソコンを使っています。 自作したshell scriptを毎回決まった時間に自動で動作させたいと思って

  • 解決済

    guileインストール方法

    前提・実現したいこと Schemeを学んでいて、学校で使っているguileを自宅のPCでも使いたいと思いますが、うまくインストールできません。 terminal上でguileが

  • 解決済

    WordPressでプラグインが有効化できません

    前提・実現したいこと 当方htmlの知識は多少ありますが、PHPの知識は全くありません。 どうぞ宜しくお願い致します。 WordPressでプラグインをアップロードし、インスト

  • 受付中

    PyCharmのデバッガ起動時にPyQt5のPluginが読めない

    前提・実現したいこと PyCharmとPyQt5を使用しており、デバッガ時にQtのエラーが出てしまい、デバッグができない状況です。 なお、普通の実行ではエラーは出ずに正常に起動しま

  • 受付中

    service httpdの失敗

    前提・実現したいこと 自宅PCでWEBサーバを立てて勉強中です。 オレオレ証明書&秘密鍵を作成し、/etc/httpd/conf/に配置後、 service rehttpdとしたと

  • 解決済

    Elixirとkerasについてです。

    kerasでの処理を速くしようと思い、このサイト https://qiita.com/piacere/items/c1af7b6ce472db83cff6 に従って行っているのです

  • 解決済

    django 1.8⇨1.11(LTS)にupgradeした際に必要なこと

    ・前庭 Django,pythonでpycharmをつかってwebアプリケーションを作成しています。 ・目的 djangoのupgrade 上記に対して必要ライブラリー、pyt

  • 解決済

    model fit return ValueError ?

    #Dataset divide into two x_val = x_features[:10000] partial_x_train = x_features[10000:]

同じタグがついた質問を見る

  • Python 3.x

    6388questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Raspberry Pi

    804questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

  • Keras

    209questions