質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Python

    7969questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Chainer

    143questions

    Chainerは、国産の深層学習フレームワークです。あらゆるニューラルネットワークをPythonで柔軟に書くことができ、学習させることが可能。GPUをサポートしており、複数のGPUを用いた学習も直感的に記述できます。

  • Anaconda

    123questions

  • CUDA

    83questions

    CUDAは並列計算プラットフォームであり、Nvidia GPU(Graphics Processing Units)向けのプログラミングモデルです。CUDAは様々なプログラミング言語、ライブラリ、APIを通してNvidiaにインターフェイスを提供します。

chainer==1.5.1をインストールしたい

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 440

pumpavo

score 2

chainer-DCGANをコードを動かしたく

pip install chainer==1.5.1 --no-cache-dir

で1.5のchainerをinstallしたいのですが

Failed building wheel for chainer
Running setup.py clean for chainer
Failed to build chainer
tensorflow 1.7.0 has requirement tensorboard<1.8.0,>=1.7.0, but you'll have tensorboard 1.8.0 which is incompatible.
とエラーが出てインストールできません。

どのようにしたらインストールできるでしょうか?よろしくお願いします。

環境
windows
anaconda
Python 3.5.2
visual studio 2015
CUDA
cudnn

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

エラーメッセージによるとtensorboardのバージョン相違によるものなので、この対応をしてから再実行すればいいはずです。必要されるバージョンは1.7.x系と記載があるのでその通りにしてはいかがでしょうか

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

https://github.com/chainer/chainer/blob/v1.5.1/setup.py

tensorboardの依存性ありましたっけ?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/06 08:07

    そうなんです。ただ掲示されているメッセージからはそうとしか読めないんです。多分、chainer->tensorflow->tesorboardという依存ではないでしょうか

    キャンセル

  • 2018/07/06 08:44

    chainerはtensorflowの依存性もなかったはずです。

    pipの仕様がよくわかりませんが、
    chainerのビルドに失敗したのと全く別に、
    以前にtensorflow1.7をインストールし、その時にtensorboard1.7も入って、さらになぜかtensorboard1.8だけ入れて、くだん通りtensorflow周りの警告が出るようになったのを見ている可能性を主張してみます。

    キャンセル

  • 2018/07/06 08:45

    それか、その状態でchainerをインストールしようとした時にtensorflowの依存関係が壊れていることに気づいてエラーを出したか…

    キャンセル

  • 2018/07/06 11:50

    「pip install --upgrade tensorflow==1.7.0」をやってみると、次は「tensorflow-gpu 1.8.0 has requirement tensorboard<1.9.0,>=1.8.0, but you'll have tensorboard 1.7.0 which is incompatible.」と赤い文字で出てきました

    キャンセル

  • 2018/07/06 14:56

    tensorflowとtensorflow-gpuでバージョンが異なるせいで共通して使用されるtensorboardが大混乱したようですね。
    gpu版が動くのであれば、tensorflowの方をアンインストールした方がいいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    7969questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Chainer

    143questions

    Chainerは、国産の深層学習フレームワークです。あらゆるニューラルネットワークをPythonで柔軟に書くことができ、学習させることが可能。GPUをサポートしており、複数のGPUを用いた学習も直感的に記述できます。

  • Anaconda

    123questions

  • CUDA

    83questions

    CUDAは並列計算プラットフォームであり、Nvidia GPU(Graphics Processing Units)向けのプログラミングモデルです。CUDAは様々なプログラミング言語、ライブラリ、APIを通してNvidiaにインターフェイスを提供します。