質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.84%

  • Python

    6355questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • C

    3340questions

    C言語は、1972年にAT&Tベル研究所の、デニス・リッチーが主体となって作成したプログラミング言語です。 B言語の後継言語として開発されたことからC言語と命名。そのため、表記法などはB言語やALGOLに近いとされています。 Cの拡張版であるC++言語とともに、現在世界中でもっとも普及されているプログラミング言語です。

  • C++

    3133questions

    C++はC言語をもとにしてつくられた最もよく使われるマルチパラダイムプログラミング言語の1つです。オブジェクト指向、ジェネリック、命令型など広く対応しており、多目的に使用されています。

pythonライブラリを使用したいのですがzlibが必要だと言われてしまう ValueError: zlib is required unless explicitly disabled using

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 148

grilled_python

score 77

※パッチを追加した後を追記いたしました。

pythonのライブラリを使用したかったのですがzlibというライブラリが必須ということでwindows10にインストールしたいです。cygwinを導入して、デスクトップにzipファイルを解凍。
$ cd zlib-1.2.11
$ ./configure --shared
$ make
$ make install
の順番でコマンド実行したのですが、makeの部分でエラーが出てしまいました。
どのように対処すればいいでしょうか。

$ ./configure --shared
Checking for gcc...
Checking for shared library support...
No shared library support.
Building static library libz.a version 1.2.11 with gcc.
Checking for size_t... Yes.
Checking for off64_t... No.
Checking for fseeko... Yes.
Checking for strerror... Yes.
Checking for unistd.h... Yes.
Checking for stdarg.h... Yes.
Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf().
Checking for vsnprintf() in stdio.h... Yes.
Checking for return value of vsnprintf()... Yes.
Checking for attribute(visibility) support... No.
$ make
gcc -O3 -I. -c -o example.o test/example.c
gcc -O3  -c -o adler32.o adler32.c
gcc -O3  -c -o crc32.o crc32.c
gcc -O3  -c -o deflate.o deflate.c
gcc -O3  -c -o infback.o infback.c
gcc -O3  -c -o inffast.o inffast.c
gcc -O3  -c -o inflate.o inflate.c
gcc -O3  -c -o inftrees.o inftrees.c
gcc -O3  -c -o trees.o trees.c
gcc -O3  -c -o zutil.o zutil.c
gcc -O3  -c -o compress.o compress.c
gcc -O3  -c -o uncompr.o uncompr.c
gcc -O3  -c -o gzclose.o gzclose.c
gcc -O3  -c -o gzlib.o gzlib.c
gzlib.c: 関数 ‘gz_open’ 内:
gzlib.c:243:20: 警告: implicit declaration of function ‘_wopen’; did you mean ‘f                                   wopen’? [-Wimplicit-function-declaration]
         fd == -2 ? _wopen(path, oflag, 0666) :
                    ^~~~~~
                    fwopen
gcc -O3  -c -o gzread.o gzread.c
gcc -O3  -c -o gzwrite.o gzwrite.c
ar rc libz.a adler32.o crc32.o deflate.o infback.o inffast.o inflate.o inftrees.                                   o trees.o zutil.o compress.o uncompr.o gzclose.o gzlib.o gzread.o gzwrite.o
gcc -O3 -o example.exe example.o -L. libz.a
libz.a(gzlib.o):gzlib.c:(.text+0xab2): `_wopen' に対する定義されていない参照です
libz.a(gzlib.o):gzlib.c:(.text+0xab2): 再配置がオーバーフローしないように切り詰                                   められました: R_X86_64_PC32 (未定義シンボル `_wopen' に対して)
libz.a(gzlib.o):gzlib.c:(.text+0xc50): `_wopen' に対する定義されていない参照です
libz.a(gzlib.o):gzlib.c:(.text+0xc50): 再配置がオーバーフローしないように切り詰                                   められました: R_X86_64_PC32 (未定義シンボル `_wopen' に対して)
collect2: エラー: ld はステータス 1 で終了しました
make: *** [Makefile:289: example.exe] エラー 1
$ make install
rm -f /usr/local/lib/libz.a
cp libz.a /usr/local/lib
chmod 644 /usr/local/lib/libz.a
rm -f /usr/local/share/man/man3/zlib.3
cp zlib.3 /usr/local/share/man/man3
chmod 644 /usr/local/share/man/man3/zlib.3
rm -f /usr/local/lib/pkgconfig/zlib.pc
cp zlib.pc /usr/local/lib/pkgconfig
chmod 644 /usr/local/lib/pkgconfig/zlib.pc
rm -f /usr/local/include/zlib.h /usr/local/include/zconf.h
cp zlib.h zconf.h /usr/local/include
chmod 644 /usr/local/include/zlib.h /usr/local/include/zconf.h

 使用したいライブラリを追記

django-dynamic-scraperというdjango上でscrapyを管理するライブラリです。
windows10
django1.11
Python3.4
pip install django-dynamic-scraperの段階で

  Failed building wheel for pillow


ValueError: zlib is required unless explicitly disabled using --disable-zlib, aborting


などのエラーが出てしまいます。

 cygwinの中にwopenが無いために起こるエラーに対するパッチを当てました。 

パッチ1
パッチ2
こちらを当てた事で警告がでない様になり、インストールが上手くいった様に思えたので、今一度pip installを行いまいましたが、結果は同じエラーでした。
cygwinのコマンドとログを載せます。なにか根本的に間違っているのでしょうか?

$ cd zlib-1.2.11
$ ./configure 
$ make
$ make install

$ ./configure
Checking for gcc...
Checking for shared library support...
No shared library support.
Building static library libz.a version 1.2.11 with gcc.
Checking for size_t... Yes.
Checking for off64_t... No.
Checking for fseeko... Yes.
Checking for strerror... Yes.
Checking for unistd.h... Yes.
Checking for stdarg.h... Yes.
Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf().
Checking for vsnprintf() in stdio.h... Yes.
Checking for return value of vsnprintf()... Yes.
Checking for attribute(visibility) support... No.
$ make
gcc -O3 -I. -c -o example.o test/example.c
gcc -O3  -c -o adler32.o adler32.c
gcc -O3  -c -o crc32.o crc32.c
gcc -O3  -c -o deflate.o deflate.c
gcc -O3  -c -o infback.o infback.c
gcc -O3  -c -o inffast.o inffast.c
gcc -O3  -c -o inflate.o inflate.c
gcc -O3  -c -o inftrees.o inftrees.c
gcc -O3  -c -o trees.o trees.c
gcc -O3  -c -o zutil.o zutil.c
gcc -O3  -c -o compress.o compress.c
gcc -O3  -c -o uncompr.o uncompr.c
gcc -O3  -c -o gzclose.o gzclose.c
gcc -O3  -c -o gzlib.o gzlib.c
gcc -O3  -c -o gzread.o gzread.c
gcc -O3  -c -o gzwrite.o gzwrite.c
ar rc libz.a adler32.o crc32.o deflate.o infback.o inffast.o inflate.o inftrees.o trees.o zutil.o compress.o uncompr.o gzclose.o gzlib.o gzread.o gzwrite.o
gcc -O3 -o example.exe example.o -L. libz.a
gcc -O3 -I. -c -o minigzip.o test/minigzip.c
gcc -O3 -o minigzip.exe minigzip.o -L. libz.a
$ make install
rm -f /usr/local/lib/libz.a
cp libz.a /usr/local/lib
chmod 644 /usr/local/lib/libz.a
rm -f /usr/local/share/man/man3/zlib.3
cp zlib.3 /usr/local/share/man/man3
chmod 644 /usr/local/share/man/man3/zlib.3
rm -f /usr/local/lib/pkgconfig/zlib.pc
cp zlib.pc /usr/local/lib/pkgconfig
chmod 644 /usr/local/lib/pkgconfig/zlib.pc
rm -f /usr/local/include/zlib.h /usr/local/include/zconf.h
cp zlib.h zconf.h /usr/local/include
chmod 644 /usr/local/include/zlib.h /usr/local/include/zconf.h


anacondaのenvにインストールしないと意味がないのではと思い。

$ cd zlib-1.2.11
$ ./configure --prefix=/users/jun/anaconda3/env/dds
$ make
$ make install
結果は同じようです。

pycharmに戻りターミナルから
pip install django-dynamic-scraper
ログが長いので一部を抜粋

(dds) C:\Users\Jun\PycharmProjects\dds>pip install django-dynamic-scraper
Collecting django-dynamic-scraper
====================================
Building wheels for collected packages: pillow
  Running setup.py bdist_wheel for pillow ... error
=======================================
  ValueError: zlib is required unless explicitly disabled using --disable-zlib, aborting

  ----------------------------------------
  Failed building wheel for pillow
  Running setup.py clean for pillow
Failed to build pillow
Installing collected packages: future, pillow, decorator, ply, six, jsonpath-rw, django-dynamic-scraper
  Running setup.py install for pillow ... error
======================================
    ValueError: zlib is required unless explicitly disabled using --disable-zlib, aborting

    ----------------------------------------
Command "C:\Users\Jun\Anaconda3\envs\dds\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\Jun\\AppData\\Local\\T
emp\\pip-install-nz0vhaly\\pillow\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.clo
se();exec(compile(code, __file__, 'exec'))" install --record C:\Users\Jun\AppData\Local\Temp\pip-record-c2ybtkgm\install-record.tx
t --single-version-externally-managed --compile" failed with error code 1 in C:\Users\Jun\AppData\Local\Temp\pip-install-nz0vhaly\
pillow\
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • sh_akira

    2018/06/25 18:57

    そもそもの使いたいpythonのライブラリを教えてもらった方が早いかもしれませんね。参考までにビルドエラーを直すには「gzlib.c undefined reference to _wopen」 とかを検索ワードにすると良いかと思います。そもそもの問題のPythonのモジュールインストールは https://stackoverflow.com/questions/38733647/cant-install-pillow-for-python-3-x-in-windows-zlib-is-required これとかで解決しないですかね。

    キャンセル

  • grilled_python

    2018/06/25 20:04

    ありがとうございます。情報を追加いたしました。

    キャンセル

  • grilled_python

    2018/06/25 20:34

    ありがとうございます。情報を追加いたしました。教えていただいたキーワードとリンク先の情報を探してみます。

    キャンセル

回答 2

checkベストアンサー

+1

cygwinにはwopenがないので、上記エラーがでるんですね。

https://stackoverflow.com/questions/42537454/compiling-gcc-7-20170212-on-windows-7-64-with-cygwin-wopen-error

ここに2つパッチが紹介されています。
試してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/26 15:59

    回答ありがとうございます。このパッチの情報に一度行きついたのですが、合っているのか分からなくて力尽きておりました。情報を頂けた事によってもう一度パッチの当て方から頑張ってみようと思います。

    キャンセル

+1

zlibに関してはcygwinからapt-cygコマンドを導入して
$ apt-cyg zlib
でちゃんとインストール出来ました。
調べた結果pillowとzlibとwindowsは相性が悪いような事が書いてありました。
これ以上は初心者の自分には難しい問題だと思ったので、これで調べる事を終わろうと思います。
アドバイスをくれた方々に感謝いたします。
pillow公式

Building on Windows
We don’t recommend trying to build on Windows. It is a maze of twisty passages, mostly dead ends. There are build scripts and notes for the Windows build in the winbuild directory.

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.84%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    6355questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • C

    3340questions

    C言語は、1972年にAT&Tベル研究所の、デニス・リッチーが主体となって作成したプログラミング言語です。 B言語の後継言語として開発されたことからC言語と命名。そのため、表記法などはB言語やALGOLに近いとされています。 Cの拡張版であるC++言語とともに、現在世界中でもっとも普及されているプログラミング言語です。

  • C++

    3133questions

    C++はC言語をもとにしてつくられた最もよく使われるマルチパラダイムプログラミング言語の1つです。オブジェクト指向、ジェネリック、命令型など広く対応しており、多目的に使用されています。

  • トップ
  • C++に関する質問
  • pythonライブラリを使用したいのですがzlibが必要だと言われてしまう ValueError: zlib is required unless explicitly disabled using