質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.84%

  • Python 3.x

    4874questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • pandas

    417questions

    Pandasは、PythonでRにおけるデータフレームに似た型を持たせることができるライブラリです。 行列計算の負担が大幅に軽減されるため、Rで行っていた集計作業をPythonでも比較的簡単に行えます。 データ構造を変更したりデータ分析したりするときにも便利です。

(Python)pandas_datareaderのインポート失敗について

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 663

masu

score 1

 前提・実現したいこと

https://qiita.com/akichikn/items/782033e746c7ee6832f5
上記サイトを参考に、Pythonで株価を取得したいと思っています。
しかし、pandas_datareaderのimport時点で以下のエラーメッセージが発生しました。
初歩の初歩の質問で恐縮ですが、何卒ご教示いただけると幸いです

 発生している問題・エラーメッセージ

※**** = ユーザ名
※test.py = テスト用のファイル名

Traceback (most recent call last):
File "C:/Users/**/AppData/Local/Programs/Python/Python36-32/test.py", line 1, in <module> import pandas_datareader File "C:\Users\**\AppData\Local\Programs\Python\Python36-32\lib\site-packages\pandas_datareader\init.py", line 2, in <module>
from .data import (DataReader, Options, get_components_yahoo,
File "C:\Users\**\AppData\Local\Programs\Python\Python36-32\lib\site-packages\pandas_datareader\data.py", line 14, in <module> from pandas_datareader.fred import FredReader File "C:\Users\**\AppData\Local\Programs\Python\Python36-32\lib\site-packages\pandas_datareader\fred.py", line 1, in <module>
from pandas.core.common import is_list_like
ImportError: cannot import name 'is_list_like'

 該当のソースコード

import pandas_datareader.data as web

 試したこと

・Python3.6の再インストール
・Pythonのアップグレード
・print("Hello")等、標準の機能は正常に使えること

 補足情報(FW/ツールのバージョンなど)

・Anaconda環境は利用していません
・pip install pandas.datareaderでモジュールはインストールしています

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

コメントが付かないようですので、とりあえずヒントになるかも知れないコメントです。

自分もPyCharmでやってみたところ再現しました。問題の

pandas_datareader\fred.py", line 1, in <module>
from pandas.core.common import is_list_like
ImportError: cannot import name 'is_list_like'


ですが、pandas.core.commonにはis_list_likeは存在しないためpandas_datareaderのissuesを当たったところ

https://github.com/pydata/pandas-datareader/pull/520

こんなの見つけました。pandasの仕様変更によりis_list_likeの定義モジュールが移動し、pandas_datareaderに手を入れなければならないという話のようでした。GitHubの最新ソースfred.pyを見たところ1行目が

from pandas.core.common import is_list_like
=>
from pandas_datareader.compat import is_list_like
に修正されてるようです。

PyCharmでインストールしたpandas_datareaderのバージョンは0.6.0ですが

https://pydata.github.io/pandas-datareader/stable/

を見ますとstable versionの最新が0.6.0に見えたので今現在pipで普通にインストールしたのでは「壊れたpandas_datareaderしか入らない」ということなのかなと思いました(このあたり自信ないです)


残念ながら自分にはどうすべきかはっきり分かりません。development versionをインストールするぐらいしか思いつきません。
変なこと書いちゃいましたが普通はpandasのダウングレードですね!
hayataka2049さんご指摘ありがとうございます。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/18 09:31

    ん、そういう話ならpandasのダウングレードで良いんでは?

    キャンセル

  • 2018/05/18 10:07

    う、おっしゃるとおりですね!
    せっかく入ってる新しいバージョンを戻すのがもったいないという意識が働いてました。
    Pythonの環境構築はいまだに苦手でどうすべきか自信持てないです...

    キャンセル

  • 2018/05/18 22:12

    お二人ともご回答ありがとうございます!
    ダウングレードと、development verの両方を試してみます

    キャンセル

  • 2018/05/18 22:15 編集

    両方は要らんです。リンク先のリンク先のスタックオーバーフローにworking well with 0.21.0とか書いてあるので、恐らくそれで大丈夫でしょう。どうしても新しいpandasを使いたい事情がない限りは安牌です

    キャンセル

  • 2018/05/18 22:25

    ですねー。
    なんかボケっとしてましたが回答訂正しときます!

    キャンセル

  • 2018/05/19 09:49

    お二人とも、更にご回答ありがとうございます。
    pandasを0.21.0にダウングレードすることで、無事に解決することができました。
    本当にありがとうございました!

    キャンセル

0

こちらによると、モジュールが改定になったようです。
https://pandas-datareader.readthedocs.io/en/latest/

pandasの0.19.X以降であれば以下でデータ取得できるようです。

import pandas_datareader as pdr

import datetime

start = datetime.datetime(2010, 1, 1)
end = datetime.datetime(2013, 1, 1)

prices = pdr.DataReader(['CVX','XOM','BP'],'morningstar', start, end).unstack(0)['Close']

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/19 09:51

    補足いただきありがとうございます。
    リンク先の情報も参考にさせていただきました。
    確かに0.19.X以降であればデータ取得できることも確認できました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.84%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python 3.x

    4874questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • pandas

    417questions

    Pandasは、PythonでRにおけるデータフレームに似た型を持たせることができるライブラリです。 行列計算の負担が大幅に軽減されるため、Rで行っていた集計作業をPythonでも比較的簡単に行えます。 データ構造を変更したりデータ分析したりするときにも便利です。