composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

RSS

  • 解決済

    回答
    2

    composerでcakephpインストールしたが、autoloadがない

    エラー Problem 1 - cakephp/cakephp 3.4.5 requires ext-intl * -> the requested PHP extension intl is missing from your system. - cakephp/cakephp 3.4.4 requires ext-intl * -> t

    • -1評価
    • 39PV
    chNOBUNAGA chNOBUNAGA 5日前
  • 解決済

    回答
    1

    CakePHPのインストール時のエラー対応方法が分からない

    前提・実現したいこと 「cakePHPをインストールしctpファイルの編集がしたい」と考えている者です。 エラーメッセージから、php.iniファイルの何らかの不足を補えということは分かりましたが、方法が分かりません。 似た状況の方の質問も拝見しましたが、よくわかりませんでした… ご教授お願いいたします。 Windows10、XAMPP入り

    • 0評価
    • 47PV
    newKanao newKanao 6日前
  • 解決済

    回答
    2

    LaravelをComposerでインストールしたが、.envファイルが見当たらない。

    表題のとおりです。隠しファイルになっているのでしょうか。なくても直接書き込めば解決しますが、すべての場所に書くのはめんどくさいので見つける方法があったら教えて下さい。 以下のサイトを参考にインストールしました。 環境はAWSのEC2(Amazon Linux)に構築しました。 http://qiita.com/na0AaooQ/items/e9b7

    • 0評価
    • 57PV
    Hir Hir 1週間前
  • 受付中

    回答
    0

    Composerインストールについて

    The PHP exe file you specified did not run correctly [exit code 1]: C:\xampp\php\php.exe No output was returned. このようなエラーが出ます対処の仕方を教えてください。お願いします

    • 0評価
    • 49PV
    nappayokero78 nappayokero78 1週間前
  • 受付中

    回答
    0

    cakePHPインストール方法

    前提・実現したいこと 今Windows10にcomposerをインストールし、コマンドプロンプトを用いて CakePHPをインストールしようと思っています。 composer.jsonファイルを作成した場所に移動し(xampp→htdogs)、 “composer install” を実行したところ、画像のようなjson does not contai

    • 0評価
    • 54PV
    yumayuma yumayuma 3週間前
  • 受付中

    回答
    1

    Mac Laravel5.4 をアンインストールし、Laravel5.1 をインストールするには

    前提・実現したいこと mac、composer 1.3.2 ,PHP 7.0.15を使用しています。 Laravel5.4 をアンインストールし、Laravel5.1 をインストールするには どうしたら良いでしょうか? アプリケーションファルダに、Laravel5.3が存在していないのですが、 php artisan --version

    • 0評価
    • 86PV
    qmomo qmomo 1ヶ月前
  • 解決済

    回答
    1

    composerの使用時に生じるPHPのバージョンの不一致

    前提・実現したいこと 使用しているレンタルサーバーはロリポップのスタンダードプランです。 composerを使ってTwilio PHP SDKをインストールしようとしたところPHPのバージョンが条件を満たしていないという趣旨のエラーメッセージが吐かれます。 しかしphpinfo()で確認できるPHPバージョンもphp-vで確認できるバージョンが7と表示

    • 0評価
    • 95PV
    gogandantesu gogandantesu 1ヶ月前
  • 受付中

    回答
    0

    php artisan --help をするとメモリエラーになってしまう

    composer を使用し、laravel でプロジェクトを作成たあと。 composer require 'laralib/l5scaffold' --dev を実装したところ、以下のエラーが表示されるようになりました。 エラーの解決方法をご教授してください。 発生している問題・エラーメッセージ php artisan --help や、co

    • 0評価
    • 68PV
    qmomo qmomo 1ヶ月前
  • 解決済

    回答
    1

    composer.json、composer.lockのgit管理方法

    cpmposerはとても便利なのですが、いつもgitでの管理方法を迷います。 例えば、新規で新しいパッケージを追加する時は、 composer.jsonに追加して、composer updateすれば、 composer.lockが最新化されるかと思います。 そしてgit pushすればリモートが最新化されますね。 そのあとに別の人がgit p

    • 0評価
    • 80PV
    speed_star777 speed_star777 1ヶ月前
  • 受付中

    回答
    1

    laravelでsocialiteの利用

    laravel5.1です。 socialiteを使用としています。 composer require laravel/socialite とやってみたところエラーが出ました。 ./composer.json has been updated Loading composer repositories with package informa

    • 0評価
    • 77PV
    atemu atemu 2ヶ月前
  • 受付中

    回答
    0

    レンタルサーバーへのcomposerインストール

    前提・実現したいこと レンタルサーバー(共用サーバー)のバリューサーバーでlaravelを使おうと思っています。が、その前にcomposerのコマンドが使用できません。 下記サイトを参考しインストールしました。 http://laravel.hatenablog.com/entry/2013/11/28/000910 発生している問題・エラーメッ

    • 0評価
    • 108PV
    sumomomomomo sumomomomomo 2ヶ月前
  • 解決済

    回答
    1

    composer installに失敗します[Undefined variable: baseDir...

    前提・実現したいこと 既存ソースを元に、PHP(CakePHP)の環境をLinux(Ubuntu)上に作ろうとしています。 composer.json,composer.lockファイルが存在していたため、 composer installを実行したのですが、 エラーが出てしまいます。 当方、Composerどころか、PHP、CakePHP、L

    • 0評価
    • 126PV
    AkikoS AkikoS 3ヶ月前
  • 受付中

    回答
    1

    Composer(php)が上手くインストールできません

    プログラミング初心者です。phpの開発にcomposerをインストールする必要があるのですが上手くいきません。大変お忙しい中、恐縮ですが教えてください。 PCのosはmacOS Sierra 10.12.2です。 インストール方法はら以下サイトを参考にしています。 http://peachcle.com/install-the-cakephp3

    • 0評価
    • 143PV
    MatsumuraYu MatsumuraYu 3ヶ月前
  • 解決済

    回答
    1

    composer が使用できないサーバーで cowitter を使用したい

    件名の通りです。 サーバーは CPI ACE 01 を使用しています。 http://qiita.com/beru222/items/8311f220b6605319b8ca サーバーを変える以外に方法はないでしょうか? 「GitHubからzipで落としてきて展開する」という方法を取った場合、 composer.json に書いてあるファイ

    • 0評価
    • 194PV
    pac894398 pac894398 3ヶ月前
  • 解決済

    回答
    1

    指定バージョンのCakePHPをインストールする方法について

    CakePHPのインストールに関する質問です。 Windows10、PHP 5.6.24という環境にCakePHPの3.1.14をインストールしたいのですが、 最新バージョンの3.3.4がインストールされてしまいます。 composer.json { "require": { "cakephp/cakephp": "3

    • 1評価
    • 212PV
    maki3 maki3 4ヶ月前
  • 解決済

    回答
    1

    Composer Composer.json

    独習PHP第3版という本の278ページでComposerをインストールしたあと、パッケージ定義ファイルで定義しておくのが基本と紹介されており、Composer.jsonをアプリケーションルート直下に配置するとあるんですが、具体的にどこに配置すればいいのかわかりません。 自分はWindowsでデスクトップにPHPフォルダを作ってその中にPHPファイルをい

    • 0評価
    • 167PV
    ryohasegawa ryohasegawa 4ヶ月前
  • 解決済

    回答
    2

    CentOS6.8(64bit)にPHP5.4以上をインストールしLaravel環境を構築したい(3...

    CentOS6.8(64bit)にPHP5.6をインストールした後、Laravel環境を構築しようと、Composerを インストールしました。 []# curl -sS https://getcomposer.org/installer | php ・・・・・ Composer successfully installed to: /root

    • 0評価
    • 317PV
    kanrin0 kanrin0 4ヶ月前
  • 受付中

    回答
    1

    composer install しようとするとmemoryによるエラーが起きる。

    composer install を実行すると Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 16777216 bytes) in phar:///usr/local/Cellar/composer/1.2.2/libexec/co

    • 0評価
    • 294PV
    maaaalon maaaalon 4ヶ月前
  • 解決済

    回答
    1

    CentOS6.8(64bit)にPHP5.4以上をインストールしLarabel環境を構築したい(2...

    CentOS6.8(64bit)にPHP5.6をインストールした後、Larabel環境を構築したいとです。 []# php -v PHP 5.6.28 (cli) (built: Nov 9 2016 07:23:55) Copyright (c) 1997-2016 The PHP Group Zend Engine v2.6.0, Copyr

    • 0評価
    • 178PV
    kanrin0 kanrin0 4ヶ月前
  • 解決済

    回答
    1

    [初心者] CakePHP3 のインストール時のエラー

    前提・実現したいこと CakePHP3のインストール 発生している問題・エラーメッセージ (composerをインストールした後) [vagrant@localhost cakephp_lessons]$ php composer.phar create-project --prefer-dist cakephp/app myapp Failed

    • 0評価
    • 225PV
    ogasannnnn ogasannnnn 5ヶ月前
1

タグ情報

  • あなたの順位

    -

  • タグ登録者数

    19

  • 総質問数

    68

  • 今週の質問数

    2

関連するタグ

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る