質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.53%
PyTorch

PyTorchは、オープンソースのPython向けの機械学習ライブラリ。Facebookの人工知能研究グループが開発を主導しています。強力なGPUサポートを備えたテンソル計算、テープベースの自動微分による柔軟なニューラルネットワークの記述が可能です。

Flask

FlaskはPython用のマイクロフレームワークであり、Werkzeug・Jinja 2・good intentionsをベースにしています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

Q&A

解決済

1回答

170閲覧

PyTorchをインストールしたい

yasuuu

総合スコア9

PyTorch

PyTorchは、オープンソースのPython向けの機械学習ライブラリ。Facebookの人工知能研究グループが開発を主導しています。強力なGPUサポートを備えたテンソル計算、テープベースの自動微分による柔軟なニューラルネットワークの記述が可能です。

Flask

FlaskはPython用のマイクロフレームワークであり、Werkzeug・Jinja 2・good intentionsをベースにしています。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

0グッド

0クリップ

投稿2023/11/11 01:35

編集2023/11/14 13:55

実現したいこと

  • PyTorchをインストールする

前提

Flaskで物体検知機能アプリを作っています。
そのために、下記のようにPyTorchをインストールしようとしたのですが、エラーが出てしまいます。

(venv) $ pip install torch torchvision opencv-python

発生している問題・エラーメッセージ

ERROR: Could not find a version that satisfies the requirement torch (from versions: none) ERROR: No matching distribution found for torch

該当のソースコード

なし

試したこと

  • 調べると、PyTorchはPython3.11.xまでしかサポートしていないようだったので、今のvenv内でpythonのバージョンを下げられないか?とさらに調べましたが、その方法が分かりませんでした。
  • 今のvenvでは、python3.12.0です。
  • 仮想環境内のPythonバージョンを切り替えるためには、venvの--clearオプションを利用して仮想環境を一度クリアする必要があルようですが、それだと、pip installしていたモジュールもクリアされるとのことで困っています。(Pythonのバージョンを下げる以外はイジりたくない)

補足情報(FW/ツールのバージョンなど)

なし

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hoshi-takanori

2023/11/11 06:18

OS の種類とバージョンは何ですか? また、python はどうやってインストールしましたが?
yasuuu

2023/11/11 07:01

macOS Sonoma 14.0です。 pythonは、公式サイトからダウンロードしました。
jbpb0

2023/11/11 08:55

> Pythonのバージョンを下げる以外はイジりたくない pipで入れるものの多くは、pythonのバージョン毎に別のものが用意されてて、インストールする環境のpythonのバージョンに合うものが自動的に選ばれてインストールされます (そうじゃないものもあるけど、そんなに多くない) なので、あるバージョンのpythonの環境にインストールしたものの多くは、別のバージョンのpythonでは使えません
yasuuu

2023/11/11 09:02

なるほどです。では、仮にpythonのバージョンを下げて、PyTorchがインストールできたとしても、他のpipでこれまでに入れたものが、正常に動かなくなる可能性があるということでしょうか?
guest

回答1

0

自己解決

今のvenvだけで解決することを諦め、新しいvenv(venv2)を作り、そちらでpython3.11.6を利用することにした。すると、問題なくPyTorchをインストールできた。

投稿2023/11/14 04:55

yasuuu

総合スコア9

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.53%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問