質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

VirtualBox

VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。

受付中

Ubuntu22.04でVirtualboxが正常にインストールされない

reimen
reimen

総合スコア0

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

VirtualBox

VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。

1回答

0グッド

1クリップ

417閲覧

投稿2022/11/04 13:05

編集2022/11/05 02:09

前提

Ubuntu22.04にて、Virtualboxをインストールしようとした際に、以下のエラーメッセージが発生し、Virtualboxが動作しません。
もし、原因や解決方法がわかる方がいらっしゃいましたら、教えていただけますでしょうか。

実現したいこと

VirtualboxをUbuntu22.04へ正常にインストールしたい。

発生している問題・エラーメッセージ

XXXXX$ sudo apt install virtualbox パッケージリストを読み込んでいます... 完了 依存関係ツリーを作成しています... 完了 状態情報を読み取っています... 完了 以下の追加パッケージがインストールされます: virtualbox-qt 提案パッケージ: vde2 virtualbox-guest-additions-iso 以下のパッケージが新たにインストールされます: virtualbox virtualbox-qt アップグレード: 0 個、新規インストール: 2 個、削除: 0 個、保留: 3 個。 45.4 MB 中 0 B のアーカイブを取得する必要があります。 この操作後に追加で 172 MB のディスク容量が消費されます。 続行しますか? [Y/n] y 以前に未選択のパッケージ virtualbox を選択しています。 (データベースを読み込んでいます ... 現在 208248 個のファイルとディレクトリがインストールされています。) .../virtualbox_6.1.38-dfsg-3~ubuntu1.22.04.1_amd64.deb を展開する準備をしています ... virtualbox (6.1.38-dfsg-3~ubuntu1.22.04.1) を展開しています... 以前に未選択のパッケージ virtualbox-qt を選択しています。 .../virtualbox-qt_6.1.38-dfsg-3~ubuntu1.22.04.1_amd64.deb を展開する準備をしています ... virtualbox-qt (6.1.38-dfsg-3~ubuntu1.22.04.1) を展開しています... virtualbox (6.1.38-dfsg-3~ubuntu1.22.04.1) を設定しています ... Job for virtualbox.service failed because the control process exited with error code. See "systemctl status virtualbox.service" and "journalctl -xeu virtualbox.service" for details. invoke-rc.d: initscript virtualbox, action "restart" failed. × virtualbox.service - LSB: VirtualBox Linux kernel module Loaded: loaded (/etc/init.d/virtualbox; generated) Active: failed (Result: exit-code) since Fri 2022-11-04 21:48:25 JST; 4ms ago Docs: man:systemd-sysv-generator(8) Process: 40970 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE) CPU: 27ms 11月 04 21:48:25 mr-02 systemd[1]: Starting LSB: VirtualBox Linux kernel module... 11月 04 21:48:25 mr-02 virtualbox[40970]: * Loading VirtualBox kernel modules... 11月 04 21:48:25 mr-02 virtualbox[40970]: * modprobe vboxdrv failed. Please use 'dmesg' to find out why 11月 04 21:48:25 mr-02 virtualbox[40970]: ...fail! 11月 04 21:48:25 mr-02 systemd[1]: virtualbox.service: Control process exited, code=exited, status=1/FAILURE 11月 04 21:48:25 mr-02 systemd[1]: virtualbox.service: Failed with result 'exit-code'. 11月 04 21:48:25 mr-02 systemd[1]: Failed to start LSB: VirtualBox Linux kernel module. virtualbox-qt (6.1.38-dfsg-3~ubuntu1.22.04.1) を設定しています ... mailcap (3.70+nmu1ubuntu1) のトリガを処理しています ... desktop-file-utils (0.26-1ubuntu3) のトリガを処理しています ... hicolor-icon-theme (0.17-2) のトリガを処理しています ... gnome-menus (3.36.0-1ubuntu3) のトリガを処理しています ... man-db (2.10.2-1) のトリガを処理しています ... shared-mime-info (2.1-2) のトリガを処理しています ... XXXXX$

試したこと

エラーを見た限りだと、Linuxカーネルモジュール周りでエラーが起きていると考え、以下のサイトの方法を試しましたが、既に最新バージョンになっているため、効果がありませんでした。
http://snowdrop.asia/ubuntu%E3%81%AEvirtualbox%E3%81%8C%E8%B5%B7%E5%8B%95%E3%81%97%E3%81%AA%E3%81%84%E5%95%8F%E9%A1%8C-2/

(11/5追記)
過去バージョン(virtualbox6.1)についてもインストールを試みたのですが、こちらも以下のようなエラーが発生してインストールできませんでした。

XXXXX$ sudo dpkg -i virtualbox-6.1_6.1.40-154048~Ubuntu~jammy_amd64.deb 以前に未選択のパッケージ virtualbox-6.1 を選択しています。 (データベースを読み込んでいます ... 現在 207729 個のファイルとディレクトリがインストールされています。) virtualbox-6.1_6.1.40-154048~Ubuntu~jammy_amd64.deb を展開する準備をしています ... virtualbox-6.1 (6.1.40-154048~Ubuntu~jammy) を展開しています... dpkg: 依存関係の問題により virtualbox-6.1 の設定ができません: virtualbox-6.1 は以下に依存 (depends) します: libqt5core5a (>= 5.15.1) ...しかし: パッケージ libqt5core5a:amd64 はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libqt5gui5 (>= 5.14.1) | libqt5gui5-gles (>= 5.14.1) ...しかし: パッケージ libqt5gui5:amd64 はまだインストールされていません。 パッケージ libqt5gui5-gles はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libqt5opengl5 (>= 5.0.2) ...しかし: パッケージ libqt5opengl5 はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libqt5printsupport5 (>= 5.0.2) ...しかし: パッケージ libqt5printsupport5 はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libqt5widgets5 (>= 5.15.1) ...しかし: パッケージ libqt5widgets5 はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libqt5x11extras5 (>= 5.6.0) ...しかし: パッケージ libqt5x11extras5 はまだインストールされていません。 virtualbox-6.1 は以下に依存 (depends) します: libsdl1.2debian (>= 1.2.11) ...しかし: パッケージ libsdl1.2debian はまだインストールされていません。 dpkg: パッケージ virtualbox-6.1 の処理中にエラーが発生しました (--install): 依存関係の問題 - 設定を見送ります mailcap (3.70+nmu1ubuntu1) のトリガを処理しています ... gnome-menus (3.36.0-1ubuntu3) のトリガを処理しています ... desktop-file-utils (0.26-1ubuntu3) のトリガを処理しています ... hicolor-icon-theme (0.17-2) のトリガを処理しています ... shared-mime-info (2.1-2) のトリガを処理しています ... 処理中にエラーが発生しました: virtualbox-6.1 XXXXX$

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

回答1

0

もしこれが原因なら何故インストールされていないのかよく分からないのですが,

sudo apt search dkms

等のコマンドで,dkmsvirtualbox-dkmsがインストールされているか確認してみて下さい。
もしインストールされていないようでしたら,この二つをインストールしてみて下さい。

あとおせっかいついでですが,質問にリンクされているサイトの情報はubuntu 17.10向けで5年前のもので参考になりません。
ぐぐる時に情報の鮮度に気をつけた方がいいと思います。

https://gihyo.jp/list/group/Ubuntu-Weekly-Recipe

とかが参考になる時もあるでしょう。

投稿2022/11/04 14:06

編集2022/11/04 14:16
ujimushi_sradjp

総合スコア1503

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

reimen

2022/11/05 02:02

ご回答いただきありがとうございます。 dkmsとvirtualbox-dkmsについて、確認したのですが、既に最新バージョンがインストールされていました。

まだベストアンサーが選ばれていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

VirtualBox

VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。