質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.45%
Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Q&A

解決済

1回答

493閲覧

python のバージョンアップデートについて(MACユーザーです)

wafuberyllium

総合スコア3

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

0グッド

0クリップ

投稿2023/04/01 08:49

編集2023/04/01 09:15

 Python のバージョンってどれくらい重要なものなのですか?

<背景>

 自分は kivy を使って GUI を作ってみようと考えたのですが、調べてみると kivy は最新の python3.10 には対応していないと書かれていたり、実際インストールして動作確認をしてみても上手くいきませんでした

 さらに調べてみると、kivy は python 3.9 になら対応しているとわかり、最新のバージョンで python を使うより少し前のバージョンの方が対応している kivy などのオープンソースライブラリが多いのではないかと考えました

 もちろん、python3 と python2 では大きな違いがあり、2だと使いにくい部分が多々存在していると思いますが、python3.10 が使えるところを3.9にあえてバージョンを落として使用することは間違いでしょうか?

<補足>

 自分の python のバージョンは 3.10.4 です。
「いやいやそれ最新バージョンじゃないよw」 のツッコミや
「そのバージョンだったら kivy 対応してるよ」 などどんなことでも構わないので何かアドバイスいただけないでしょうか?

 ほぼ素人でありながら独学で勉強しているので些細なことでも教えていただけると大変ありがたいです

 最後に、忙しい中時間を割いて最後まで読んでいただきありがとうございました

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

melian

2023/04/01 09:02

公式のドキュメントには Python 3.10 にも対応していると記載されています。 Installing Kivy — Kivy 2.1.0 documentation https://kivy.org/doc/stable/gettingstarted/installation.html > Kivy 2.1.0 officially supports Python versions 3.7 - 3.10. > 実際インストールして動作確認をしてみても上手くいきませんでした 上手く行かなかった状況を具体的に追記してみてください。(kivy のインストールの仕方や動作確認のために実行したプログラムのソースコード、表示されたエラーメッセージ等)
wafuberyllium

2023/04/01 09:18

参考にしたサイトはこれです↓ https://yumarublog.com/python/kivy-install/ 「先ほど作成したtest_kivyフォルダに以下のようなmain.pyを作成します。」 から上手くいきませんでした ターミナルで実行しても function function> としか出てこず、確認ができませんでした
wafuberyllium

2023/04/01 09:21

kivyのフォルダを選択した後、「フォルダに新規ターミナル」をクリックして同様のことをしても同じようにfunction function> としかでてきませんでした
wafuberyllium

2023/04/01 09:22

そもそも動作確認ができていないのでちゃんとインストールされているかがわからないです
TakaiY

2023/04/01 10:09

ここは、質問に修正要望などのコメントを書くところです。 なので、コメントへの回答は、ここに書くのでなく、質問を編集して追記/修正しましょう。 また、編集するにあたって、 『「先ほど作成したtest_kivyフォルダに以下のようなmain.pyを作成します。」から上手くいきませんでした』 のように、単に「うまくいきませんでした」ではこちらにはなにもわかりません。 「xxxというコマンドを実行したが、yyyのようなエラーメッセージが表示された」など、具体的にやったことと、起きたことを書いてください。 コードにしても、参照先のリンクを示すのではなく、実際のファイルにに書いた内容をそのまま<code>ボタンで出てくる枠の中にコピペしたほうがいいです。 書き間違いなどあるかもしれません。 また、エラーメッセージが表示されたのであれば、要約するのではなく、すべて、記載してください。
guest

回答1

0

ベストアンサー

コメントでいろいろ確認中ではありますが、書けることは書いておきます。
なので、回答ではありません、悪しからず。

調べてみると kivy は最新の python3.10 には対応していないと書かれていたり

どこを調べていますか?
まず、調べるべきは本家です。コメントにもありますが、そこには、「3.7 - 3.10.」がサポートされていると書いてあります。3.10が入っていますので、今インストールされているpythonであれば、最新のkivy 2.1.0. であればサポートしていることになります。
また、これを見ると、python最新の 3.11 はサポートされていないということになりますね。

python2 では大きな違いがあり

最新はだめだけれど、古ければいいわけでもありません。
先に書いたとおり、 3.7より古いものはサポート外です。

python3.10 が使えるところを3.9にあえてバージョンを落として使用することは間違いでしょうか?

そんなことはありません。 先にも書いたとおり、 pythonの最新は 3.11 ですが、kivyを使いたければ、 3.7 ~ 3.10 のものを使う必要があります。
自分で使いたいモジュールがあるのであれば、それがサポートしているものを使うことになるでしょう。
ただし、使いたいモジュールだとしても、かなり前にサポートが終了していて、かなり古いpythonでなければ動かないというような場合、同様の機能を持つモジュールを探したほうが、他のモジュールの組合せのことを考えても、より新しいpythonが使えるようにしたほうがいいことが多いですね。

投稿2023/04/01 10:31

TakaiY

総合スコア12834

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.45%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問