質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.84%

  • Python

    6348questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Jupyter

    165questions

  • pip

    154questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

pip install jupyter を実行したときのエラーの解決法が分かりません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 693

前提・実現したいこと

Pythonの学習を始めたいと思い、標準のPython3をインストールしました。
Jupyter Notebookも使いたかったのでpip install jupyterをコマンドプロンプトで実行したところ、下記のエラーが表示されました。いったい何のことか分からず、解決のしようがありません。分かる方がいらっしゃいましたらご教授願います。

発生している問題・エラーメッセージ

C:\Users\coo>pip install jupyter
Collecting jupyter
  Using cached jupyter-1.0.0-py2.py3-none-any.whl
Collecting notebook (from jupyter)
  Using cached notebook-5.2.0-py2.py3-none-any.whl
Requirement already satisfied: nbconvert in c:\users\coo\appdata\local\programs\
python\python37-32\lib\site-packages (from jupyter)
Collecting qtconsole (from jupyter)
  Using cached qtconsole-4.3.1-py2.py3-none-any.whl
Collecting jupyter-console (from jupyter)
  Using cached jupyter_console-5.2.0-py2.py3-none-any.whl
Collecting ipywidgets (from jupyter)
  Using cached ipywidgets-7.0.3-py2.py3-none-any.whl
Collecting ipykernel (from jupyter)
  Using cached ipykernel-4.6.1-py3-none-any.whl
Requirement already satisfied: jupyter-core in c:\users\coo\appdata\local\progra
ms\python\python37-32\lib\site-packages (from notebook->jupyter)
Requirement already satisfied: traitlets>=4.2.1 in c:\users\coo\appdata\local\pr
ograms\python\python37-32\lib\site-packages (from notebook->jupyter)
Requirement already satisfied: ipython-genutils in c:\users\coo\appdata\local\pr
ograms\python\python37-32\lib\site-packages (from notebook->jupyter)
Requirement already satisfied: jinja2 in c:\users\coo\appdata\local\programs\pyt
hon\python37-32\lib\site-packages (from notebook->jupyter)
Collecting jupyter-client (from notebook->jupyter)
  Using cached jupyter_client-5.1.0-py2.py3-none-any.whl
Requirement already satisfied: tornado>=4 in c:\users\coo\appdata\local\programs
\python\python37-32\lib\site-packages (from notebook->jupyter)
Requirement already satisfied: nbformat in c:\users\coo\appdata\local\programs\p
ython\python37-32\lib\site-packages (from notebook->jupyter)
Requirement already satisfied: entrypoints>=0.2.2 in c:\users\coo\appdata\local\
programs\python\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: pandocfilters>=1.4.1 in c:\users\coo\appdata\loca
l\programs\python\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: pygments in c:\users\coo\appdata\local\programs\p
ython\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: testpath in c:\users\coo\appdata\local\programs\p
ython\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: mistune>=0.7.4 in c:\users\coo\appdata\local\prog
rams\python\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: bleach in c:\users\coo\appdata\local\programs\pyt
hon\python37-32\lib\site-packages (from nbconvert->jupyter)
Requirement already satisfied: prompt-toolkit<2.0.0,>=1.0.0 in c:\users\coo\appd
ata\local\programs\python\python37-32\lib\site-packages (from jupyter-console->j
upyter)
Requirement already satisfied: ipython in c:\users\coo\appdata\local\programs\py
thon\python37-32\lib\site-packages (from jupyter-console->jupyter)
Collecting widgetsnbextension~=3.0.0 (from ipywidgets->jupyter)
  Using cached widgetsnbextension-3.0.6-py2.py3-none-any.whl
Requirement already satisfied: decorator in c:\users\coo\appdata\local\programs\
python\python37-32\lib\site-packages (from traitlets>=4.2.1->notebook->jupyter)
Requirement already satisfied: six in c:\users\coo\appdata\local\programs\python
\python37-32\lib\site-packages (from traitlets>=4.2.1->notebook->jupyter)
Requirement already satisfied: MarkupSafe>=0.23 in c:\users\coo\appdata\local\pr
ograms\python\python37-32\lib\site-packages (from jinja2->notebook->jupyter)
Requirement already satisfied: python-dateutil>=2.1 in c:\users\coo\appdata\loca
l\programs\python\python37-32\lib\site-packages (from jupyter-client->notebook->
jupyter)
Collecting pyzmq>=13 (from jupyter-client->notebook->jupyter)
  Using cached pyzmq-16.0.2.tar.gz
Requirement already satisfied: jsonschema!=2.5.0,>=2.4 in c:\users\coo\appdata\l
ocal\programs\python\python37-32\lib\site-packages (from nbformat->notebook->jup
yter)
Requirement already satisfied: html5lib!=1.0b1,!=1.0b2,!=1.0b3,!=1.0b4,!=1.0b5,!
=1.0b6,!=1.0b7,!=1.0b8,>=0.99999999pre in c:\users\coo\appdata\local\programs\py
thon\python37-32\lib\site-packages (from bleach->nbconvert->jupyter)
Requirement already satisfied: wcwidth in c:\users\coo\appdata\local\programs\py
thon\python37-32\lib\site-packages (from prompt-toolkit<2.0.0,>=1.0.0->jupyter-c
onsole->jupyter)
Requirement already satisfied: simplegeneric>0.8 in c:\users\coo\appdata\local\p
rograms\python\python37-32\lib\site-packages (from ipython->jupyter-console->jup
yter)
Requirement already satisfied: jedi>=0.10 in c:\users\coo\appdata\local\programs
\python\python37-32\lib\site-packages (from ipython->jupyter-console->jupyter)
Requirement already satisfied: colorama; sys_platform == "win32" in c:\users\coo
\appdata\local\programs\python\python37-32\lib\site-packages (from ipython->jupy
ter-console->jupyter)
Requirement already satisfied: pickleshare in c:\users\coo\appdata\local\program
s\python\python37-32\lib\site-packages (from ipython->jupyter-console->jupyter)
Requirement already satisfied: setuptools>=18.5 in c:\users\coo\appdata\local\pr
ograms\python\python37-32\lib\site-packages (from ipython->jupyter-console->jupy
ter)
Requirement already satisfied: webencodings in c:\users\coo\appdata\local\progra
ms\python\python37-32\lib\site-packages (from html5lib!=1.0b1,!=1.0b2,!=1.0b3,!=
1.0b4,!=1.0b5,!=1.0b6,!=1.0b7,!=1.0b8,>=0.99999999pre->bleach->nbconvert->jupyte
r)
Requirement already satisfied: parso==0.1.0 in c:\users\coo\appdata\local\progra
ms\python\python37-32\lib\site-packages (from jedi>=0.10->ipython->jupyter-conso
le->jupyter)
Installing collected packages: pyzmq, jupyter-client, ipykernel, notebook, qtcon
sole, jupyter-console, widgetsnbextension, ipywidgets, jupyter
  Running setup.py install for pyzmq ... error
    Complete output from command c:\users\coo\appdata\local\programs\python\pyth
on37-32\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\coo\\
AppData\\Local\\Temp\\pip-build-sl345xw3\\pyzmq\\setup.py';f=getattr(tokenize, '
open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compil
e(code, __file__, 'exec'))" install --record C:\Users\coo\AppData\Local\Temp\pip
-j054q_hk-record\install-record.txt --single-version-externally-managed --compil
e:
--- Logging error ---
Traceback (most recent call last):
  File "c:\users\coo\appdata\local\programs\python\python37-32\lib\logging\__ini
t__.py", line 984, in emit
    stream.write(msg)
  File "c:\users\coo\appdata\local\programs\python\python37-32\lib\site-packages
\pip\_vendor\colorama\ansitowin32.py", line 141, in write
    self.write_and_convert(text)
  File "c:\users\coo\appdata\local\programs\python\python37-32\lib\site-packages
\pip\_vendor\colorama\ansitowin32.py", line 169, in write_and_convert
    self.write_plain_text(text, cursor, len(text))
  File "c:\users\coo\appdata\local\programs\python\python37-32\lib\site-packages
\pip\_vendor\colorama\ansitowin32.py", line 174, in write_plain_text
    self.wrapped.write(text[start:end])

該当のソースコード

試したこと

様々な条件で検索してみましたが、解決策にはたどり着きませんでした。

補足情報(言語/FW/ツール等のバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

pythonの学習が目的であれば、python+各種ライブラリがパッケージされたAnacondaというソフトウェアを使用するとよいです。jupyter-notebookも含まれています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/10/30 13:02

    回答ありがとうございます。
    確かにAnacondaの方が便利だと思いますが、Anacondaのインストールに失敗して、今に至っていました。
    今後はそちらの解決法を考えていきたいと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.84%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    6348questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Jupyter

    165questions

  • pip

    154questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。