質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.84%

  • Eclipse

    1569questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

  • Ubuntu

    1199questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

Eclipseを日本語化しようとすると起動しません(起動はするけど、すぐエラーウィンドウが表示される)

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 324

Ubuntu 17.04 + Eclipse 3.8 + pleiades
java version "1.8.0_144"

sudo apt-get install eclipse

sudo apt-get instal pleiades

端末を起動

$eclipse -clean

エラーウィンドウが出ました。

イメージ説明

端末上にもログがありまりた。

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
INFO  21:06:25.319 [main] (PropertySet) load  0.002 秒 -     16 エントリー config.ini
The program 'Eclipse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
(Details: serial 301 error_code 143 request_code 139 minor_code 7)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
*Oracle-Java8 => OpenJDKにしていました!

起動はしていましたが、IDE画面が表示される前にエラーウィンドウが出てしまいます

3.8 => 4.2にしてみました。

$eclipse -clean
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized.  Will retry after the state location is initialized.
org.eclipse.m2e.logback.configuration: Logback config file: /home/satuki/workspace/.metadata/.plugins/org.eclipse.m2e.logback.configuration/logback.1.6.2.20150902-0002.xml
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [bundleresource://558.fwk2009787198:1/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [bundleresource://558.fwk2009787198:2/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type nlectorStaticBinder]
org.eclipse.m2e.logback.configuration: Initializing logback

エラーウィンドウも出ています。

イメージ説明

一時的に起動はするものの数分たつと、画面が消え、エラーウィドウが表示されます。

どうすればこの事象を治すことが出来ますか?
知ってる人がいましたら教えてください!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • keicha_hrs

    2017/10/12 18:05

    以前、4.5が動かないという質問をされていましたが、それは解決したのですよね?それとは別にEclipseをインストールしたということですか?その表示にはPleiadesプラグインのオプションも見えますが、eclipse.iniを編集されたのですか?

    キャンセル

  • satuki_yamabuki

    2017/10/12 18:08

    その通りです。 4.5での日本語化には成功したのですが、プロジェクトが開けないという事象がおきました。 下位バージョンならできるかもとインストールしてみてら。案の定です・・・

    キャンセル

  • keicha_hrs

    2017/10/13 11:56

    全く別内容の質問に書き換えないでください!

    キャンセル

  • satuki_yamabuki

    2017/10/13 12:15

    ごめんなさい。できるだけ、もの記事にそうように書き直しました。

    キャンセル

回答 1

checkベストアンサー

0

調べてみた限り、Ubuntu 16.04以降では、Eclipse 4.4以下をPleiadesで日本語化して正常動作させるのは難しい(無理?)みたいですね。Pleiadesプラグイン自体も公式サイトで配布されている現行版はEclipse 4.4以下をサポートしていませんので、周辺環境(GUIツールとかJavaのバージョンとか)の変化に対応できなくなったのでしょう。

eclipse.iniの記述の工夫で回避できるのか、或いは問題を起こしているモジュールを突き止めてその部分だけを古いバージョンに差し替えるのか、そういった方法が他に存在する可能性はあるかもしれませんが、そこまでは調べきれません。

なお、Ubuntu 14.04ではapt-getによってインストールできるEclipse 3.8およびPleiadesによって日本語化しても、(ざっと動かした程度だが)正常動作するようです。(Ubuntu 14.04は5年間サポートバージョンなので、あと1年半ほどはサポートがは継続します)

Eclipse 3.8を用いるなら、日本語化するためにUbuntuを14.04に下げるか、日本語化を諦めるか。差し当たってはそのどちらかしかないのでは。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.84%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Eclipse

    1569questions

    Eclipseは、IBM社で開発された統合開発環境のひとつです。2001年11月にオープンソース化されました。 たくさんのプラグインがあり自由に機能を追加をすることができるため、開発ツールにおける共通プラットフォームとして位置づけられています。 Eclipse自体は、Javaで実装されています。

  • Ubuntu

    1199questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • トップ
  • Eclipseに関する質問
  • Eclipseを日本語化しようとすると起動しません(起動はするけど、すぐエラーウィンドウが表示される)