質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.02%
Xcode 7

Xcode 7は、ソフトウェア開発のためのアップルの統合開発環境であるXcodeのバージョン。UIを作成するために用いるグラフィカルツールです。iOS9/OS X El Capitan/watchOS2に対応。Swift 2コンパイラーが搭載されています。

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Xcode

Xcodeはソフトウェア開発のための、Appleの統合開発環境です。Mac OSXに付随するかたちで配布されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

Swift 2

Swift 2は、Apple社が独自に開発を行っている言語「Swift」のアップグレード版です。iOSやOS X、さらにLinuxにも対応可能です。また、throws-catchベースのエラーハンドリングが追加されています。

Q&A

解決済

iPhoneアプリの互換性を変更する方法がわかりません。

burdock
burdock

総合スコア12

Xcode 7

Xcode 7は、ソフトウェア開発のためのアップルの統合開発環境であるXcodeのバージョン。UIを作成するために用いるグラフィカルツールです。iOS9/OS X El Capitan/watchOS2に対応。Swift 2コンパイラーが搭載されています。

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Xcode

Xcodeはソフトウェア開発のための、Appleの統合開発環境です。Mac OSXに付随するかたちで配布されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

Swift 2

Swift 2は、Apple社が独自に開発を行っている言語「Swift」のアップグレード版です。iOSやOS X、さらにLinuxにも対応可能です。また、throws-catchベースのエラーハンドリングが追加されています。

3回答

0グッド

2クリップ

22722閲覧

投稿2017/05/24 14:33

編集2017/05/24 14:33

iPhoneアプリの互換性に関しまして、質問させていただきます。
質問内容は、下記のとおりです。

■質問内容
互換性をiPhoneのみにすることは可能でしょうか。
また、可能であれば互換性の変更方法をご教示いただけますでしょうか。

■補足
現在、AppStoreで自作iPhoneアプリを公開しています。
アプリの審査時にiPad用のアプリアイコンを提出していないことが
原因と思うのですが、iPadに自作アプリをインストールすることはできない
状況です。
iPhoneに自作アプリをインストールすることはできます。

現在AppStore内、自作アプリの公開ページでは、
下記の画像のような表示になっています。
イメージ説明

互換性がiPhoneとiPad,およびiPod touchと記載されて
います。

しかし、現在iPadを使って、自作アプリをインストールすることはできない
状況のため、可能であれば
「互換性:iPhoneのみ」と記載したいです。

お手数をおかけいたしますが、質問内容に関しまして
お教示いただけますでしょうか。
宜しくおねがいいたします。

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

fuzzball

2017/05/25 00:06

そのインストール出来ないiPadはiOS9.1以降なのでしょうか?ちなみに具体的な機種は何ですか?
burdock

2017/05/25 01:58

最新のiPad2017です。
burdock

2017/05/25 02:01

すみません、完全な自己解決ではないのですが、少し問題が解決しましたので質問内容を編集させていただきます。ただちょっと今お時間がないので、正午以降に編集いたします。
burdock

2017/05/25 03:55

質問内容の編集しようと思ったのですが、TakeOne様の回答で完全に解決できました。一旦クローズさせていただきます。

回答3

1

ベストアンサー

General>Deployment Info>Devicesを「iPhone」にすれば、
そのアプリはiPhone専用アプリになります。

ただし、AppStoreのその互換性表示は「iPad」が含まれたまま表示されます。
私がリリースしているアプリもiPhone専用で作っているものがありますが、
互換性表示は「iPad」が入っています。

どういうことかというと、iPadには「iPhone互換モード」という機能があり、
iPhone専用アプリをiPadで動作させることができるということです。

(参考)
https://teratail.com/questions/15770

つまりiPhone専用アプリは、iPadの「iPhone互換モード」でも動作できなければなりません。
それが動作できないのであれば、動作できるように修正しないといけないというのが
Appleの審査ガイドラインです。

それが動作できないのにアプリがリリースされてしまったのは、
おそらくAppleの審査の確認漏れではないかと思います。
次回アップデートの際には審査でリジェクトされる可能性があると思います。

投稿2017/05/25 02:15

TakeOne

総合スコア6210

Masahiro1👍を押しています

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

burdock

2017/05/25 03:50

>つまりiPhone専用アプリは、iPadの「iPhone互換モード」でも動作できなければなりません。 はじめて知りました。謎が解けました。ありがとうございます!

0

(deleted)

投稿2017/05/24 23:51

編集2017/05/25 00:22
fuzzball

総合スコア16727

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

0

xcodeのGeneralのDeployment InfoのDevicesの項目をUniversalからiPhoneに変更して審査を通せばいいのではないでしょうか?

投稿2017/05/24 14:49

yuabe

総合スコア143

良いと思った回答にはグッドを送りましょう。
グッドが多くついた回答ほどページの上位に表示されるので、他の人が素晴らしい回答を見つけやすくなります。

下記のような回答は推奨されていません。

  • 間違っている回答
  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

burdock

2017/05/24 15:28

回答いただきありがとうございます。xcodeのGeneral>Deployment Info>Devicesは、iPhoneを選択し審査に提出しています。

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.02%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Xcode 7

Xcode 7は、ソフトウェア開発のためのアップルの統合開発環境であるXcodeのバージョン。UIを作成するために用いるグラフィカルツールです。iOS9/OS X El Capitan/watchOS2に対応。Swift 2コンパイラーが搭載されています。

iOS

iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

Xcode

Xcodeはソフトウェア開発のための、Appleの統合開発環境です。Mac OSXに付随するかたちで配布されています。

Swift

Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

Swift 2

Swift 2は、Apple社が独自に開発を行っている言語「Swift」のアップグレード版です。iOSやOS X、さらにLinuxにも対応可能です。また、throws-catchベースのエラーハンドリングが追加されています。