質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • Swift

    8942questions

    Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

  • iOS

    4774questions

    iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

  • SDK

    154questions

    SDK(software development kit)は特定のハードウェアのプラットフォーム、開発環境又はソフトウェアパッケージでソフトウェアをつくるのに必要な開発ツールのセットです。SDKはAPI、IDE又は他の開発ツールとフレームワークを組み合わせたもので構成されていることがあります。

pod install時にエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 698

yamataku29

score 39

CocoaPodsでNCMBのSDKのバージョン2.3.3を指定DLしたいのですが、 pod ’NCMB’, :git => ‘https://github.com/NIFTYCloud-mbaas/ncmb_ios.git’, ’~>2.3.3’ をpodファイルに書き込んだ時にエラーが出てしまいます。

環境
CocoaPods 1.2.1
Xcode 8.3.1

[!] Invalid `Podfile` file: syntax error, unexpected '\n', expecting =>
/Users/User_name/.ghq/bitbucket.org/User_name/App_name/Podfile:25: syntax error, unexpected keyword_do_block, expecting keyword_end
    installer.pods_project.targets.each do |target|
                                          ^
/Users/User_name/.ghq/bitbucket.org/User_name/App_name/Podfile:26: syntax error, unexpected keyword_do_block, expecting keyword_end
        target.build_configurations.each do |config|
                                           ^
/Users/User_name/.ghq/bitbucket.org/User_name/App_name/Podfile:29: syntax error, unexpected keyword_end, expecting end-of-input.

 #  from /Users/User_name/.ghq/bitbucket.org/User_name/App_name/Podfile:5
 #  -------------------------------------------
 #  target 'App_name' do
 >      pod 'NCMB', :git => 'https://github.com/NIFTYCloud-mbaas/ncmb_ios.git', '~>2.3.3'
 #      pod 'FBSDKCoreKit'
 #  -------------------------------------------

[!] Smart quotes were detected and ignored in your Podfile. To avoid issues in the future, you should not use TextEdit for editing it. If you are not using TextEdit, you should turn off smart quotes in your editor of choice.

\n がどっかに入っている?
と思い、atomで正規表現検索をしているのですが、該当する物が見つからず。

イメージ説明

どこ直せばよいのかイマイチわかっていないので、アドバイス貰えますと大変ありがたいです。

追記
pod ’NCMB’, :git => ‘https://github.com/NIFTYCloud-mbaas/ncmb_ios.git’ だけだと問題なく最新版がDLできます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

結果、別の人がgitにあげているSDKバージョンがあったので、それを使って解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.47%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Swift

    8942questions

    Swiftは、アップルのiOSおよびOS Xのためのプログラミング言語で、Objective-CやObjective-C++と共存することが意図されています

  • iOS

    4774questions

    iOSとは、Apple製のスマートフォンであるiPhoneやタブレット端末のiPadに搭載しているオペレーションシステム(OS)です。その他にもiPod touch・Apple TVにも搭載されています。

  • SDK

    154questions

    SDK(software development kit)は特定のハードウェアのプラットフォーム、開発環境又はソフトウェアパッケージでソフトウェアをつくるのに必要な開発ツールのセットです。SDKはAPI、IDE又は他の開発ツールとフレームワークを組み合わせたもので構成されていることがあります。