質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • JavaScript

    16489questions

    JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

  • Python

    8041questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • jQuery

    6726questions

    jQueryは、JavaScriptライブラリのひとつです。 簡単な記述で、JavaScriptコードを実行できるように設計されています。 2006年1月に、ジョン・レシグが発表しました。 jQueryは独特の記述法を用いており、機能のほとんどは「$関数」や「jQueryオブジェクト」のメソッドとして定義されています。

  • Python 2.7

    1269questions

    Python 2.7は2.xシリーズでは最後のメジャーバージョンです。Python3.1にある機能の多くが含まれています。

  • Electron

    197questions

    Electronは、HTML5とNode.jsというWebの技術を用いてデスクトップアプリケーションを作成できるクロスプラットフォームな実行環境です。

electron+pythonでjqueryが読み込めない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,016

kawaryo_0615

score 2

前提・実現したいこと

pythonで簡易なアプリケーションの開発をしておりましたが,GUIにやや不満を覚えていたため,より見栄えの良いものを作るべく,electronと連動させることにしました.
しかし,jqueryやbootstrapなどのライブラリを使用する上で,jqueryの読み込みで嵌りました.

javaScriptは初心者同然なので,何か致命的な見落としがあるかもしれませんが,ご教授いただければ幸いです.

因みに,pythonでFlaskを用いているため,htmlファイルはtemplatesフォルダ内に配置してhtmlを返却しています.
同様に,jqueryやbootstrapを始めとしたjavaScriptファイルやcssファイルは,静的ファイルとして扱うためにstaticフォルダ内に配置しています.

発生している問題・エラーメッセージ

electron単体で動作させた場合,html内で

<script>
window.jQuery = window.$ = require('../static/js/jquery-3.1.1.min.js')
</script>

と書くことでjQueryの読み込みが可能だったのですが,これをpythonベースで行う場合,以下のようなエラーメッセージが表示されます.

cannot find module '/static/js/jquery-3.1.1.min.js'

該当のソースコード

'use strict';

const electron = require('electron');
const app = electron.app;
const BrowserWindow = electron.BrowserWindow;
let mainWindow;

app.on('window-all-closed', function() {
  if (process.platform != 'darwin') {
    app.quit();
  }
});

app.on('ready', function() {
  const subpy = require('child_process').spawn('python',['./hello.py']);
  const rp = require('request-promise');
  const mainAddr = 'http://localhost:5000';

  var openWindow = function() {
    mainWindow = new BrowserWindow({
      width:1600, height:900, webPreferences: {nodeIntegration: true}
    });
    mainWindow.loadURL(mainAddr);

    mainWindow.on('closed', function() {
      mainWindow = null;
      subpy.kill('SIGINT');
    });
  };

  var startUp = function() {
    //console.log('test');
    rp(mainAddr)
      .then(function(htmlString) {
        console.log('server started');
        openWindow();
      })
      .catch(function(err) {
        startUp();
      });
  };

  startUp();
});
<!DOCTYPE html>

<html>
  <head>
    <meta charset="utf-8">
    <title>audienceviewer electron ver.</title>
  </head>
  <body>
    <div class="container">
        <button id="fileSelect" type="button" class="btn btn-primary btn-lg btn-block">pdf</button>
    </div>
    <h1>hello, electron!</h1>
    <script>
        window.jQuery = window.$ = require("{{ url_for('static', filename='js/jquery-3.1.1.min.js') }}")
    </script>
    <script src="./static/js/bootstrap.min.js"></script>
    <script src="./static/js/audienceviewer.js"></script>
  </body>
</html>
# -*- coding: utf-8 -*-

from __future__ import print_function
import time
from flask import Flask, render_template

app = Flask(__name__)

@app.route("/")
def index():
    return render_template('index.html')


if __name__ == '__main__':
    app.run(host="127.0.0.1", port=5000)

試したこと

node-integrationをfalseにしてみたところ,フロントでnode.jsが使えなくなったので

window.jQuery = window.$ = require('../static/js/jquery-3.1.1.min.js')

のところでrequireが定義されていないというエラーが出たため,node-integrationはtrueにしております.

補足情報(言語/FW/ツール等のバージョンなど)

pythonのバージョンは2.7.11,electronのバージョンは1.4.13です.
開発OSはWindowsです.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

+1

html内に

<script>
window.nodeRequire = require;
delete window.require;
delete window.exports;
delete window.module;
</script>

を加え,コードを少し編集することで解決しました.

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • JavaScript

    16489questions

    JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

  • Python

    8041questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • jQuery

    6726questions

    jQueryは、JavaScriptライブラリのひとつです。 簡単な記述で、JavaScriptコードを実行できるように設計されています。 2006年1月に、ジョン・レシグが発表しました。 jQueryは独特の記述法を用いており、機能のほとんどは「$関数」や「jQueryオブジェクト」のメソッドとして定義されています。

  • Python 2.7

    1269questions

    Python 2.7は2.xシリーズでは最後のメジャーバージョンです。Python3.1にある機能の多くが含まれています。

  • Electron

    197questions

    Electronは、HTML5とNode.jsというWebの技術を用いてデスクトップアプリケーションを作成できるクロスプラットフォームな実行環境です。