質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • MySQL

    7420questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。

MySQLの文字コードがlatin1になってしまう。utf8にしたい。

受付中

回答 3

投稿

  • 評価
  • クリップ 2
  • VIEW 10K+

ucan

score 546

MySQL初心者です。

character_set_serverとcharacter_set_databaseの値がlatin1となってしまいます。
どこのサイトを見てもcharacter-set-server = utf8とすれば文字コードが直るような記述があるのですが、etc/my.cnfを書き換えて再起動しても文字コードはlatin1のままです。

my.cnfの中身は次のようになっています。

[client]
port                           = 3306
socket                         = /var/lib/mysql/mysql.sock
default-character-set          = utf8

[mysqld]
port                           = 3306
socket                         = /var/lib/mysql/mysql.sock
datadir                        = /var/lib/mysql
log-error                      = /var/log/mysqld.log
pid-file                       = /var/run/mysqld/mysqld.pid
tmpdir                         = /tmp
log-bin                        = mysql-bin
expire_logs_days               = 7
symbolic-links                 = 0
default_password_lifetime      = 0

character-set-server           = utf8
language                       = /usr/share/mysql/japanese/

[mysqld_safe]
log-error                      = /var/log/mysqld.log
pid-file                       = /var/run/mysqld/mysqld.pid

[mysqldump]
socket                         = /var/lib/mysql/mysql.sock
default-character-set          = utf8

MySQLのバージョンは5.7系です。

# mysql -V
mysql  Ver 14.14 Distrib 5.7.16, for Linux (x86_64) using  EditLine wrapper

 文字コードの確認コマンド

> show variables like "%character%";
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | utf8                       |
| character_set_connection | utf8                       |
| character_set_database   | latin1                     |
| character_set_filesystem | binary                     |
| character_set_results    | utf8                       |
| character_set_server     | latin1                     |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

> show variables like "%collation%";
+----------------------+-------------------+
| Variable_name        | Value             |
+----------------------+-------------------+
| collation_connection | utf8_general_ci   |
| collation_database   | latin1_swedish_ci |
| collation_server     | latin1_swedish_ci |
+----------------------+-------------------+

> show global variables like 'character%';
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | latin1                     |
| character_set_connection | latin1                     |
| character_set_database   | latin1                     |
| character_set_filesystem | binary                     |
| character_set_results    | latin1                     |
| character_set_server     | latin1                     |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

詳しい方、アドバイスお願いします。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

0

my.cnfに[mysql]セクションがないようです。以下の内容を追加するとどうなるでしょうか。

[mysql]
default-character-set = utf8

参考:
MySQL 5.6リファレンスマニュアル (5.7の英語版マニュアルとほぼ同内容)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/04 11:14

    不要なコメント、空行、スペースを削除してみましたが、変化なしです。試しにMySQLをアンインストールしたり、文字コードの設定のみ残したりも試しましたが変わらず。。これは5.7.16バージョン固有の不具合では...と疑い出しています。その辺りを調べてみようと思います。

    キャンセル

  • 2016/12/04 13:54

    あと、サーバ起動時のオプションで--character-set-server=latin1が指定されていたりしませんか。
    $ ps -ef | grep mysqld
    といったふうに確認してみては。

    キャンセル

  • 2016/12/04 16:41

    # ps -ef | grep mysqld
    mysql 21299 1 0 02:22 ? 00:00:04 /usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid
    root 22003 19427 0 07:04 pts/0 00:00:00 grep --color mysqld

    latin1は指定されていないようです。

    キャンセル

0

; 以下でテーブルを確認して
show create table hogehoge;
CREATE TABLE `hogehoge` (
  `id` int(10) unsigned NOT NULL AUTO_INCREMENT,
  `created` datetime DEFAULT NULL,
  `updated` datetime DEFAULT NULL,
  `name` varchar(63) DEFAULT NULL,
  PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;


latin1であれば

alter database [データベース名] default character set utf8
use [データベース名]
alter table hogehoge charset=utf8


上記のように変えてみてはどうでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/01 23:19

    回答ありがとうございます。
    テーブルは`CHARSET=utf8 COLLATE=utf8_unicode_ci`となっており、
    データベースは`DEFAULT CHARACTER SET latin1`となっています。

    alter databaseでutf8に変更はできますが、`character_set_server`は`latin1`のままです。
    もちろん`character_set_database`の方は`utf8`になります。

    キャンセル

0

具体的な回答ではありませんが、、

mysqld セクションに

character-set-server           = utf8


を指定しているにもかかわらずcharacter_set_serverlatin1のまま、ということから、
「実はそのオプションファイルを読み込んでいない」
または
「別のオプションファイルが設定を上書きしている」
という可能性が考えられます。

一度、MySQL起動時のオプションに--defaults-file=[該当のオプションファイルのパス]を追加して MySQLを再起動するとどうなるか、試してみてもらえますか?
https://dev.mysql.com/doc/refman/5.7/en/server-options.html#option_mysqld_defaults-file

Use only the given option file.


ちなみに、MySQL がデフォルトでどのファイルを読み込むかは、以下のページで説明されています。
https://dev.mysql.com/doc/refman/5.7/en/option-files.html#option-files-unix

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • MySQL

    7420questions

    MySQL(マイエスキューエル)は、TCX DataKonsultAB社などが開発するRDBMS(リレーショナルデータベースの管理システム)です。世界で最も人気の高いシステムで、オープンソースで開発されています。MySQLデータベースサーバは、高速性と信頼性があり、Linux、UNIX、Windowsなどの複数のプラットフォームで動作することができます。