質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

Q&A

解決済

2回答

11632閲覧

pipのアップデートができない

yasutin

総合スコア41

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

pip

pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

0グッド

0クリップ

投稿2021/12/31 02:17

sklearnのモジュールを使いたいのですが、pipがアップデートできないせいで使えません。以下はコマンドプロンプトで表示されたテキストです。

python

1コード 2C:\Users\Yasu>python -m pip install --upgrade pip 3Requirement already satisfied: pip in c:\users\yasu\appdata\local\programs\python\python36-32\lib\site-packages (21.3.1) 4

すでにアップデートされているように見えるのですが、numpyをインストールしようとすると、

python

1コード 2C:\Users\Yasu>py -m pip install numpy 3Requirement already satisfied: numpy in c:\users\yasu\appdata\local\programs\python\python310\lib\site-packages (1.21.5) 4WARNING: You are using pip version 21.2.4; however, version 21.3.1 is available. 5You should consider upgrading via the 'C:\Users\Yasu\AppData\Local\Programs\Python\Python310\python.exe -m pip install --upgrade pip' command. 6

このようにpipをアップグレードしろと言われます。OSはWindowsです。どうすればよいでしょうか。どなたかよろしくお願いします!

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

1T2R3M4

2021/12/31 02:21

他人のPCなのでしょうか。 pyとpythonで異なるバージョンが起動しているようですが。
Bull

2021/12/31 05:39

余計なお世話ですが、Windows で複数のバージョンの Python をインストールしているときは、Python 本体 (Python.exe) に PATH を通さない方がいいです。 ちょっと面倒ですが、ランチャー (py.exe) でバージョンを指定して Python 本体を起動するようにすれば、混乱せずにすみます。
yasutin

2022/01/01 03:34

間違えて3.61と3.10の二つをインストールしてしまいました。3.61のパイソンを使っていきたいのですが、どうすればよいでしょうか?python3.10の方をアンインストールすればよいですか?
Bull

2022/01/01 05:57 編集

python3.10 をアンインストールする必要はないと思いますが、混乱を避けるためには、アンインストールも一つの方法ですかね。 py.exe で起動するのならば、 py -3.6 ソースファイル.py などとします。 pip でインストールするときは、 py -3.6 -m pip install ~ などとします。 ただ現状、python3.6 に PATH が通っているようなので、そのまま python ソースファイル.py でもいいかもしれません。 py.exe は、デフォルトでは最新バージョンの python を起動します。
guest

回答2

0

https://qiita.com/umi_mori/items/3aa8409d915b421025f2
わたしはこれで修復できました。

投稿2021/12/31 11:15

Sheldonlovest

総合スコア4

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

pythonで3.6が、pyで3.10が起動するようになってます。

投稿2021/12/31 02:22

quickquip

総合スコア11094

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問