質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.77%

  • Python 3.x

    1518questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

python3でbeautifulsoup4を使えるようにしたい

受付中

回答 2

投稿 2016/05/19 12:37 ・編集 2016/05/19 22:11

  • 評価
  • クリップ 0
  • VIEW 1,506

heihoo

score 59

今回、仕事でPython3.xでWebスクレイピングを行うことになりました。
以前まで、Python2.xでスクレイピングを行っていましたが、今回は仕事の関係で3.x系を使うことに。
開発環境は手元のMac book air OS X EL Capitan 10.11.3です。

python2.x系では、

$ python
Python 2.7.11 |Anaconda custom (x86_64)| (default, Dec  6 2015, 18:57:58)
[GCC 4.2.1 (Apple Inc. build 5577)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
Anaconda is brought to you by Continuum Analytics.
Please check out: http://continuum.io/thanks and https://anaconda.org
>>> from bs4 import BeautifulSoup
>>>


BeautifulSoupを読み込めますが、

$ python3
Python 3.4.3 |Continuum Analytics, Inc.| (default, Mar  6 2015, 12:07:41)
[GCC 4.2.1 (Apple Inc. build 5577)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from bs4 import BeautifulSoup
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named 'bs4'


3.xだと読み込めません。

ちなみに、以下でパスを調べてみました。

2系

$python -c "import site; print(site.getsitepackages())"
['Users/heihoo/anaconda/lib/python2.7/site-packages', '/Users/heihoo/anaconda/lib/site-python']

3系

$ python3 -c "import site; print(site.getsitepackages())"
['/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/site-packages', '/Library/Frameworks/Python.framework/Versions/3.3/lib/site-python', '/Library/Python/3.3/site-packages']

最後に、pip install beautifulsoup4してみたらいかになります。

$ pip install beautifulsoup4
Requirement already satisfied (use --upgrade to upgrade): beautifulsoup4 in /usr/local/lib/python2.7/site-packages

pip3コマンドも試してみましたが、ダメでした。

$ pip3 install beautifulsoup4
pyenv: pip3: command not found

The `pip3' command exists in these Python versions:
  3.4.3

どうすれば、python3系でbeautifulsoup4が使えるようになりますでしょうか?
ご教授宜しくお願い申し上げます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

beautifulsoup4 in /usr/local/lib/python2.7/site-packages


とあるように、pipコマンドのパッケージインストール先がpython2系環境になっているため、
おそらくPython3環境にはインストールされていないのだと思います。

  • pip3
  • pip-3.x

などの、python3系向けコマンドがあったと思うので、そちらを使えばインストールできるかと。
(おそらくpython3と同じパスにあります)

投稿 2016/05/19 14:39

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

0

easy_install-3.4 pip
をしてから、
pip3 install beautifulsoup4
したら読み込めました。

投稿 2016/05/19 22:18

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.77%

関連した質問

  • 受付中

    pythonのimportについて。

    >>> from sklearn import datasets Traceback \(most recent call last\):   File "<pyshell#3

  • 解決済

    pipがアップグレードできません

    Python初心者です。 pipをアップグレードしようとすると下記のようなエラーが出てしまいます。 色々なサイトで調べたのですが解決できず困っています。 教えいただけるとあり

  • 受付中

    Ironpythonでpythonのサードパーティライブラリを使う

    現在Visual Studio 2015 communityでvisual C#を用いて、Windows Form Applicationを作成しています。 そこで、データファイ

  • 解決済

    Python2.7.13のpipが認識されない

    大学での画像処理の研究に使うため Python2.7.13 バージョンwindowns x86 MSI installerをダウンロードしました。 モジュールを追加しようとするも

同じタグがついた質問を見る

  • Python 3.x

    1518questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

閲覧数の多いPython 3.xの質問