質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

受付中

Ubuntu16.04でsudo apt installができない

prog_tamaza
prog_tamaza

総合スコア14

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

1回答

0評価

0クリップ

165閲覧

投稿2022/05/27 03:46

Ubuntu16.04LTSにライブラリをインストールしようとしたところ、以下のエラーが出てしまい、何もインストールすることができません。
以下はsudo apt install libopenblas-devをインストールしようとした結果です。

~$ sudo apt install libopenblas-dev Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: binutils cpp cpp-5 gcc gcc-5 gcc-5-base gcc-6-base gfortran gfortran-5 libasan2 libatomic1 libblas-common libblas-dev libblas3 libc-dev-bin libc6 libc6-dev libcc1-0 libcilkrts5 libgcc-5-dev libgcc1 libgfortran-5-dev libgfortran3 libgmp10 libgomp1 libisl15 libitm1 liblsan0 libmpc3 libmpfr4 libmpx0 libopenblas-base libquadmath0 libstdc++6 libtsan0 libubsan0 linux-libc-dev manpages manpages-dev multiarch-support zlib1g Suggested packages: binutils-doc cpp-doc gcc-5-locales gcc-multilib make autoconf automake libtool flex bison gdb gcc-doc gcc-5-multilib gcc-5-doc libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libmpx0-dbg libquadmath0-dbg gfortran-multilib gfortran-doc gfortran-5-multilib gfortran-5-doc libgfortran3-dbg liblapack-doc-man liblapack-doc glibc-doc debconf | debconf-2.0 locales man-browser The following NEW packages will be installed: binutils cpp cpp-5 gcc gcc-5 gcc-5-base gcc-6-base gfortran gfortran-5 libasan2 libatomic1 libblas-common libblas-dev libblas3 libc-dev-bin libc6 libc6-dev libcc1-0 libcilkrts5 libgcc-5-dev libgcc1 libgfortran-5-dev libgfortran3 libgmp10 libgomp1 libisl15 libitm1 liblsan0 libmpc3 libmpfr4 libmpx0 libopenblas-base libopenblas-dev libquadmath0 libstdc++6 libtsan0 libubsan0 linux-libc-dev manpages manpages-dev multiarch-support zlib1g 0 upgraded, 42 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/49.6 MB of archives. After this operation, 235 MB of additional disk space will be used. Do you want to continue? [Y/n] y E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 71%E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 100% dpkg: error: error removing old backup file '/var/lib/dpkg/status-old': Is a directory E: Sub-process /usr/bin/dpkg returned an error code (2)

debconf関係でエラーが起きているようですが、調べると最悪OSの再インストールが必要だとも書いていたので一気に不安になりました。
再インストール以外で解決する方法はありますでしょうか?

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。