質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

djangoのPostgreSQL's limit of 63 characters についてのエラー

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 118

PythonYo

score 0

前提・実現したいこと

djangoを使った簡単なアプリを作成しました。
python manage.py runserver
でローカルで走らせたところ(ここまではエラーは出ません)、
ImproperlyConfigured at /admin/
というエラーが出ました。
このエラーを取りたいです。

以下のエラーメッセージの/*...*/にはこのプログラムのアドレスが入ってます。

発生している問題・エラーメッセージ

The database name '/Users/***...***/db.sqlite3' (71 characters) is longer than PostgreSQL's limit of 63 characters. Supply a shorter NAME in settings.DATABASES.

該当のソースコード

BASE_DIR = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.postgresql_psycopg2',
        'NAME': os.path.join(BASE_DIR, 'db.sqlite3'),
    }
}

試したこと

PostgreSQLについて調べましたが、よく分かりませんでした。

補足情報(FW/ツールのバージョンなど)

今回、このエラーが出てしまいましたが、
元々は出ていませんでした。
herokuにデプロイして、それもうまく走りました(現在もちゃんと動いてます)。

さらに改善を加えようと、ローカルに戻ったらこのエラーが出てしまいました。
しかしコードは何一つ変更していません。
PostgreSQLの仕様に反してるのは分からなくはないのですが、
それならデプロイする前から同様のエラーが出てもいいのではと思ってしまいます。

恥ずかしながら素人ですので、環境設定的なことになると大変弱いです。
なにか分かる方がいらっしゃったらご教示頂ければ幸いです。
よろしくお願いします。

python-3.6.5
asgiref==3.2.10
dj-database-url==0.5.0
Django==3.0.6
django-heroku==0.3.1
gunicorn==20.0.4
psycopg2==2.8.6
pytz==2020.1
sqlparse==0.3.1
whitenoise==5.2.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mimikyu

    2020/09/13 10:34

    エラー文から、データベース名をPostgreSQL's limit of 63 charactersの制限内にしてくださいと言われております。コードの変更はしていないということですが、フォルダの階層やフォルダ名の変更などもしていないでしょうか?

    キャンセル

  • PythonYo

    2020/09/13 14:05

    追加質問ありがとうございます。
    特に変更はしていません。
    ローカルで実行確認をしたあとは、

    git init
    git add .
    git commit -m "【コメント】"
    git remote add heroku https://git.heroku.com/【アプリケーション名】.git
    heroku config:set SECRET_KEY="***************"
    git push heroku master
    heroku run python manage.py migrate
    heroku run python manage.py createsuperuser

    これくらいでしょうか。
    heroku上でも実行確認をして、
    再びローカルに戻ったら、このエラーが出た次第です。
    一連の命令はターミナルから実行しています。

    キャンセル

  • PythonYo

    2020/09/13 23:06

    私の誤認識がありました。
    改めて1から作り直して、細かくエラーチェックを行ったところ、
    ローカルで既にこのエラーが出ていたことが分かりました。

    DATABASES = {
    'default': {
    'ENGINE': 'django.db.backends.sqlite3', ## 変更前
    'NAME': os.path.join(BASE_DIR, 'db.sqlite3'),
    }
    }

    DATABASES = {
    'default': {
    'ENGINE': 'django.db.backends.postgresql_psycopg2', ## 変更後
    'NAME': os.path.join(BASE_DIR, 'db.sqlite3'),
    }
    }

    このように変えたところエラーが発生するようになりました。
    変更理由は、
    herokuではpostgresqlをしようしなければならないだろうと認識しています。
    'ENGINE'の変更に問題があるのでしょうか?
    それとも
    'NAME'にも別な変更が必要になるのでしょうか?
    よろしくお願いします。

    キャンセル

回答 1

0

NAMEには、プロジェクトで使用するデータベース名を指定します。
また、以下のキーの値を設定する必要があります。

 キー   設定値 
 TEMPLATE   template1などデータベースを作成するときのテンプレート 
 USER   データベースに接続するユーザーの名前 
 PASSWORD   上記ユーザーのパスワード 
 HOST   データベースが稼働するホスト 
 PORT   データベースに接続するTCP/IPポート 

なお、ENGINEには、django.db.backends.postgresqlを指定した方が良いのではないかと思います。

DATABASES

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/09/16 23:47

    ご回答ありがとうございます。

    settings.pyに、
    DATABASES = {
    'default': {
    'ENGINE': 'django.db.backends.postgresql',
    'NAME': 'dbname',
    'USER': 'dbuser',
    'PASSWORD': 'FIX',
    'HOST': 'localhost',
    'PORT': '',
    }
    }

    このように書いてみました。そして
    python manage.py makemigrations
    を実行すると

    django.db.utils.OperationalError: could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?

    このようなエラーが発生しました。
    PORTが空欄なのが問題なのでしょうか?
    よろしくお願いします。

    キャンセル

  • 2020/09/17 08:36

    デフォルトでポートは5432が設定されるので大丈夫だと思います。
    postgresql.confやpg_hba.confなど、PostgreSQLの接続設定はされていますか?

    キャンセル

  • 2020/09/21 01:29

    ご回答ありがとうございます。

    >postgresql.confやpg_hba.confなど、PostgreSQLの接続設定はされていますか?

    接続設定についてはなにもしていません。
    恥ずかしながら、何も考えずにPostgreSQLとコードに打ち込んでいましたが、PostgreSQLを使うにはそれをインストールしなければならないということでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る