質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • PHP

    19870questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    1321questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • サーバ

    757questions

    サーバは、 クライアントサーバモデルにおいてクライアントからの要求に対し 何らかのサービスを提供するプログラムを指す言葉です。 また、サーバーソフトウェアを稼動させているコンピュータ機器そのもののことも、 サーバーと呼ぶ場合もあります。

  • FFmpeg

    83questions

    FFmpegは、動画と音声を交換できるフリーソフトウェアです。UNIX系OSから派生した、MS-DOSから操作するコマンドラインツールです。libavcodecやlibavformat、libswscale、libavfilterなどを含みます。ライセンスは、コンパイルの際のオプションによりLGPLもしくはGPLに決定されます。対応コーデックや使用できるオプションが多く、幅広く利用されています。

Ubuntu ffmpegのインストールがうまくいかない

解決済

回答 3

投稿 ・編集

  • 評価
  • クリップ 0
  • VIEW 2,556

lolipop

score 467

現在Ubutuサーバにffmpegをインストールし、ffmpegをPHPを使って動画のサムネイルを生成しようと考えています。

しかし、なかなかうまくいきません。

URLを参考にしたのですが、参考にする前は以下のようにやりました。

$sudo apt-get install ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ffmpeg' has no installation candidate
root@www5458up:~# ffmpeg
ffmpeg: command not found←こうなります。

その後以下のサイトに書いてあることを順序立ててインストールしていったのですが、(約50分くらいかかったかと思います。)ffmepgコマンドは結果、command not foundとなっていまします。

参考にしたURLです。
https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

ffmpegを使ったことがある方、ffmpegコマンドを使えるようにしたいのでどなたか是非解決策お願いします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+2

メッセージを見るとffmpegというパッケージがないのでFFmpegがインストールされていません。

PPAのレポジトリを追加してはどうでしょうか?
$ sudo add-apt-repository ppa:mc3man/trusty-media
$ sudo apt-get update
$ sudo apt-get install ffmpeg

または最新のコードをダウンロードしてコンパイル、インストールする方法もあります

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2014/10/07 16:10

    出来ました。
    回答ありがとうございます。
    ベストアンサーとさせて頂きます。

    キャンセル

0

具体的にどのような操作と結果が出ているのかわからないと解決できないかと思います。
先にやった操作の場合は明らかにパッケージが無効と出ているので失敗していますが…

コマンドがないと言われるということは、ビルドに失敗したかインストールに失敗していますが、具体的な結果が見えないとわかりません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2014/10/07 09:20

    TaMaMhyu様
    回答ありがとうございます。
    私は、https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu のリンクから
    Yasm
    libx264
    libfdk-aac
    libmp3lame
    libopus
    libfpx
    ffmpeg
    をYasmから開始しffmpegという順でインストールしました。
    上記URLのffmpegをインストール後、ffmpegコマンドを再度叩いてみましたが
    ffmpeg: command not found
    となっていました。
    TaMaMhyu様の回答の通りなのですが、ビルド失敗もしくはインストールに失敗しているのだと思っています。
    さすがに上記リンク先の叩いで出た出力結果が長過ぎるためteratail上に具体的に書くことは色々と大変なので割愛させていただきます。

    キャンセル

  • 2014/10/07 09:33

    どこかでエラーが出ているはずです。エラーの内容がわからないとなんとも言えないです。

    キャンセル

  • 2014/10/07 09:34

    「Get the Dependencies」の作業は行われたでしょうか?
    事前に必要な作業だと思うのですが。

    キャンセル

0

今はffmpegは公式リポジトリから削除されています。
かわりにavconvというソフトウェアがありましてこれを使うのが一般的です。

sudo apt-get install libav-tools
これで入ります。

使い方はffmpegと変わりません。元々FFmpegの派生なので。
ご参考までに。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • PHP

    19870questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    1321questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • サーバ

    757questions

    サーバは、 クライアントサーバモデルにおいてクライアントからの要求に対し 何らかのサービスを提供するプログラムを指す言葉です。 また、サーバーソフトウェアを稼動させているコンピュータ機器そのもののことも、 サーバーと呼ぶ場合もあります。

  • FFmpeg

    83questions

    FFmpegは、動画と音声を交換できるフリーソフトウェアです。UNIX系OSから派生した、MS-DOSから操作するコマンドラインツールです。libavcodecやlibavformat、libswscale、libavfilterなどを含みます。ライセンスは、コンパイルの際のオプションによりLGPLもしくはGPLに決定されます。対応コーデックや使用できるオプションが多く、幅広く利用されています。