質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

Q&A

解決済

1回答

3555閲覧

ターミナルからCocoaPodsをインストールできない

togiwa3

総合スコア6

terminal

Terminalは、Apple社のmacOSに標準で付属しているUNIX端末エミュレータ。UNIXコマンドによってMacの操作および設定を行うことができます。

MacOS(OSX)

MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

0グッド

0クリップ

投稿2020/04/19 00:52

前提・実現したいこと

MacのterminalからCocoaPodsをインストールしたいのですが、以下のエラーでインストールできない状態です。

実行したコマンド↓
sudo gem install cocoapods

どなたかご教示いただけませんでしょうか?

発生している問題・エラーメッセージ

Building native extensions. This could take a while... ERROR: Error installing cocoapods: ERROR: Failed to build gem native extension. current directory: /Library/Ruby/Gems/2.6.0/gems/ffi-1.12.2/ext/ffi_c /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby -I /Library/Ruby/Site/2.6.0 -r ./siteconf20200412-32010-2lb55y.rb extconf.rb mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/include/ruby.h You might have to install separate package for the ruby development environment, ruby-dev or ruby-devel for example. extconf failed, exit code 1 Gem files will remain installed in /Library/Ruby/Gems/2.6.0/gems/ffi-1.12.2 for inspection. Results logged to /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-19/2.6.0/ffi-1.12.2/gem_make.out

試したこと

gemを最新にする(sudo gem upgrade --system) 
以下のエラーが発生

While executing gem ... (Gem::CommandLineError) Unknown command upgrade

補足情報(FW/ツールのバージョンなど)

ProductName: Mac OS X
ProductVersion: 10.15.4
RubyGemsのバージョン: 3.1.2

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

TsukubaDepot

2020/04/19 02:40

https://teratail.com/questions/252681 まずはこちらの例は試されたでしょうか。 ちなみに、上記の質問へのコメントにもあるように、Homebrew を入れるのが一番良さそうです。
togiwa3

2020/04/22 13:49

Homebrewを入れたらできました! ありがとうございます!!
guest

回答1

0

ベストアンサー

mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/include/ruby.h
You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

Rubyをビルドするための環境が不足しているエラーがたくさん出ています。
何らかのパッケージを事前に入れておく必要があるのでしょう。

MacOSの場合、「Homebrew」というパッケージマネージャを導入しておくと、
不足しているファイルを検索して見つかればインストールできるので便利です。

私のMacOSXもHomebrewを導入していますが、cocoapodsは簡単にインストールできました。
よろしければHomebrewを使ってみてください。便利ですよ。

$ gem install cocoapods (一般ユーザで実行できるのが便利) 省略 Fetching cocoapods-deintegrate-1.0.4.gem Fetching cocoapods-downloader-1.3.0.gem Fetching cocoapods-plugins-1.0.0.gem Fetching cocoapods-search-1.0.0.gem Fetching cocoapods-stats-1.1.0.gem Fetching cocoapods-trunk-1.4.1.gem Fetching cocoapods-try-1.1.0.gem 省略 Successfully installed cocoapods-deintegrate-1.0.4 Successfully installed cocoapods-downloader-1.3.0 Successfully installed cocoapods-plugins-1.0.0 Successfully installed cocoapods-search-1.0.0 Successfully installed cocoapods-stats-1.1.0 Successfully installed cocoapods-trunk-1.4.1 Successfully installed cocoapods-try-1.1.0 省略 33 gems installed

投稿2020/04/19 03:51

technocore

総合スコア7264

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

togiwa3

2020/04/22 13:49

Homebrewを使ったらインストールすることができました! ありがとうございます!!
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問