質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.11%

ubuntu18.04にNVIDIAドライバーを入れたが-smi表示せず-2

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 766

deka-cho

score 18

以前、下記の質問をして「セキュアブートをオフにしてみては?」とのご助言を戴き実行するとnvidia-smi表示が出来ました。有難うございました。


Windows10PCの外部SSDにubuntu18.04を入れ、NVIDIAドライバーを入れてリブートさせようとしたら下記の表示が出た。そのままリブートすると
nvidia-smiのコマンドに対してステータス表示せず。ドライバー等が認識されていません。
Your system has UEFI Secure Boot enabled.UEFI Secure Boot requires additional configuration to work with third-party drivers.
The system will assist you in configuring UEFI Secure Boot. To permit the use of third-party drivers, a new Machine-Owner Key (MOK) has been generated.This key now needs to be enrolled in your system's firmware.
To ensure that this change is being made by you as an authorized user,and not by an attacker,you must choose a password now and then confirm the change after reboot using the same password, in both the "Enroll  MOK" and "Change Secure Boot state"  menus that will be presented to you  when this system reboots. 


しかし、そのままCUDA10.0を入れようとしたら下記のエラーとなりました。
ERROR: An NVIDIA kernel module 'nvidia-drm' appears to already be loaded in your kernel.  This may be because it is in use (for example, by an Xserver, a CUDA program, or the NVIDIA Persistence Daemon), but thismay also happen if your kernel was configured without support for     module unloading.  Please be sure to exit any programs that may be      using the GPU(s) before attempting to upgrade your driver.  If no       GPU-based programs are running, you know that your kernel supports       module unloading, and you still receive this message, then an error       may have occured that has corrupted an NVIDIA kernel module's usage       count, for which the simplest remedy is to reboot your computer.


今度はセキュリティブートをONにしてubuntuに入ると
nvidia-smi表示は出来ませんがdpkg -l |grep nvidia表示ではしっかりドライバー類は入っています。そのままcuDNNも入りましたが、tensorflowのtf.test.is_gpu_available()でGPUが無いと言われました。
結局セキュリティブートをONのままドライバーを入れる方法を探るか?又はOFFにしてCUDAは入るようにするかですが、Nouveauを無効化する
http://tadaoyamaoka.hatenablog.com/entry/2018/01/05/232416とか
https://atsuyakoike.hatenablog.com/entry/2019/08/08/214530
を参考にやってみましたが、成功しません。そもそもセキュリティブートとの関連性の記述がある記事は見つかりません。パソコンは新型(GPU:RTX1650)ですし、UBUNTUのクリーンインストール状態からNvidiaDriverのインストールでエラーとなります。
ご指導よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

+1

セキュリティブートとの関連性の記述がある記事が見つかりませんと書きましたが、
http://kottas.hatenablog.com/entry/2019/02/02/000000等その他ありました。
しかし、この記事で
sudo apt install mokutil
sudo mokutil --disable-validationをやってリブートコマンドを打ったらパワーオフして
立ち上がらなくなりました。エラーは
Failed to open \EFI\BOOT\mmx64.efi -Not Found
Failed to load image \EFI\BOOT\mmx64.efi -Not Found
Failed to start MockManager: Not Found
Something has gone seriously wrong:imput_mok_state() failed:Not Found
さらに問題なのはその時全く使っていないubuntuのインストール用のUSBメモリでも同じエラーで立ち上がりません。ということはPC側に何か変更がかかったということですがbiosの設定でそんなものはありませんので理解が全く不能です。
GPU:RTX1650は間違いでGTX1650でした。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/01/13 19:03

    biosを工場設定モードにしても治りません。しかし、
    MMX64.efiというファイルがないのなら.efiというファイルから作れ!との記事を見つけたので\EFI\BOOTにあるgrubx64.efiをコピーしてMMX64.efiを作ったら、ブートするようになりました。まことに理解不能ながらこの問題は解決しました。
    nvidiaドライバーとcudaの問題は別々にインストールすると色々やりましたが上手く行きません。
    https://qiita.com/yukoba/items/4733e8602fa4acabcc35
    のように一括で入れる方法でようやく解決しました。
    GPUの種類とDRIVERとCUDAのバージョンの関係で非常に難しいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.11%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる