質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

解決済

[Laravel]composer requireでエラーが出る。Conclusion: remove laravel/framework v5.8.35

yakito-morokosi
yakito-morokosi

総合スコア11

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

2回答

0評価

2クリップ

8841閲覧

投稿2019/11/01 00:12

### やりたいこと
laravelcollectiveをインストールしたい。

やったこと

composer require laravelcollective/html

エラーメッセージ

error

Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: remove laravel/framework v5.8.35 - Conclusion: don't install laravel/framework v5.8.35 - laravelcollective/html 6.0.x-dev requires illuminate/view ^6.0 -> satisfiable by laravel/framework[6.x-dev], illuminate/view[6.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.1.0, v6.2.0, v6.3.0, v6.4.1]. - laravelcollective/html 6.0.x-dev requires illuminate/view ^6.0 -> satisfiable by laravel/framework[6.x-dev], illuminate/view[6.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.1.0, v6.2.0, v6.3.0, v6.4.1]. - laravelcollective/html v6.0.3 requires illuminate/view ^6.0 -> satisfiable by laravel/framework[6.x-dev], illuminate/view[6.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.1.0, v6.2.0, v6.3.0, v6.4.1]. - laravelcollective/html v6.0 requires illuminate/view 6.0.* -> satisfiable by illuminate/view[v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4]. - laravelcollective/html v6.0.1 requires illuminate/view 6.0.* -> satisfiable by illuminate/view[v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4]. - laravelcollective/html v6.0.2 requires illuminate/view 6.0.* -> satisfiable by illuminate/view[v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4]. - Can only install one of: laravel/framework[6.x-dev, v5.8.35]. - don't install illuminate/view 6.x-dev|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.0.0|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.0.1|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.0.2|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.0.3|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.0.4|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.1.0|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.2.0|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.3.0|don't install laravel/framework v5.8.35 - don't install illuminate/view v6.4.1|don't install laravel/framework v5.8.35 - Installation request for laravel/framework (locked at v5.8.35, required as 5.8.*) -> satisfiable by laravel/framework[v5.8.35]. - Installation request for laravelcollective/html ^6.0 -> satisfiable by laravelcollective/html[6.0.x-dev, v6.0, v6.0.1, v6.0.2, v6.0.3]. Installation failed, reverting ./composer.json to its original content.

備考

composer.jsonの"require"には"laravel/framework": "5.8.*"があります。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Laravel

LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。