質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

Githubからchainerをダウンロードしてimportできるようにする方法

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 1,447

score 19

前提・実現したいこと

Githubからchainerをダウンロードしてimportできるようにしたいです。
Anacondaのsite-packagesにchainerをコピーしました。
そのあと、jupyterlabでimportしてみたのですが、エラーが起きました。
どうすれば、importできるのでしょうか?

発生している問題・エラーメッセージ

ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-12-68de7802c7dc> in <module>
      1 
----> 2 import chainer

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\__init__.py in <module>
      8 
      9 from chainer import _version
---> 10 from chainer import backends  # NOQA
     11 from chainer import dataset  # NOQA
     12 from chainer import datasets  # NOQA

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\backends\__init__.py in <module>
----> 1 from chainer.backends import cuda  # NOQA
      2 from chainer.backends import intel64  # NOQA
      3 
      4 
      5 # TODO(niboshi): Refactor registration of backend modules for functions like

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\backends\cuda.py in <module>
     44 from chainer import _backend
     45 from chainer.backends import _cpu
---> 46 from chainer.backends import intel64
     47 from chainer.configuration import config
     48 from chainer import types  # NOQA

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\backends\intel64.py in <module>
      6 from chainer import _backend
      7 from chainer.backends import _cpu
----> 8 from chainer.configuration import config
      9 
     10 

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\configuration.py in <module>
      3 import typing as tp  # NOQA
      4 
----> 5 from chainer import types  # NOQA
      6 
      7 

~\Anaconda3\lib\site-packages\chainer-7.0.0b4-py3.7.egg\chainer\types.py in <module>
      1 import numbers
      2 import typing as tp  # NOQA
----> 3 import typing_extensions as tpe  # NOQA
      4 
      5 try:

ModuleNotFoundError: No module named 'typing_extensions'

該当のソースコード

import sys
sys.path.append(r"C:\Users\***\Anaconda3\Lib\site-packages\chainer-master")
#***はユーザー名
import chainer

試したこと

ないです。

補足情報(FW/ツールのバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

chainerは知らないのですが、ここのGitHubですか?

chainerに限らず、pythonのソースパッケージで「setup.py」が用意されているものは、その「setup.py」でインストールする事を想定しています。
ですので、単なるコピーでインストールするのは避けるべきです。

とりあえず「setup.py」のあるディレクトリに移動し、「pip install .」と実行すればインストールできるので、そのようにしましょう。

ただし、他のコメントでも出ていますが、依存しているパッケージもインストールしなければならないので、エラーになると思います。
setup.pyを見ると、以下のように書かれているので、これらのパッケージもインストールしてください。
(そして、それらが依存しているパッケージも、です)

requirements = {
    'install': [
        'setuptools',
        # typing==3.7.4 causes error "TypeError: Instance and class checks can
        # only be used with @runtime_checkable protocols" only with Python 2.
        # https://github.com/chainer/chainer/pull/7562
        'typing' + ('<=3.6.6' if sys.version_info[0] <= 2 else ''),
        'typing_extensions' + ('<=3.6.6' if sys.version_info[0] <= 2 else ''),
        'filelock',
        'numpy>=1.9.0',
        'protobuf>=3.0.0',
        'six>=1.9.0',
    ],

んで、GitHubからソースを持ってくる事にこだわらない、かつ他にpipでインストールできる環境があるのであれば、その環境でパッケージをダウンロードして、ダウンロードしたパッケージを該当環境に持ってきてインストールした方が、このような依存関係も簡単に解決できるでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/25 21:47

    一旦それで月曜日にやってみます。

    キャンセル

0

どうしても,Githubからchainerをダウンロードしてimportしたいというわけでないのなら,

pip install chainer


でインストールできます.
また,anacondaでしたら,

conda install cupy chainer


でインストールできるようです.(未確認)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/25 15:12

    長い時間機械学習を行いたいので
    ローカルで行いたいです。

    キャンセル

  • 2019/10/25 17:09

    そもそも論なのですが、プロキシの設定してcondaあるいはpipでインストールするのはいかがでしょうか。
    windowsでしたら環境変数にHTTP_PROXY・HTTPS_PROXYあたりを追加すればコマンドが使用できるようになるかと思います。

    キャンセル

  • 2019/10/25 21:47

    プロキシも検討してみます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る