質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

Eclipseがクラッシュする

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 5,002

score 159

質問

Raspberry Pi3、Ubuntu MATE18.04LTSでのJava開発環境としてEclipseを

sudo apt install eclipse


でインストールしましたがEclipseを起動しようとすると下の画像のようにエラーが出て起動しません。
Eclipseのエラー
言われる通り、/home/<ユーザー名>/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1554289702018.logを見てみると

!SESSION Wed Apr 03 20:08:22 JST 2019 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-04-03 20:08:22.177
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)


というエラーが出力されていました。Javaのエラーっぽいのですが意味不明です。Eclipseがないと開発が不便なので直し方を教えていただきたいです。

バージョン情報

Raspberry Pi 3 B
OS : Ubuntu MATE 18.04 LTS
Eclipseバージョン: 3.8(だと思います)
OpenJDK 11 (依存パッケージとしてインストールされました)
その他にOracleJDKもインストールされています。Pleiadesはインストールされていません。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

fuji_0055さん、

Ubuntu Mate(ubuntu-mate-18.04.2-beta1-desktop-armhf raspi-ext4.img)だと、書かれているエラーがでます。

Eclipse fails to start (java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter) を見ると、まだ、ubuntuは、In Progressで、なおってないっぽい??ですね。

しかし、Raspbian Stretch(2019-04-08-raspbian-stretch.img)環境だと apt install ecpliseで動きました。

ので、Raspbianのレポジトリにあるのを使ってみます。

UbuntuとRaspbianのパッケージで、競合するものがあると、上手くインストールできないので、eclipseに関連したものをすべてアンインストールしてください.
(フレッシュインストールした、ubuntu-mate-18.04.2-beta1-desktop-armhf raspi-ext4.imgのイメージで確認しています。)

# raspbianレポジトリ情報追加
echo 'deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi' | sudo tee /etc/apt/sources.list.d/raspbian.list

# 鍵を登録
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys  9165938D90FDDD2E

# パッケージ情報更新
sudo apt update

# stretchのeclipseを導入
sudo apt install -t stretch eclipse

#念の為更新されないように hold 
sudo apt-mark hold eclipse

ラズパイUbuntuMateでEclipse

(追記)
java-11 では、エラーになるので、複数javaが入っているというような場合は、sudo update-alternatives --config javaで、java-8を使うようにしてください

mt08@mt08-desktop:~$ sudo update-alternatives --config java
alternative java (/usr/bin/java を提供) には 2 個の選択肢があります。

  選択肢    パス                                          優先度  状態
------------------------------------------------------------
* 0            /usr/lib/jvm/java-11-openjdk-armhf/bin/java      1101      自動モード
  1            /usr/lib/jvm/java-11-openjdk-armhf/bin/java      1101      手動モード
  2            /usr/lib/jvm/java-8-openjdk-armhf/jre/bin/java   1081      手動モード

現在の選択 [*] を保持するには <Enter>、さもなければ選択肢の番号のキーを押してください: 2
update-alternatives: /usr/bin/java (java) を提供するためにマニュアルモードで /usr/lib/jvm/java-8-openjdk-armhf/jre/bin/java を使います
mt08@mt08-desktop:~$

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/13 15:04

    動かない原因は何なんでしょう?
    不思議ですね。

    キャンセル

  • 2019/04/13 15:28 編集

    バグ報告から、1年以上もたっているのに、直ってないなんて、なんでしょうね。

    キャンセル

  • 2019/04/14 11:10

    https://forums.ubuntulinux.jp/viewtopic.php?id=10193のようにパッケージがDebianとUbuntuのものでめちゃくちゃになってしまったりしないか心配です。
    とりあえず頑張ってみます。ありがとうございました。

    キャンセル

  • 2019/04/14 12:46

    ほかディストリビューションのレポジトリを混ぜると、そういった心配はありますね。JAVA関係だと関係しそうな範囲も広そうですし...
    なので、`ワカッテイル人`向け、でしょうね。

    もっとうまい方法が見つかったら、シェアしてくださいね。

    キャンセル

0

類似の問題
Eclipse fails to start (java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter)

この中の#11が参考になるかも。
他にもいくつかの対策が記載されています。

Silly me! There is a simple work around:
​apt-get purge eclipse ; ​apt autoremove
Download Eclipse Installer on https://eclipse.org/downloads and install it as non root.
My apologizes.
【Google翻訳】
愚かな私! 簡単な回避策があります。
apt-get purge eclipse; 適切な自動削除
https://eclipse.org/downloadsからEclipseインストーラーをダウンロードし、非rootとしてインストールしてください。
私の謝罪。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/06 20:02

    ARM用のバイナリーが公式サイトに用意されていない(メインのPCの32bit用まで)ので、公式サイトからダウンロードすることができません。
    自力で何とか直したいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る