質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

よくわかりません助けてください;

受付中

回答 5

投稿

  • 評価
  • クリップ 0
  • VIEW 12K+

score 13

```### 前提・実現したいこと
※プログラミング初心者の学生です。詳しく教えてくださると助かります。。

ラズベリーパイにて、AIとカメラによる画像認識を作りたいのですが(AIひょっこり猫カメラ)
ImportError:No module named 'keras'
とエラー出ました…
tensorflow内のフォルダにkerasあるのですが…

試したこと

インストールし直したり、アップグレードし直したり
import keras を追加してみたりしましたが なおりません

補足情報(FW/ツールのバージョンなど)

ターミナルでpip showしてみたところ
tensorflow==1.110
keras==2.2.4
pip==19.0.1
numpy==1.15.4
scipy==0.18.1
theanoは、「DEPRECATION:Python 2.7 will reach the end of its life on January 1st,2020.Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.」と出て バージョン出て来ませんでした。

pythonは3.7.2DLしたはずなのですが…

スマホだと画像載せれないぽいので、pcにスクショのせます

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • dit.

    2019/01/24 15:32

    タイトルは要件をわかりやすく書いてください。
    質問するときのヒントhttps://teratail.com/help/question-tipsにもありますが「助けてください」「初心者です」はありがちな失敗として挙げられています。

    キャンセル

  • dit.

    2019/01/24 15:33

    また、質問は編集することができますので新たに質問を作成するのではなくこの質問を編集してください。(新しく作ってしまった質問は回答がつかないうちに削除リクエストしてください。)

    キャンセル

  • Helldragon

    2019/01/24 15:39

    なるほど…初めてで 急を要するものだったので
    すみません… 助言ありがとうございます

    キャンセル

  • 退会済みユーザー

    2019/01/24 18:02

    複数のユーザーから「やってほしいことだけを記載した丸投げの質問」という意見がありました
    「質問を編集する」ボタンから編集を行い、調査したこと・試したことを記入していただくと、回答が得られやすくなります。

回答 5

+1

pip3 install keras
pip3.7 install keras


のどっちかで行けると思います

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/24 16:00

    pip3.5のコマンド見つかりません です

    キャンセル

  • 2019/01/24 16:01

    お手上げ。
    諸々ちゃんとインストールできていないっぽいので、インストール過程を落ち着いて見直してみてください

    キャンセル

  • 2019/01/24 16:03

    わかりました
    お手数すみません
    ありがとうございました

    キャンセル

+1

ラズベリーパイは使ったことすらないのですが、この様子だとpython3.7.2は正しくインストールされていません。
おそらく、tensorflowなどは全てpython2.7のほうにインストールされているものだと思われます。
また、tensorflowはこちらを見た限りだと、3.6までしか対応していないようです。
なので、まずはpythonのインストールから行う必要があります。
インストール方法については、「ラズベリーパイ python インストール」で検索するといくつか出てきたので、そちらを参考にしてください。

pythonがインストール出来たら、改めてpipでtensorflowやkerasをインストールすればよいと思います。
(なお、すでにpython2.7が入っているようなので、pip3.6になったりするかもしれません)


tensorflow内のフォルダにkerasあるのですが…

これはtensorflowに組み込まれているkerasであり、通常のkerasとは異なります。
こちらを使いたい場合は、from keras.~ import ~from tensorflow.keras.~ import ~とする必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/24 16:55

    丁寧にありがとうございます!
    試してみます。。

    キャンセル

0

pip showでのkeras よく見てみると
Location:/usr/local/lib/python2.7/dist-packages
でした

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

python3コマンドで動くpython 3.5.3があるようですが、こちらはデフォルトでインストールされていたものですか? であればそれを使えは問題ないと思います。

ライブラリ類はpython3 -m pipが動けばそれを使えば良いです。

また、aptでも入る(そしてそちらの方が推奨される雰囲気みたい)なので、さっさと構築したければそちらを用いれば良いでしょう。pipがない場合も、たぶんapt経由で入ると思います(未検証)。

Raspberry PiのPythonライブラリはpipよりapt-getで入れるのが断然早い - karaage. [からあげ]

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

ラズベリーパイのOSはRaspberryのwith desktop
で、リモートデスクトップではないやりかたでやってるのですが
関係ありますか…?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る