質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Java EE

Java EE(Java Enterprise Edition)はJavaベースのテクノロジーとその相互運用の仕様をまとめたものです。サーバとクライアントのアーキテクチャを規定し、特定アプリケーションのクラス用に定義されたテクノロジー設定のプロファイルを使用します。

Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

サーブレット

サーブレット(Servlets)とはウェブやアプリケーションサーバー上に動くプログラムのことであり、ウェブブラウザや他のHTTPクライエントとデータベースやHTTPサーバー上のアプリケーションの中間層としての働きをします。

Q&A

解決済

3回答

32916閲覧

初心者です。 javax.servlet.annotation.WebServlet がインポートできません。

YugoOgura

総合スコア14

Java EE

Java EE(Java Enterprise Edition)はJavaベースのテクノロジーとその相互運用の仕様をまとめたものです。サーバとクライアントのアーキテクチャを規定し、特定アプリケーションのクラス用に定義されたテクノロジー設定のプロファイルを使用します。

Java

Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

サーブレット

サーブレット(Servlets)とはウェブやアプリケーションサーバー上に動くプログラムのことであり、ウェブブラウザや他のHTTPクライエントとデータベースやHTTPサーバー上のアプリケーションの中間層としての働きをします。

1グッド

0クリップ

投稿2015/09/18 12:51

編集2015/09/18 14:33

最近、javaを学び始めたものです。初歩的な質問かもしれませんが、よろしくお願いします。

Eclipseを使ってサーブレットクラスを作成しようと思ったのですが、
「javax.servlet.annotation.WebServlet」をインポートしようと思っても、
「インポートされた javax.servlet.annotation は見つかりません」とエラーがでます。
参考にしている本を見ても、解決方法がのっておらず、困っています。
どなたか原因を教えて下さい。お願いします。

追記
使用しているアプリケーションサーバは、Apache Tomcatv7.0.xです。

どのようにしてサーブレットクラスを作成したかというと、
ファイルメニューから、「動的プロジェクト」を作成。
そのプロジェクトを、ローカルホストのTomcat7(Java7)サーバーに追加。
そして、そのプロジェクトの中にサーブレットクラスを新規作成しました。

misaki0422👍を押しています

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

argius

2015/09/18 14:05

Eclipseで新規プロジェクトなどでプロジェクトを作成したと思いますが、これの種類によって操作が変わってきます。どのように新規プロジェクトを作成したかを教えてください。
YugoOgura

2015/09/18 14:21

ありがとうございます。 詳しく書きました。
guest

回答3

0

ベストアンサー

javax.servlet.annotation.WebServletServlet 3.0でないと使えないようです。

Eclipseでどのようにプロジェクトを作っているのかを具体的に教えてください。


(追記)

動的Webモジュールを作成するときに、そのバージョンが3.0になっていればServlet3.0になっているはずです。
もう一度新規プロジェクトを実行してみて、ウィザード画面の「動的Webモジュール バージョン」という項目を見てみてください。
3.0が選択出来ない場合、Eclipseのバージョンが古い可能性もあります。その場合は新しいEclipseを使った方が良いです。

あとから変更するには、
プロジェクトのプロパティーを開き、プロジェクト・ファセットという設定を探します。
その中に「動的Webモジュール」という項目がありますので、それを3.0に変更すればServlet3.0になります。

投稿2015/09/18 12:58

編集2015/09/18 14:28
argius

総合スコア9392

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

YugoOgura

2015/09/19 14:03

確かに、3.0ではなく、2.5が選択されていました!ここが変更できればいいのですね! 僕が使っているEclipseは,「Eclipse 4.5 Mars Pleiades All in One」です。 これで選べるのが今のところServlet2.5までなのですが、これでは新しくないのでしょうか?
argius

2015/09/19 14:49

Apache Tomcat7.0が選択されている(らしい)というお話しでしたので、Eclipseが古い可能性を疑いました。 Eclipse 4.5でしたら最新ですね。 解決されたようですので、自己解決でも構いません、質問をクローズしていだだけると助かります。
guest

0

arguisさんからご指摘があった、プロジェクト・ファセットの動的Webモジュールの項目で、ランタイム(R)の項目を見たら、Tomcat6が選んであり、それをTmcat7に変更したら、Servlet3.0を選ぶことができ、すべてうまくいきました!!
使用しているサーバーがTomcat7でも、それ以外のところでtomcat6を選んでいたのがいけなかったみたいです。
お騒がせしました。回答してくださったかたがた、ありがとうございました。

投稿2015/09/19 14:10

YugoOgura

総合スコア14

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

javax.servlet.annotation.WebServletというアノテーションを含んだservlet-api.jarがクラスパスにないと思われます。このアノテーションはServlet APIのv3.0に追加されたものなので、結構新しいです。

参考にされている書籍が解説されているのは、Servlet API v3.0を対象にしている書籍なのでしょうか?その辺りが異なると、設定方法も違うことがよくあります。できるだけ書籍に書かれている手順で環境を作り、バージョンに合わせることをオススメします。

参考: Webアプリケーションの基礎 Servlet編

投稿2015/09/18 12:59

退会済みユーザー

退会済みユーザー

総合スコア0

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

YugoOgura

2015/09/18 13:58

回答ありがとうございます。 参考にしている書籍は、Servlet APIv3.0を対象にしており、その本の通りにやると、@WebServletアノテーションも自動で作成されるはずなのですが...。 本と同じ手順でやったつもりなのです...。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問