質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.46%

  • Ruby

    9707questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2552questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • Ubuntu

    1868questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • VirtualBox

    931questions

    VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。

VirtualboxUbuntuでrails起動方法が分かりません。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 163

DrqYuto

score 116

sudo apt install ruby-railties

rails new bbs
したところ
cannot load such file
イメージ説明

イメージ説明

bundler error?が出ました…
イメージ説明

bundlerはインストールできました?が、rails -vでエラー?が出ました。
イメージ説明

nokogiriでエラー出ました。
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

gem をインストールする時に bundler が必要ですが、その bundler がないためエラーが起きている気がします。

gem install bundler

上記を実行して見てください。

念のため参考の URL を貼らせていただきます。

https://qiita.com/tokimari/items/51ac63a1fe244b819aea

よかったら参考にしてくださいね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/12 15:16

    gem install bundlerでエラー?が出ました

    キャンセル

  • 2018/11/12 19:28

    sudo gem install bundler
    を試してみてください。

    permission がないと吐かれていますね。
    sudo を付けると、スーパーユーザーという管理者的なのでコマンドを実行できますよ!!

    キャンセル

  • 2018/11/13 13:16

    sudoはできましたが、rails -vができなくなりました…

    キャンセル

  • 2018/11/13 18:21

    解決に時間がかかってしまい申し訳ないです・・・泣

    問題を二つに大別できると思っています。

    まず、そもそもの
    「rails -v ができない」
    ということと
    「nokogiri がインストールできない」ということだと思っています。

    「rails -v」ができない問題ですが、
    Gemfile の中身を見せていただきたいです。

    また、下記サイトがとても現象に似ている気がします。
    試してみてください。
    https://qiita.com/dskst/items/b1f073fcffeca3bc9fc6#9-brew-doctor-%E3%82%92%E3%81%97%E3%81%A6%E3%81%BF%E3%81%9Fnokogiri%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%AB%E6%88%90%E5%8A%9F

    二つ目の「nokogiri がインストールできない」問題ですが、
    最後の画像にある gen install nokogiri … を実行した際のエラーログを見せて欲しいです。

    キャンセル

  • 2018/11/13 21:09

    Ubuntu入れ直したのでまた明日やります。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.46%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby

    9707questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2552questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • Ubuntu

    1868questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • VirtualBox

    931questions

    VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。