質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • Linux

    3907questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    2772questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Ubuntu

    1491questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • シェル

    251questions

    シェル(shell)はUnix や Linux 系のOSで使用されるコマンドインタプリタを指します。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

yum install が出来ません。

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 8,803

EzrealTrueshot

score 373

CentOS6.5にベンチマークソフトを入れようとしたのですが下記エラーがでて、困っております。
(正確にはベンチマークソフトに必要な前提となるもの。)

--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.132.el6_5.2.i686 (update)
           Requires: glibc-common = 2.12-1.132.el6_5.2
           Installed: glibc-common-2.12-1.132.el6_5.3.x86_64 (@updates)
               glibc-common = 2.12-1.132.el6_5.3
           Available: glibc-common-2.12-1.132.el6.x86_64 (base)
               glibc-common = 2.12-1.132.el6
           Available: glibc-common-2.12-1.132.el6_5.1.x86_64 (update)
               glibc-common = 2.12-1.132.el6_5.1
           Available: glibc-common-2.12-1.132.el6_5.2.x86_64 (update)
               glibc-common = 2.12-1.132.el6_5.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Requires: glibc-common = 2.12-1.132.el6_5.2
と表示されているので、それらしきものをもってきたのですが、上手く行きません。

これはいったい何が原因なのでしょうか?


  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

glibc-commonの2.12-1.132.el6_5.2が必要なのに、
(略)3.x86_64がインストールされてるから失敗しているように思えます。

OSは64bitですか?
64bitであればインストールしようとしてるパッケージの64bit用(x86_64)があればそっちをインストールしてみてください。
32bitだったらglibc-commonを一度アンインストールして32bit用をインストールしてみてください。
一応最後の数字も合わせて。

ちなみにi686とx86_64は別物です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2014/08/25 21:28

    $ rpm -e glibc-common-2.12-1.132.el6_5.3.x86_64
    error: Failed dependencies:
    glibc-common = 2.12-1.132.el6_5.3 is needed by (installed) glibc-2.12-1.132.el6_5.3.x86_64

    なんか泥沼にはまってますかね?
    困ったなぁ・・・

    キャンセル

  • 2014/08/25 22:04

    glibc-commonをアンインストールしてもらって、
    glibc-common-2.12-1.132.el6_5.2.(i686/x86_64)をインストールしてみてください。
    el6_5.3ではなくel6_5.2です。
    (i686/x86_64)がどっちかは「uname -a」して出てきた方で。

    glibc-commonのアンインストールは、yumでインストールしているならyum removeで

    キャンセル

  • 2014/08/25 23:31

    あ、
    glibc-commonがアンインストールできれば、
    yum installするときに勝手に適切なglibc-common入れてくれるかもしれないです。

    キャンセル

  • 2014/08/26 13:04

    >glibc-commonをアンインストールしてもらって・・・
    依存関係が多すぎて?remove出来ませんでした。
    Skipping the running kernel: kernel-2.6.32-431.el6.x86_64
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    --> Finished Dependency Resolution
    Error: Trying to remove "yum", which is protected
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    >glibc-common-2.12-1.132.el6_5.2.(i686/x86_64)をインストールしてみてください。
    $ rpm -ivh glibc-2.12-1.132.el6_5.2.i686.rpm
    warning: glibc-2.12-1.132.el6_5.2.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEY
    error: Failed dependencies:
    glibc-common = 2.12-1.132.el6_5.2 is needed by glibc-2.12-1.132.el6_5.2.i686
    libfreebl3.so is needed by glibc-2.12-1.132.el6_5.2.i686
    libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.132.el6_5.2.i686


    私が使っているOSは64bitですが、32bit版プログラムを使用するために
    $yum install glibc.i686
    これが絶対に必要なのです;

    他にどのような手があるでしょうか?

    キャンセル

  • 2014/08/26 15:12

    たまたま手元の環境でcentosの32bitあったのでglibc.i686のバージョンみてみたら、
    5.3って出て来ましたね。
    bit数関係なくglibcのバージョンが古いのにglibc-commonが新しいからおかしくなってるかもしれないです。
    yum updateでパッケージ更新してみてyum installしたらどうなりますかね??

    キャンセル

関連した質問

同じタグがついた質問を見る

  • Linux

    3907questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • CentOS

    2772questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Ubuntu

    1491questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • シェル

    251questions

    シェル(shell)はUnix や Linux 系のOSで使用されるコマンドインタプリタを指します。

  • yum

    153questions

    yumコマンドは、UNIX系OSのRPMパッケージのインストールなどを行うためのプログラムのことです。

関連ワード: trying to remove "yum", which is protected error: trying to remove "yum", which is protected glibc-2.12