質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.64%

ラズベリーパイでapt-getコマンドが途中で止まる

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,486

soich

score 155

環境

  • Raspberry Pi 3 Model B
  • Raspbianのバージョン
pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

 事象

apt-getコマンドでlircをインストールしたいのですが「トリガを処理しています」で処理が止まってうまくインストールできません。
▼実行コマンド

pi@raspberrypi:~ $ sudo apt-get install  lirc
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
提案パッケージ:
  lirc-compat-remotes lirc-drv-irman lirc-doc lirc-x setserial ir-keytable
推奨パッケージ:
  gir1.2-vte
以下のパッケージが新たにインストールされます:
  lirc
アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
426 kB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 1,898 kB のディスク容量が消費されます。
以前に未選択のパッケージ lirc を選択しています。
(データベースを読み込んでいます ... 現在 118872 個のファイルとディレクトリがインストールされています。)
.../lirc_0.9.4c-9_armhf.deb を展開する準備をしています ...
lirc (0.9.4c-9) を展開しています...
lirc (0.9.4c-9) を設定しています ...
Listing '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/baseview.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/choosers.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/config.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/database.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/mvc_control.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/mvc_model.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/mvc_view.py'...
Compiling '/usr/lib/arm-linux-gnueabihf/python3/dist-packages/lirc/util.py'...
systemd (232-25+deb9u4) のトリガを処理しています ...

man-db (2.7.6.1-2) のトリガを処理しています ... # ←ここで処理が止まってインストールされない
pi@raspberrypi:~ $ cat /etc/os-release

また、apt-get updateapt-get remove vim等のコマンドも同じく途中で終了しております。
日本語フォントなどをインストールしていたので数日前まではapt-get使えていたと思います。

原因などわかりますでしょうか。raspbianフォーマットし直した方が良いのでしょうか。。
足りない情報などあればコメントください。

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

すみません、apt-getはトリガーを処理していますでインストール完了なんですね。
大変な勘違いでした。こちら閉じます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る