質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

Linux ubuntu 18.04 「yumについて」

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,234
退会済みユーザー

退会済みユーザー

端末を利用しプリンタードライバーをインストールしていた時の話です。
コマンドライン(流れていた時)にyum ・・ 有効なリポジトリがありませんとエラーが吐かれましたがインストーラーは無視した模様でした。

有効なリポジトリが有りませんって言われた時
どのように対処すればいいのですか?

ご教授お願いします

Linux ubuntu 18.04

補足

★プリンター(モデル):Brother DCP-J572N

★インストール手順

  1. Brotherサポートサイトにて型式を入力
  2. 簡易インストーラをdebでダウンロード
  3. そして端末を開き,Downloadフォルダーに移動して
  4. bash linux-brjprinter-installer-2.2.1-1 と入力して従った

★ソースコード(インストール):https://gist.github.com/mumui-m/1f4bedcd2859918465711d643b1c2124

★エラー:
yum install policycoreutils-python
Repository 'reposioty': Error parsing config: Error parsing "baseurl = 'reposioty..'": URL must be http, ftp, file or https not ""
Repository 'repository_url': Error parsing config: Error parsing "baseurl = 'repository_url'": URL must be http, ftp, file or https not ""
有効なリポジトリーがありません。
「yum repolist all」を実行し、所持するリポジトリーを参照してください。
「yum-config-manager --enable <repo>」でリポジトリーを有効にできます。
...

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2018/10/15 06:35

    プリンタの種類とコマンドラインで実行したコマンドを質問に追記していただけないでしょうか?

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2018/10/15 18:50

    了解しました。

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2018/10/15 20:04

    更新しました

    キャンセル

回答 3

checkベストアンサー

0

yumはRHEL系Linux用(CentOSとか)のパッケージ管理システムを指します。
Ubuntuでいうところのaptみたいなもんですね。
なので、おそらく用意したインストーラ(?)はUbuntu向けでは無いのかもしれません。
ですので、Ubuntu向け(若しくはDebian向けでもいけるかもですが)のドライバを用意できるのか
確認するところから始めてみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/15 20:03

    はい

    キャンセル

0

Ubuntu 18.04に対応したプリンタードライバーをインストールしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/15 20:03

    brother サポートページからdeb版をダウンロードしました
    そしてbash linux-brjprinter-installer-2.2.1-1で従いました。

    キャンセル

0

最初のページで Linuxの選択からやりなおしてみてはいかがでしょうか?

  1. https://support.brother.co.jp/j/b/downloadtop.aspx?c=jp&lang=ja&prod=dcpj572n
    に移動する。
  2. OSをLinuxに OSのバージョンをLinux(deb)にする

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る