質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Ruby

    7907questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7465questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    337questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

2.2.2の配下に2.2.0ディレクトリがあるのはおかしいですか?usr/local/var/rbenv/versions/2.2.2/lib/ruby/2.2.0/rubygems/

受付中

回答 4

投稿

  • 評価
  • クリップ 2
  • VIEW 817

cDm_48

score 164

rbenvを使用し、rubyのバージョンを管理しております。

これまでずっと2.2.0を使用しており、最近2.2.2をインストールしました。

そしてこのたび、2.2.2のrubyバージョンにて、とあるgemをインストールしました。

そのgemの公式ドキュメントの手順ではその後、ターミナルで init をするとのことだったので、
行ったところ以下のようなエラーがでてきました。

from /usr/local/var/rbenv/versions/2.2.2/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'

あまりrbenvに詳しくないのですが、2.2.2のバージョン配下に2.2.0ディレクトリがあることからのエラーなのかと思い調査していたのですが、よくわかりませんでした。

そもそも、それが原因なのか、また他に原因があるのかわからない状態です。

以上をふまえて、原因がお分かりの方がいらっしゃいましたらご教示願えますでしょうか?

宜しくお願いします。


※gemは個人開発者のでしたので、今回は名前を控えさせて頂きます。
  特にgithubのissueとかにはバグ報告みたいなのはなかったです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 4

+2

とあるgemをインストール
とのことで、詳細が分からない状況で具体的に回答するのは困難ですが…

まず、rbenv を使用していて
2.2.2のバージョン配下に2.2.0ディレクトリがあること
は正常な状態だと思います。

でもって、require に失敗した…という限られたキーワードからたどり着いた情報では、どうやら rubyのバージョンアップに伴う以下の 仕様変更 が原因のようです。

Ruby 1.9.2から$LOAD_PATHにカレントディレクトリが含まれなくなった

ところで、
その後、ターミナルで init をするとのことだったので、行った
というのは、具体的には以下のコマンドを実行したということですか?

$ ruby init.rb

もしそうであれば、試しに ダメ元 で以下を実行してみてください。

$ ruby -I. init.rb

万が一、これでインストール作業が完了したとしても、その とあるgem がうまく稼働するという保証はありませんけれども… つまり、そもそも、その とあるgem の 稼働条件 はどうなっているのでしょうか?

まぁ、本来は、gemの開発者ご本人に質問&フィードバックするのが筋でしょうね。
あるいは、もっと頑張ってみたければ
  • 一旦rubyのバージョンを下げてrubyのバージョンに依存した不具合なのか確認してみる
  • gemのソースをgrepし、保証外であることを覚悟の上でrequireしている箇所を修正してみる
とか。

問題解決の一助になれば幸いです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

Rubyでは、"lib/ruby"以下にライブラリを置くときに
バージョン番号のフォルダを作成し、バージョン毎に分けておくという決まりがあります。
これはRubyのバージョンを上げたときに、新しいバージョンに
対応していない(または修正されていない)ライブラリを誤って使用して、
混乱しないようにするためです。
これは標準ライブラリもgemも同じです。

では、2.2.2を入れてるはずなのになぜ2.2.0かというと、
互換性があるバージョン毎にわけるというきまりになっているからです。
Ruby 2.1.0からセマンティックバージョニングを採用しています。
これは2.1や2.2の部分が同じであれば互換性があるというバージョンの付け方になっています。
なので、2.1.xであれば代表して2.1.0を、2.2.xであれば代表して2.2.0を
さきほどの"lib/ruby"以下に置くときのバージョンとして採用するようにし、
わざわざ毎回ライブラリを入れなくても済むようにしています。
※入れなくてもすむのはrbenv等を使わずに/usr/local等へ普通に入れたときの話です。

以上の通り、2.2.2だと2.2.0配下にライブラリが入るのが正常な動作ということです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

私の艦橋 (Mac, rbenv,) では、
/Users/katoy/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/rails-4.2.3
という場所に rails が入っています。
" ... 2.2.2の配下に2.2.0ディレクトリがあるのはおかしい..." という事は無いと思います。


投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

他の方の回答の通り2.2.0というのは正常です。
2.2.x は新しいため、まだ動かないgemが色々あるようです。せっかくrbenvを使っているのですから、他のバージョンでためして見ましょう。2.1.6とか。

あと、そのgemが何時の物か。かなり古いようだと、pi-chanさんが書かれている通り、
どうやら rubyのバージョンアップに伴う以下の 仕様変更 が原因のようです。 
が原因かもしれません。そうすると、1.8.7とか1.9.1に落とさないといけないかも。サポート切れですが。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7907questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7465questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    337questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

  • トップ
  • Rubyに関する質問
  • 2.2.2の配下に2.2.0ディレクトリがあるのはおかしいですか?usr/local/var/rbenv/versions/2.2.2/lib/ruby/2.2.0/rubygems/