質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

解決済

matplotlibのエラー

yokookentarou
yokookentarou

総合スコア11

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

1回答

0評価

0クリップ

15507閲覧

投稿2018/07/24 10:35

編集2018/07/24 10:50

from

from xml.dom import minidom import collections import os import matplotlib.pyplot as plt import matplotlib as matplot import seaborn as sns %matplotlib inline ```--------------------------------------------------------------------------- ModuleNotFoundError Traceback (most recent call last) <ipython-input-34-2ef533d57cc9> in <module>() 5 import os 6 ----> 7 import matplotlib.pyplot as plt 8 import matplotlib as matplot 9 import seaborn as sns ModuleNotFoundError: No module named 'matplotlib' 上記のコードを打ち込むと ModuleNotFoundError: No module named 'matplotlib' とエラーが出てしまう 環境としてはmacOS High Sierra バージョン10.13.5です pythonでpip install matplotlibを読み込ませ、installしたのですが、変わらず 上記のエラーが出てしまうのですが、どのようにすれば改善できるのでしょうか? よろしくお願いします。 ・環境構築に関しては、ネットからanacondaをインストールしました。 今回githubで参考にしているのですがその途中でエラーが出てしまいました。 参考URLはこちらになります https://github.com/sekilab/RoadDamageDetector/blob/master/RoadDamageDatasetTutorial.ipynb ・ターミナルでpip show matplotlibと実行した結果 ```Name: matplotlib Version: 2.2.2 Summary: Python plotting package Home-page: http://matplotlib.org Author: John D. Hunter, Michael Droettboom Author-email: matplotlib-users@python.org License: BSD Location: /anaconda3/lib/python3.6/site-packages Requires: numpy, cycler, pyparsing, python-dateutil, pytz, six, kiwisolver Required-by: seaborn, scikit-image コード

・jupyter notebook上でimport sys;print(sys.version);print(sys.path)と実行した結果

3.6.6

[GCC 4.2.1 Compatible Clang 4.0.1 (tags/RELEASE_401/final)] ['', '/anaconda3/envs/TensorFlow2/lib/python36.zip', '/anaconda3/envs/TensorFlow2/lib/python3.6', '/anaconda3/envs/TensorFlow2/lib/python3.6/lib-dynload', '/anaconda3/envs/TensorFlow2/lib/python3.6/site-packages', '/anaconda3/envs/TensorFlow2/lib/python3.6/site-packages/IPython/extensions', '/Users/yokookentarou/.ipython'] コード

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

tachikoma

2018/07/24 11:11

ターミナルでsource activate TensorFlow2を実行できます?

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Python 3.x

Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

Python

Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。