質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Python 3.x

    7456questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Django

    1190questions

    DjangoはPythonで書かれた、オープンソースウェブアプリケーションのフレームワークです。複雑なデータベースを扱うウェブサイトを開発する際に必要な労力を減らす為にデザインされました。

  • Heroku

    951questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

HerokuにDjangoアプリをデプロイできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 225

ymhr1121

score 2

 前提・実現したいこと

Django Girsのチュートリアル
に沿って、git pushコマンドにて
Herokuにデプロイをしたのですが、エラーとなり解決できません。

 発生している問題・エラーメッセージ

C:\Users\xxxx\PycharmProjects\djangogirls>git push heroku master
Enumerating objects: 26, done.
Counting objects: 100% (26/26), done.
Delta compression using up to 4 threads.
Compressing objects: 100% (23/23), done.
Writing objects: 100% (26/26), 7.68 KiB | 393.00 KiB/s, done.
Total 26 (delta 0), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote:
remote: -----> Python app detected
remote:  !     The latest version of Python 3 is python-3.6.6 (you are using Pyt
hon 3.6.6, which is unsupported).
remote:  !     We recommend upgrading by specifying the latest version (python-3
.6.6).
remote:        Learn More: https://devcenter.heroku.com/articles/python-runtimes

remote: -----> Installing Python 3.6.6
remote:  !     Requested runtime (Python 3.6.6) is not available for this stack
(heroku-16).
remote:  !     Aborting.  More info: https://devcenter.heroku.com/articles/pytho
n-support
remote:  !     Push rejected, failed to compile Python app.
remote:
remote:  !     Push failed
remote: Verifying deploy...
remote:
remote: !       Push rejected to ancient-earth-27024.
remote:
To https://git.heroku.com/ancient-earth-27024.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/ancient-earth-27024.g
it'

 該当のソースコード

参考までにgit init ~ git pushの手前までに実行したコマンドを記載します

C:\Users\XXXX\PycharmProjects\djangogirls>git init
Initialized empty Git repository in C:/Users/XXXX/PycharmProjects/djangogirls
/.git/

C:\Users\XXXX\PycharmProjects\djangogirls>git config user.name "XXXX Yamah
ara"

C:\Users\XXXX\PycharmProjects\djangogirls>git config user.email xxxx@gmai
l.com

C:\Users\XXXX\PycharmProjects\djangogirls>git status
On branch master

No commits yet

Untracked files:
(use "git add <file>..." to include in what will be committed)

.gitignore
.idea/
Procfile
blog/
manage.py
mysite/
requirements.txt
runtime.txt

nothing added to commit but untracked files present (use "git add" to track)

C:\Users\XXXX\PycharmProjects\djangogirls>heroku create
Creating app... done, ⬢ boiling-depths-63630
https://boiling-depths-63630.herokuapp.com/ | https://git.heroku.com/boiling-dep
ths-63630.git

C:\Users\XXXX\PycharmProjects\djangogirls>git push heroku master
error: src refspec master does not match any.
error: failed to push some refs to 'https://git.heroku.com/boiling-depths-63630.
git'

C:\Users\XXXX\PycharmProjects\djangogirls>git add -A .

C:\Users\XXXX\PycharmProjects\djangogirls>git commit -m "My Django Girls app"

[master (root-commit) 06c74d4] My Django Girls app
22 files changed, 601 insertions(+)
create mode 100644 .gitignore
create mode 100644 .idea/djangogirls.iml
create mode 100644 .idea/misc.xml
create mode 100644 .idea/modules.xml
create mode 100644 .idea/vcs.xml
create mode 100644 .idea/workspace.xml
create mode 100644 Procfile
create mode 100644 blog/init.py
create mode 100644 blog/admin.py
create mode 100644 blog/apps.py
create mode 100644 blog/migrations/0001_initial.py
create mode 100644 blog/migrations/init.py
create mode 100644 blog/models.py
create mode 100644 blog/tests.py
create mode 100644 blog/views.py
create mode 100644 manage.py
create mode 100644 mysite/init.py
create mode 100644 mysite/settings.py
create mode 100644 mysite/urls.py
create mode 100644 mysite/wsgi.py
create mode 100644 requirements.txt
create mode 100644 runtime.txt

 試したこと

最初、Python 3.6.5でエラーが出たため、
3.6.6にバージョンアップしましたが、それでも上記のエラーが出ています。
3.7.0にバージョンアップしても同じエラーになりました。

 補足情報(FW/ツールのバージョンなど)

Widows7
Python 3.6.6
Heroku CLI
git for windows 2.18.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • pumper

    2018/07/07 14:50

    runtime.txtとrequirements.txtの詳細を貼ってください.

    キャンセル

回答 1

check解決した方法

0

以下の通り実施したところ正常にデプロイできました。
質問を見ていただいた方、申し訳ありませんでした。

  • djangoのプロジェクトからやり直し
  • psycopg2をインストール
  • 最新のpsycopg2は、Windows版Pythonでは32bit版3.6.6にまでしか対応していないため、
    32bit版3.6.6で作業を進める

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Python 3.x

    7456questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

  • Django

    1190questions

    DjangoはPythonで書かれた、オープンソースウェブアプリケーションのフレームワークです。複雑なデータベースを扱うウェブサイトを開発する際に必要な労力を減らす為にデザインされました。

  • Heroku

    951questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。