質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.33%

  • Python 3.x

    7409questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

pyperclipのNot Implemented Error(Mac)

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 316

cpp335

score 2

 前提・実現したいこと

pyperclipが使いたいのですが、うまくコピーとペーストができません。

下記のサイトを見ましたが、4つの対策をどうやって実現すればよいのかがわかりません。
ターミナルからvagrantを起動して、.pyファイルを呼び出していますが、下記のエラーコードがでます。

https://pyperclip.readthedocs.io/en/latest/introduction.html#not-implemented-error

sudo apt-get install xsel to install the xsel utility.
sudo apt-get install xclip to install the xclip utility.
pip install gtk to install the gtk Python module.
pip install PyQt4 to install the PyQt4 Python module.

 発生している問題・エラーメッセージ

Traceback (most recent call last):
  File "clip1.py", line 2, in <module>
    pyperclip.copy("hello")
  File "/home/vagrant/.pyenv/versions/3.5.2/lib/python3.5/site-packages/pyperclip/__init__.py", line 595, in lazy_load_stub_copy
    return copy(text)
  File "/home/vagrant/.pyenv/versions/3.5.2/lib/python3.5/site-packages/pyperclip/__init__.py", line 284, in __call__
    raise PyperclipException(EXCEPT_MSG)
pyperclip.PyperclipException: 
    Pyperclip could not find a copy/paste mechanism for your system.
    For more information, please visit https://pyperclip.readthedocs.io/en/latest/introduction.html#not-implemented-error 

 該当のソースコード

import pyperclip
pyperclip.copy("hello")
print(pyperclip.paste())

 試したこと

pip install PyQt4 やpip install gtkでは下記のエラーがでました。

Could not find a version that satisfies the requirement PyQt4 (from versions: )
No matching distribution found for PyQt4

 補足情報(FW/ツールのバージョンなど)

python3.5.2
Mac OS high sierra
mac book pro

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hayataka2049

    2018/05/24 22:18

    あんまり関係ないと思います

    キャンセル

  • cpp335

    2018/05/24 23:06

    エラーコードにあった__init__.pyファイルを開いて読んでみると 下記の文面が最初にありました。python3とmacでは使えないんでしょうかね。pbcopy、pbpasteの方法を探して見ます。On Windows, no additional modules are needed. On Mac, the pyobjc module is used, falling back to the pbcopy and pbpaste cli commands. (These commands should come with OS X.). On Linux, install xclip or xsel via package manager. For example, in Debian: sudo apt-get install xclip sudo apt-get install xsel Otherwise on Linux, you will need the gtk or PyQt5/PyQt4 modules installed. gtk and PyQt4 modules are not available for Python 3,

    キャンセル

  • quiqui

    2018/05/29 17:55

    vagrantで動かしているんだったら、pythonから見たときのOSは仮想マシンです。もしそうなら仮想マシンにはクリップボードの機構がないですから動きませんよね。

    キャンセル

回答 1

checkベストアンサー

0

とりあえず「pip install gtk」と「pip install PyQt4」を打ってみましょう。環境構築によって微妙にコマンドが違ってpipがpip3だったりsudo pipだったりするかもしれませんが、pyperclipを入れたときと同様にインストールしてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/24 22:10

    回答ありがとうございます。
    コマンド変えましたが上記のエラーがでます。

    キャンセル

  • 2018/05/24 22:12

    とりあえずインストールには成功しましたか?

    キャンセル

  • 2018/05/24 22:14

    いえ。上記のエラーコード以外には何もでないのでインストールされていないように思います。

    キャンセル

  • 2018/05/24 22:19 編集

    いえ、pipコマンドでインストールしたときの出力を教えてください

    キャンセル

  • 2018/05/24 22:22

    pyperclipをインストールした際のコメントはすみません。残っていません。
    gtkとPyQt4pip installのコマンドをうつと下記のように表示されます。
    Could not find a version that satisfies the requirement PyQt4 (from versions: )
    No matching distribution found for PyQt4

    キャンセル

  • 2018/05/24 22:56

    PyQtおよびgtkのmacへのインストール方法は検索すると出てきます。ただ、それでうまくいくかという疑問が私の中で生じてきたので、もしダメだったらご了承ください。
    一応手順としては、両方入れてpyperclipを再インストールしてみる感じだと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Python 3.x

    7409questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。