質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • MacOS(OSX)

    1972questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • Python 2.7

    1318questions

    Python 2.7は2.xシリーズでは最後のメジャーバージョンです。Python3.1にある機能の多くが含まれています。

  • pip

    183questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。

pipによるパッケージインストールについてのエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,543

4mmsod

score 9

pipを利用してScrapyというフレームワークをインストールしようと試みたのですが、ディレクトリが作成できないといった旨のエラーが発生してしまいます。
初歩的な質問で申し訳ございませんが解決法ご存知の方お願いします。

OS X 
Python2.7.10
pip6.1.1
root権限なし

コマンド:pip install Scrapy

エラー:
error: could not create '/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/cssselect': Permission denied

Command "/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python -c "import setuptools, tokenize;file='/private/var/folders/nx/shl94qgs273ct34v53m4wtg80000gp/T/pip-build-GZlQIu/cssselect/setup.py';exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))" install --record /var/folders/nx/shl94qgs273ct34v53m4wtg80000gp/T/pip-agXu7p-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/nx/shl94qgs273ct34v53m4wtg80000gp/T/pip-build-GZlQIu/cssselect
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

「ルート権限なし」とのことですが、実行したときの状態でしょうか、それともあなたの権限範囲でしょうか。もしroot権限(あるいは管理権限)をとれるなら、sudoをつけて実行すればインストールできると思います。。

諸事情でroot権限が無い(パスワードを知ることができない)状態なら、virtualenvを使うことをお勧めします。これを使うとpythonの実行環境(パッケージ環境)を自分のhome/以下に作れるので、root権限が不要ですし、仮想環境に入ったあとはそのことを意識する必要がありません。

(wgetで取得するとtar.gzだったりして面倒なのでpip install --targetを使っています)

$ pip install --target ./my-site-packages virtualenv
$ python my-site-packages/virtualenv.py ./venv     # ./venvに仮想環境を作る
$ source ./venv/bin/activate                                   # 仮想環境に入る
(venv)$ python --version
Python 3.4.3
(venv)$ pip install Scrapy                                       # 仮想環境の中なので権限云々のエラーは出ない
Collecting Scrapy
...
(venv)$ scrapy startproject helloscrapy
...
AttributeError: 'dict' object has no attribute 'itervalues'
(venv)$ deactivate                                                  # 仮想環境から抜ける
$ 

オチじゃないですが、ScrapyはPython3系には対応してないっぽいので注意してください。OSXなら最初から2.7が入っていたと思うので大丈夫です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

関連した質問

同じタグがついた質問を見る

  • MacOS(OSX)

    1972questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • Python 2.7

    1318questions

    Python 2.7は2.xシリーズでは最後のメジャーバージョンです。Python3.1にある機能の多くが含まれています。

  • pip

    183questions

    pipとは、Pythonを用いて書かれているパッケージソフトのインストールや管理を行うためのパッケージマネジメントシステムです。pipを使う主なメリットは、コマンドラインインターフェースにて容易にPythonパッケージソフトをインストール可能だという点です。