質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Python

    6915questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Cloud9

    385questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

AWS cloud9においてpythonでccxt利用したいがエラーになる

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,173

norixi

score 8

AWS cloud9においてpythonでccxt利用したいがエラーになる

aws cloud9においてpythonでccxt利用したく、
設定をしていますがエラーがでて進みません。

 発生している問題・エラーメッセージ

sudo pip-3.6 install ccxt

You are using pip version 9.0.1, however version 9.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

 試したこと

pip install --upgrade pip を実行したところ、以下エラーが発生

Requirement already up-to-date: pip in /usr/local/lib/python2.7/site-packages

 補足情報(FW/ツールのバージョンなど)

pip version 9.0.2にアップグレードせよとのメッセージで、
upgradeしようとしても、 /usr/local/lib/python2.7/site-packages に
既に設定済み…というメッセージとの理解ですが、この後の対応が不明

envを見て、phthonに関する記述で
PWD=/usr/lib/python2.7/dist-packages
があったので、
PWD=/usr/local/lib/python2.7/site-packages
としてみたのですが動作は変わらずでした。

もし対応策がお分かりになるようであれば、
ご教授頂けると助かります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

pip install --upgrade pipだとpython2pipをアップグレードしています。

動作未検証ですが
sudo pip-3.6 install --upgrade pip あるいは
sudo python3.6(ここは環境による) -m pip install --upgrade pip
でどうでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/20 09:37

    早々にコメントありがとうございます。
    無事にupgradeできました。助かります。

    ただ、その後、ccxtを入れようとしたら、
    今度はpip=9.0.1が無い…とエラーが出てしまいました。
    また別事象なので、別Qをあげるべきですね。

    ***********
    Traceback (most recent call last):
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 666, in _build_master
    ws.require(__requires__)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 984, in require
    needed = self.resolve(parse_requirements(requirements))
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 875, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
    pkg_resources.VersionConflict: (pip 9.0.2 (/usr/local/lib/python3.6/site-packages), Requirement.parse('pip==9.0.1'))

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/usr/bin/pip-3.6", line 6, in <module>
    from pkg_resources import load_entry_point
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3147, in <module>
    @_call_aside
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3131, in _call_aside
    f(*args, **kwargs)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3160, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 668, in _build_master
    return cls._build_from_requirements(__requires__)
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 681, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
    File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 870, in resolve
    raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'pip==9.0.1' distribution was not found and is required by the application

    キャンセル

  • 2018/03/20 09:45

    pipではなくccxtインストール時のエラーであれば別途質問立てた方がよいかもですね。

    キャンセル

  • 2018/03/20 09:48

    ですね<別途質問

    再びコメントありがとうございます。
    本当に助かります。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    6915questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Cloud9

    385questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。